Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] ThinkPad Z60m+VirtualBox 4.1.22+iPhone 4S=BOGUS urb
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
wagglet
n00b
n00b


Joined: 12 Oct 2012
Posts: 4
Location: Rotorua, New Zealand

PostPosted: Fri Oct 12, 2012 11:33 pm    Post subject: [SOLVED] ThinkPad Z60m+VirtualBox 4.1.22+iPhone 4S=BOGUS urb Reply with quote

Hi all

This is driving me mad...is anyone please able to help? I am new (couple of months) to Gentoo but have been a SuSE/openSuSE user since version 6.2. I'm sorry this is such a l-o-n-g post but I'm trying to be thorough as suggested in the FAQs :-/
My symptoms look very much like those described here: http://forums.gentoo.org/viewtopic-t-908384-highlight-iphone.html but the solution is ?not appropriate for me.
I've tried to provide as much relevant information as possible - I'll gladly post anything I've missed out, just let me know :-)

My system:
IBM ThinkPad Z60m 2530-3JM running Gentoo x86 Kernel 3.3.8, fully up-to-date. This is the only computer I have and it solely runs Gentoo.
GNOME 2.x
VirtualBox 4.1.22 with all extensions & modules
Windows XP SP3 Guest running iTunes 10.7
iPhone 4S, iOS6 connected via USB

Desired behaviour:
Linux effectively ignores my iPhone and lets iTunes handle it from within a VirtualBox VM. This used to work flawlessly under openSuSE 11.4, iOS5.1.1, including Firmware updates. Exactly the same hardware, down to the USB cables. I also ported the entire VM I was using before (that worked) into my Gentoo system, so the innards of the VM are also identical. I'm not interested in having current Linux tools manage my iPhone at this time.

What happens:
GVFS detects my iPhone camera and will allow me to view / download photos from my Camera Roll (well, it did before I started deliberately removing anything iDevice/iOS-related from the kernel / USE flags etc.). iPhone unmounts successfully.
VirtualBox detects iPhone USB Device and applies USB filter (configured for all Vendor IDs=05ac)
Apple Device Driver in XP Guest loads fine 99 percent of the time; the other 1 percent it errors in Device Manager but the iPhone does briefly appear in iTunes (but I cannot do anything with it).
iTunes does not recognise my iPhone at all 99 percent of the time.
Plugging the iPhone in prior to booting the VM or manually connecting the USB Device after boot makes no difference.
I get PAGES of these errors in /var/log/messages:
Code:

Oct 13 01:23:22 localhost kernel: [  327.214306] usb 1-3.2: usbfs: usb_submit_urb returned -22
Oct 13 01:23:23 localhost kernel: [  328.230316] usb 1-3.2: BOGUS urb flags, 1 --> 0


System settings
Output of emerge --info:
Code:

Portage 2.1.11.9 (default/linux/x86/10.0/desktop/gnome, gcc-4.5.4, glibc-2.15-r2, 3.3.8-gentoo i686)
=================================================================
System uname: Linux-3.3.8-gentoo-i686-Intel-R-_Pentium-R-_M_processor_2.00GHz-with-gentoo-2.1
Timestamp of tree: Fri, 12 Oct 2012 08:30:01 +0000
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="rsync://rsync.au.gentoo.org/gentoo/ rsync://rsync.us.gentoo.org/gentoo/"
LANG="en_NZ.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_US"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa avahi berkdb bluetooth branding bzip2 cairo cdda cdr cli colord consolekit corefonts cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran gdbm gif gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk gtk3 handbook hdaps iconv ipv6 jpeg kde latex lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap nautilus ncurses networkmanager nls nptl ogg opengl openmp pam pango pcre pdf png policykit postscript ppds pppd pulseaudio python qt3support qt4 readline sdl session socialweb spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upnp upower usb vorbis wxwidgets x264 x86 xcb xml xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


VirtualBox software versions, USE flags, etc:
Code:

app-emulation/virtualbox-4.1.22  USE="additions alsa doc extensions java opengl pam pulseaudio python qt4 sdk -headless -vboxwebsrv -vnc"
app-emulation/virtualbox-modules-4.1.22  USE="-pax_kernel"
app-emulation/virtualbox-additions-4.1.22
app-emulation/virtualbox-extpack-oracle-4.1.22


Output of eix --installed libusb:
Code:

[I] dev-libs/libusb
     Available versions: 
   (0)   0.1.12-r7^t
   (1)   1.0.9
   {{+cxx debug doc static-libs}}
     Installed versions:  1.0.9(1)(04:56:30 31/08/12)(-debug -doc -static-libs)
     Homepage:            http://libusb.org/
     Description:         Userspace access to USB devices

[I] dev-libs/libusb-compat
     Available versions:  0.1.4 {{debug static-libs}}
     Installed versions:  0.1.4(17:08:26 04/10/12)(-debug -static-libs)
     Homepage:            http://libusb.sourceforge.net/
     Description:         Userspace access to USB devices (libusb-0.1 compat wrapper)

[I] virtual/libusb
     Available versions: 
   (0)   0
   (1)   1
     Installed versions:  0(10:23:45 02/09/12) 1(1)(04:56:36 31/08/12)
     Description:         Virtual for libusb

Found 3 matches.


Output of equery d libusb:
Code:

 * These packages depend on libusb:
app-admin/system-config-printer-common-1.3.9-r2 (virtual/libusb:0)
app-crypt/gnupg-2.0.19 (usb ? virtual/libusb:0)
app-mobilephone/obex-data-server-0.4.5 (usb ? virtual/libusb:0)
dev-libs/libgusb-0.1.3 (virtual/libusb:1)
dev-libs/libusb-compat-0.1.4 (virtual/libusb:1)
dev-libs/openobex-1.5 (usb ? virtual/libusb:0)
kde-base/systemsettings-4.8.5 (usb ? virtual/libusb:0)
media-gfx/gphoto2-2.4.14 (virtual/libusb:0)
media-gfx/iscan-2.26.2 (virtual/libusb:0)
media-gfx/sane-backends-1.0.22-r1 (usb ? virtual/libusb:0)
media-libs/libgphoto2-2.4.14 (virtual/libusb:0)
net-print/cups-1.5.2-r4 (usb ? virtual/libusb:0)
net-wireless/bluez-4.99 (usb ? virtual/libusb:0)
sys-apps/usbutils-006 (virtual/libusb:1)
sys-auth/libfprint-0.4.0 (virtual/libusb:1)
sys-fs/udev-171-r6 (extras ? virtual/libusb:0)
                   (action_modeswitch ? virtual/libusb:0)
sys-power/upower-0.9.16 (virtual/libusb:1)
virtual/libusb-0 (>=dev-libs/libusb-0.1.12-r7:0)
virtual/libusb-1 (>=dev-libs/libusb-1.0.9:1)


Output in /var/log/messages when connecting iPhone (no VirtualBox running):
Code:

Oct 13 11:57:19 localhost kernel: [11024.722352] usb usb1: usb wakeup-resume
Oct 13 11:57:19 localhost kernel: [11024.722364] usb usb1: usb auto-resume
Oct 13 11:57:19 localhost kernel: [11024.722371] ehci_hcd 0000:00:1d.7: resume root hub
Oct 13 11:57:19 localhost kernel: [11024.772270] hub 1-0:1.0: hub_resume
Oct 13 11:57:19 localhost kernel: [11024.772300] ehci_hcd 0000:00:1d.7: GetStatus port:2 status 001803 0  ACK POWER sig=j CSC CONNECT
Oct 13 11:57:19 localhost kernel: [11024.772310] hub 1-0:1.0: port 2: status 0501 change 0001
Oct 13 11:57:19 localhost kernel: [11024.875755] hub 1-0:1.0: state 7 ports 8 chg 0004 evt 0000
Oct 13 11:57:19 localhost kernel: [11024.875775] hub 1-0:1.0: port 2, status 0501, change 0000, 480 Mb/s
Oct 13 11:57:19 localhost kernel: [11024.929162] ehci_hcd 0000:00:1d.7: port 2 high speed
Oct 13 11:57:19 localhost kernel: [11024.929178] ehci_hcd 0000:00:1d.7: GetStatus port:2 status 001005 0  ACK POWER sig=se0 PE CONNECT
Oct 13 11:57:19 localhost kernel: [11024.982275] usb 1-2: new high-speed USB device number 7 using ehci_hcd
Oct 13 11:57:19 localhost kernel: [11025.035913] ehci_hcd 0000:00:1d.7: port 2 high speed
Oct 13 11:57:19 localhost kernel: [11025.035928] ehci_hcd 0000:00:1d.7: GetStatus port:2 status 001005 0  ACK POWER sig=se0 PE CONNECT
Oct 13 11:57:19 localhost kernel: [11025.107061] usb 1-2: skipped 3 descriptors after interface
Oct 13 11:57:19 localhost kernel: [11025.107071] usb 1-2: skipped 2 descriptors after interface
Oct 13 11:57:19 localhost kernel: [11025.107079] usb 1-2: skipped 1 descriptor after endpoint
Oct 13 11:57:19 localhost kernel: [11025.107086] usb 1-2: skipped 1 descriptor after interface
Oct 13 11:57:19 localhost kernel: [11025.108174] usb 1-2: default language 0x0409
Oct 13 11:57:19 localhost kernel: [11025.109694] usb 1-2: udev 7, busnum 1, minor = 6
Oct 13 11:57:19 localhost kernel: [11025.109702] usb 1-2: New USB device found, idVendor=05ac, idProduct=12a0
Oct 13 11:57:19 localhost kernel: [11025.109709] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Oct 13 11:57:19 localhost kernel: [11025.109716] usb 1-2: Product: iPhone
Oct 13 11:57:19 localhost kernel: [11025.109722] usb 1-2: Manufacturer: Apple Inc.
Oct 13 11:57:19 localhost kernel: [11025.109728] usb 1-2: SerialNumber: e4c28a8dc9583eb6cff868804208645251df968b
Oct 13 11:57:19 localhost kernel: [11025.109927] usb 1-2: usb_probe_device
Oct 13 11:57:19 localhost kernel: [11025.109936] usb 1-2: configuration #1 chosen from 4 choices


Output of lsusb (with iPhone connected):
Code:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 006: ID 05ac:12a0 Apple, Inc. iPhone 4S
Bus 003 Device 002: ID 04b3:3107 IBM Corp. ThinkPad 800dpi Optical Travel Mouse
Bus 004 Device 002: ID 0a5c:2110 Broadcom Corp. Bluetooth Controller
Bus 004 Device 003: ID 0483:2016 SGS Thomson Microelectronics Fingerprint Reader


Output of grep -i usb /usr/src/linux/.config:
Code:

CONFIG_BT_HCIBTUSB=y
# CONFIG_BT_HCIBFUSB is not set
# CONFIG_USB_SWITCH_FSA9480 is not set
# USB Network Adapters
# CONFIG_USB_CATC is not set
# CONFIG_USB_KAWETH is not set
# CONFIG_USB_PEGASUS is not set
# CONFIG_USB_RTL8150 is not set
# CONFIG_USB_USBNET is not set
# CONFIG_USB_HSO is not set
# CONFIG_USB_IPHETH is not set
# CONFIG_AT76C50X_USB is not set
# CONFIG_USB_ZD1201 is not set
# CONFIG_USB_NET_RNDIS_WLAN is not set
# CONFIG_I2C_TINY_USB is not set
CONFIG_SND_USB=y
CONFIG_SND_USB_AUDIO=y
# CONFIG_SND_USB_UA101 is not set
# CONFIG_SND_USB_USX2Y is not set
# CONFIG_SND_USB_CAIAQ is not set
# CONFIG_SND_USB_US122L is not set
# CONFIG_SND_USB_6FIRE is not set
# USB Input Devices
CONFIG_USB_HID=y
CONFIG_USB_HIDDEV=y
CONFIG_USB_SUPPORT=y
CONFIG_USB_COMMON=y
CONFIG_USB_ARCH_HAS_HCD=y
CONFIG_USB_ARCH_HAS_OHCI=y
CONFIG_USB_ARCH_HAS_EHCI=y
CONFIG_USB_ARCH_HAS_XHCI=y
CONFIG_USB=y
CONFIG_USB_DEBUG=y
CONFIG_USB_ANNOUNCE_NEW_DEVICES=y
# Miscellaneous USB options
# CONFIG_USB_DEVICEFS is not set
# CONFIG_USB_DEVICE_CLASS is not set
# CONFIG_USB_DYNAMIC_MINORS is not set
CONFIG_USB_SUSPEND=y
# CONFIG_USB_OTG is not set
CONFIG_USB_MON=y
CONFIG_USB_WUSB_CBAF=y
# CONFIG_USB_WUSB_CBAF_DEBUG is not set
# USB Host Controller Drivers
# CONFIG_USB_C67X00_HCD is not set
# CONFIG_USB_XHCI_HCD is not set
CONFIG_USB_EHCI_HCD=y
CONFIG_USB_EHCI_ROOT_HUB_TT=y
CONFIG_USB_EHCI_TT_NEWSCHED=y
# CONFIG_USB_EHCI_MV is not set
# CONFIG_USB_OXU210HP_HCD is not set
# CONFIG_USB_ISP116X_HCD is not set
# CONFIG_USB_ISP1760_HCD is not set
# CONFIG_USB_ISP1362_HCD is not set
# CONFIG_USB_OHCI_HCD is not set
CONFIG_USB_UHCI_HCD=y
# CONFIG_USB_SL811_HCD is not set
# CONFIG_USB_R8A66597_HCD is not set
# USB Device Class drivers
CONFIG_USB_ACM=m
CONFIG_USB_PRINTER=y
CONFIG_USB_WDM=m
# CONFIG_USB_TMC is not set
# NOTE: USB_STORAGE depends on SCSI but BLK_DEV_SD may
# also be needed; see USB_STORAGE Help for more info
CONFIG_USB_STORAGE=y
# CONFIG_USB_STORAGE_DEBUG is not set
# CONFIG_USB_STORAGE_REALTEK is not set
# CONFIG_USB_STORAGE_DATAFAB is not set
# CONFIG_USB_STORAGE_FREECOM is not set
# CONFIG_USB_STORAGE_ISD200 is not set
# CONFIG_USB_STORAGE_USBAT is not set
# CONFIG_USB_STORAGE_SDDR09 is not set
# CONFIG_USB_STORAGE_SDDR55 is not set
# CONFIG_USB_STORAGE_JUMPSHOT is not set
# CONFIG_USB_STORAGE_ALAUDA is not set
# CONFIG_USB_STORAGE_ONETOUCH is not set
# CONFIG_USB_STORAGE_KARMA is not set
# CONFIG_USB_STORAGE_CYPRESS_ATACB is not set
# CONFIG_USB_STORAGE_ENE_UB6250 is not set
CONFIG_USB_UAS=m
# CONFIG_USB_LIBUSUAL is not set
# USB Imaging devices
# CONFIG_USB_MDC800 is not set
# CONFIG_USB_MICROTEK is not set
# USB port drivers
# CONFIG_USB_SERIAL is not set
# USB Miscellaneous drivers
# CONFIG_USB_EMI62 is not set
# CONFIG_USB_EMI26 is not set
# CONFIG_USB_ADUTUX is not set
# CONFIG_USB_SEVSEG is not set
# CONFIG_USB_RIO500 is not set
# CONFIG_USB_LEGOTOWER is not set
# CONFIG_USB_LCD is not set
# CONFIG_USB_LED is not set
# CONFIG_USB_CYPRESS_CY7C63 is not set
# CONFIG_USB_CYTHERM is not set
# CONFIG_USB_IDMOUSE is not set
# CONFIG_USB_FTDI_ELAN is not set
# CONFIG_USB_APPLEDISPLAY is not set
# CONFIG_USB_SISUSBVGA is not set
# CONFIG_USB_LD is not set
# CONFIG_USB_TRANCEVIBRATOR is not set
# CONFIG_USB_IOWARRIOR is not set
# CONFIG_USB_TEST is not set
# CONFIG_USB_ISIGHTFW is not set
# CONFIG_USB_YUREX is not set
# CONFIG_USB_GADGET is not set
# CONFIG_NOP_USB_XCEIV is not set


Lastly, in a fit of desperation, here's what udevadm info --attribute-walk --path=/devices/pci0000:00/0000:00:1d.7/usb1/1-3/1-3:1.0 gave:
Code:

<---snip--->
  looking at device '/devices/pci0000:00/0000:00:1d.7/usb1/1-3/1-3:1.0':
    KERNEL=="1-3:1.0"
    SUBSYSTEM=="usb"
    DRIVER=="usbfs"
    ATTR{bInterfaceNumber}=="00"
    ATTR{bAlternateSetting}==" 0"
    ATTR{bNumEndpoints}=="03"
    ATTR{bInterfaceClass}=="06"
    ATTR{bInterfaceSubClass}=="01"
    ATTR{bInterfaceProtocol}=="01"
    ATTR{supports_autosuspend}=="0"

  looking at parent device '/devices/pci0000:00/0000:00:1d.7/usb1/1-3':
    KERNELS=="1-3"
    SUBSYSTEMS=="usb"
    DRIVERS=="usb"
    ATTRS{configuration}=="PTP"
    ATTRS{bNumInterfaces}==" 1"
    ATTRS{bConfigurationValue}=="1"
    ATTRS{bmAttributes}=="c0"
    ATTRS{bMaxPower}=="500mA"
    ATTRS{urbnum}=="50"
    ATTRS{idVendor}=="05ac"
    ATTRS{idProduct}=="12a0"
    ATTRS{bcdDevice}=="0410"
    ATTRS{bDeviceClass}=="00"
    ATTRS{bDeviceSubClass}=="00"
    ATTRS{bDeviceProtocol}=="00"
    ATTRS{bNumConfigurations}=="4"
    ATTRS{bMaxPacketSize0}=="64"
    ATTRS{speed}=="480"
    ATTRS{busnum}=="1"
    ATTRS{devnum}=="9"
    ATTRS{devpath}=="3"
    ATTRS{version}==" 2.00"
    ATTRS{maxchild}=="0"
    ATTRS{quirks}=="0x0"
    ATTRS{avoid_reset_quirk}=="0"
    ATTRS{authorized}=="1"
    ATTRS{manufacturer}=="Apple Inc."
    ATTRS{product}=="iPhone"
    ATTRS{serial}=="e4c28a8dc9583eb6cff868804208645251df968b"

  looking at parent device '/devices/pci0000:00/0000:00:1d.7/usb1':
    KERNELS=="usb1"
    SUBSYSTEMS=="usb"
    DRIVERS=="usb"
    ATTRS{configuration}==""
    ATTRS{bNumInterfaces}==" 1"
    ATTRS{bConfigurationValue}=="1"
    ATTRS{bmAttributes}=="e0"
    ATTRS{bMaxPower}=="  0mA"
    ATTRS{urbnum}=="161"
    ATTRS{idVendor}=="1d6b"
    ATTRS{idProduct}=="0002"
    ATTRS{bcdDevice}=="0303"
    ATTRS{bDeviceClass}=="09"
    ATTRS{bDeviceSubClass}=="00"
    ATTRS{bDeviceProtocol}=="00"
    ATTRS{bNumConfigurations}=="1"
    ATTRS{bMaxPacketSize0}=="64"
    ATTRS{speed}=="480"
    ATTRS{busnum}=="1"
    ATTRS{devnum}=="1"
    ATTRS{devpath}=="0"
    ATTRS{version}==" 2.00"
    ATTRS{maxchild}=="8"
    ATTRS{quirks}=="0x0"
    ATTRS{avoid_reset_quirk}=="0"
    ATTRS{authorized}=="1"
    ATTRS{manufacturer}=="Linux 3.3.8-gentoo ehci_hcd"
    ATTRS{product}=="EHCI Host Controller"
    ATTRS{serial}=="0000:00:1d.7"
    ATTRS{authorized_default}=="1"

  looking at parent device '/devices/pci0000:00/0000:00:1d.7':
    KERNELS=="0000:00:1d.7"
    SUBSYSTEMS=="pci"
    DRIVERS=="ehci_hcd"
    ATTRS{vendor}=="0x8086"
    ATTRS{device}=="0x265c"
    ATTRS{subsystem_vendor}=="0x1014"
    ATTRS{subsystem_device}=="0x0566"
    ATTRS{class}=="0x0c0320"
    ATTRS{irq}=="19"
    ATTRS{local_cpus}=="1"
    ATTRS{local_cpulist}=="0"
    ATTRS{dma_mask_bits}=="32"
    ATTRS{consistent_dma_mask_bits}=="32"
    ATTRS{enable}=="1"
    ATTRS{broken_parity_status}=="0"
    ATTRS{msi_bus}==""
    ATTRS{companion}==""
    ATTRS{uframe_periodic_max}=="100"

  looking at parent device '/devices/pci0000:00':
    KERNELS=="pci0000:00"
    SUBSYSTEMS==""
    DRIVERS==""


My other USB devices, printer, scanner, USB Mass Storage, all work fine (from within Linux - I don't use them in VirtualBox, it's for iTunes and Office 2003 only).
Any clues anyone? Any assistance at all warmly appreciated. Thanks heaps in advance.

Desperately frustratedly yours,
Paul in NZ.
Back to top
View user's profile Send private message
wagglet
n00b
n00b


Joined: 12 Oct 2012
Posts: 4
Location: Rotorua, New Zealand

PostPosted: Sat Nov 10, 2012 3:50 am    Post subject: Reply with quote

Hi Forum

After a long wait, I finally got this going... For the benefit of anyone interested, the following sequence of events seemed to automagically make everything work again:-

  • Update to iOS 6.0.1 on my iPhone
  • Update to Kernel 3.5.7 from gentoo-sources stable (manually configured & compiled)
  • Install Intel microcode updater for my processor

When updating my Kernel, I loaded my 3.3.8 .config file and continued with 'make menuconfig' to double-check and tweak settings.
My /var/log/messages now has normal USB events reported and everything "just works."

I seem unable to post my actual working .config file but if anyone wants it I'll happily send.

Hopefully someone may find this of interest/use...
~P.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum