Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Is sys-apps/man-db broken for anyone else?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2306
Location: UK

PostPosted: Sat Nov 03, 2012 3:35 pm    Post subject: Is sys-apps/man-db broken for anyone else? Reply with quote

A few days ago I started getting an error every time I run `man`: "There is no -l option ("less --help" for help)". This happens on everything *but* a 32-bit chroot I have which is pretty out of date, next I'm going to see if updating that reproduces it. edit: it does

This is happening with every version of man-db in portage and I haven't changed any config files related to either program, so I'm at a loss why it suddenly stopped working.
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 2269
Location: Dallas area

PostPosted: Sat Nov 03, 2012 4:52 pm    Post subject: Reply with quote

I noticed problems with man-db (the mandb part) when I upgraded from 2.6.3 to 2.6.3-r1.

They put a file in /etc/cron.daily, which I removed, as it errored out every time it ran.

I also noticed that they changed permission on the man directories.

If you had put down the 2.6.3-r1 version then look at the ebuild to see what they changed.

Good luck
_________________
Asus m5a99fx, FX 8320 - amd64-multilib, 3.15.9-zen, glibc-2.17, gcc-4.7.3-r1, eudev
xorg-server-1.16, openbox w/lxpanel, nouveau, oss4
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum