Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Slot conflict
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Q-collective
Advocate
Advocate


Joined: 22 Mar 2004
Posts: 2056

PostPosted: Fri Nov 02, 2012 2:19 am    Post subject: [Solved] Slot conflict Reply with quote

So, when trying to update my world, since a few days I get this:

Code:
# emerge world -uDnav

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] net-misc/dhcpcd-5.6.2 [5.2.12] USE="zeroconf" 83 kB
[ebuild     U ~] dev-python/python-exec-0.1.1 [0.1] PYTHON_TARGETS="(jython2_5) (pypy1_8) (pypy1_9) (python2_5) (python2_6) (python2_7) (python3_1) (python3_2) (-python3_3)" 63 kB
[ebuild  N     ] virtual/python-argparse-0  PYTHON_TARGETS="python2_7 python3_2 -jython2_5 -pypy1_8 -pypy1_9 -python2_5 -python2_6 -python3_1 (-python3_3)" 0 kB
[ebuild  N     ] dev-libs/xerces-c-3.1.1-r1  USE="iconv icu sse2 -curl -doc -static-libs -threads" 4,933 kB
[ebuild     U ~] app-emulation/emul-linux-x86-baselibs-20121028 [20120520] USE="-development" 39,963 kB
[ebuild     U ~] app-emulation/emul-linux-x86-db-20121028 [20120520] USE="-development" 1,780 kB
[ebuild     U ~] dev-libs/libpcre-8.31 [8.30-r2] USE="bzip2 cxx jit readline recursion-limit (unicode) zlib -libedit% -pcre16 -static-libs" 1,228 kB
[ebuild     U  ] media-gfx/splashutils-1.5.4.4-r1 [1.5.4.4] USE="fbcondecor gpm mng png -hardened -truetype" 0 kB
[ebuild  NS    ] sys-kernel/gentoo-sources-3.5.7 [3.4.9] USE="-build -deblob -symlink" 0 kB
[ebuild     U ~] app-emulation/emul-linux-x86-opengl-20121028 [20120520] USE="-development" 46,612 kB
[ebuild     U ~] app-emulation/emul-linux-x86-xlibs-20121028 [20120520] USE="opengl -development" 2,426 kB
[ebuild     U ~] app-emulation/emul-linux-x86-medialibs-20121028 [20120520] USE="-development" 10,187 kB
[ebuild     U ~] app-emulation/emul-linux-x86-soundlibs-20121028 [20120520-r2] USE="alsa -development" 6,923 kB
[ebuild     U ~] app-emulation/emul-linux-x86-qtlibs-20121028 [20120520] USE="-development" 17,626 kB
[ebuild     U  ] sys-power/upower-0.9.18 [0.9.16] USE="introspection -debug -doc -ios (-systemd)" 395 kB
[ebuild     U ~] app-emulation/wine-1.5.16-r1 [1.5.16] USE="X alsa cups gecko jpeg lcms ldap mono mp3 ncurses nls opengl oss perl png scanner ssl threads truetype udisks v4l win32 win64 xcomposite xinerama xml -capi -custom-cflags -fontconfig -gnutls -gphoto2 -gsm (-gstreamer) -hardened -odbc -openal -opencl -osmesa -pulseaudio -samba (-selinux) -test (-osmesa-multilib%)" 0 kB
[ebuild     U  ] dev-libs/boost-1.49.0-r2 [1.49.0-r1] USE="icu -debug -doc -mpi -python -static-libs -tools (-eselect%*) (-test%)" 0 kB
[uninstall     ] app-admin/eselect-boost-0.4
[blocks b      ] app-admin/eselect-boost ("app-admin/eselect-boost" is blocking dev-libs/boost-1.49.0-r2)
[ebuild     U ~] app-text/sigil-0.6.0 [0.5.3] 12,606 kB
[ebuild     U ~] kde-base/plasma-workspace-4.9.2-r1 [4.9.2] USE="handbook rss semantic-desktop (-aqua) -debug -google-gadgets -gps -python -qalculate" 0 kB

Total: 19 packages (16 upgrades, 2 new, 1 in new slot, 1 uninstall), Size of downloads: 144,819 kB
Conflict: 1 block

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

app-emulation/emul-linux-x86-opengl:0

  (app-emulation/emul-linux-x86-opengl-20121028::gentoo, ebuild scheduled for merge) pulled in by
    ~app-emulation/emul-linux-x86-opengl-20121028 required by (app-emulation/emul-linux-x86-qtlibs-20121028::gentoo, ebuild scheduled for merge)

  (app-emulation/emul-linux-x86-opengl-20120520::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-opengl-20120520 required by (app-emulation/emul-linux-x86-gtklibs-20120520::gentoo, installed)

app-emulation/emul-linux-x86-xlibs:0

  (app-emulation/emul-linux-x86-xlibs-20121028::gentoo, ebuild scheduled for merge) pulled in by
    ~app-emulation/emul-linux-x86-xlibs-20121028 required by (app-emulation/emul-linux-x86-medialibs-20121028::gentoo, ebuild scheduled for merge)

  (app-emulation/emul-linux-x86-xlibs-20120520::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-xlibs-20120520 required by (app-emulation/emul-linux-x86-gtklibs-20120520::gentoo, installed)

app-emulation/emul-linux-x86-baselibs:0

  (app-emulation/emul-linux-x86-baselibs-20120520::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-baselibs-20120520 required by (app-emulation/emul-linux-x86-gtklibs-20120520::gentoo, installed)
    (and 1 more with the same problem)

  (app-emulation/emul-linux-x86-baselibs-20121028::gentoo, ebuild scheduled for merge) pulled in by
    ~app-emulation/emul-linux-x86-baselibs-20121028 required by (app-emulation/emul-linux-x86-soundlibs-20121028::gentoo, ebuild scheduled for merge)
    (and 4 more with the same problem)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


I'm a little puzzled as what should be masked or unmasked here. Could someone give a hand?


Last edited by Q-collective on Fri Nov 02, 2012 3:00 pm; edited 1 time in total
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5271

PostPosted: Fri Nov 02, 2012 2:55 am    Post subject: Reply with quote

Well, hard to say for sure, but it seems app-emulation/emul-linux-x86-gtklibs are listed among installed, but not among to be updated.
Try adding that to update list.
Back to top
View user's profile Send private message
Q-collective
Advocate
Advocate


Joined: 22 Mar 2004
Posts: 2056

PostPosted: Fri Nov 02, 2012 3:00 pm    Post subject: Reply with quote

VoidMage wrote:
Well, hard to say for sure, but it seems app-emulation/emul-linux-x86-gtklibs are listed among installed, but not among to be updated.
Try adding that to update list.

Thanks, that was it :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum