Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Which version of Portage supports which EAPI?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
pygoscelis
Guru
Guru


Joined: 07 Jun 2003
Posts: 349

PostPosted: Sat Oct 27, 2012 10:54 pm    Post subject: Which version of Portage supports which EAPI? Reply with quote

There seems to be no information on it in the documentation.

I'm trying to use some ebuilds that require EAPI=5, but I have no idea which version of Portage I need to upgrade to.
_________________
!זה הכי, אחי Gentoo
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4666
Location: Saint Amant, Acadiana

PostPosted: Sat Oct 27, 2012 11:14 pm    Post subject: Reply with quote

Not sure, but putting =sys-apps/portage-2.2* ** into /etc/portage/package.keywords/portage will do.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1155

PostPosted: Sun Oct 28, 2012 12:49 am    Post subject: Reply with quote

All ~arch should work with ~portage
All arch should work with portage

Think of Gentoo-stable and Gentoo~current of two releases of kind of different beasts and you will be right!
Eapi5 now in Gentoo~current is the reason why there are less versions of ~portage-2.1.x than usual!
_________________
fun2gen2
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Mon Oct 29, 2012 2:52 pm    Post subject: Reply with quote

You will want to use >=sys-apps/portage-2.1.11.30
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
Lightangel
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jul 2007
Posts: 127

PostPosted: Mon Oct 29, 2012 7:55 pm    Post subject: Reply with quote

By the way beware that the old portage release candidates 2.2_* don't support EAPI > 2.
For example my portage-2.2_rc33 doesn't support EAPI greater than 2.
Of course currently you may not find it in the gentoo-portage repository, but just to let you know.
Back to top
View user's profile Send private message
pygoscelis
Guru
Guru


Joined: 07 Jun 2003
Posts: 349

PostPosted: Mon Oct 29, 2012 8:03 pm    Post subject: Reply with quote

Jaglover wrote:
Not sure, but putting =sys-apps/portage-2.2* ** into /etc/portage/package.keywords/portage will do.

I'm sure it will, but 2.2 is currently branded alpha. I'd wait until it loses that status...
_________________
!זה הכי, אחי Gentoo
Back to top
View user's profile Send private message
pygoscelis
Guru
Guru


Joined: 07 Jun 2003
Posts: 349

PostPosted: Mon Oct 29, 2012 8:06 pm    Post subject: Reply with quote

yngwin wrote:
You will want to use >=sys-apps/portage-2.1.11.30
Thanks, trying it right now.
_________________
!זה הכי, אחי Gentoo
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4666
Location: Saint Amant, Acadiana

PostPosted: Mon Oct 29, 2012 8:24 pm    Post subject: Reply with quote

pygoscelis wrote:
Jaglover wrote:
Not sure, but putting =sys-apps/portage-2.2* ** into /etc/portage/package.keywords/portage will do.

I'm sure it will, but 2.2 is currently branded alpha. I'd wait until it loses that status...

FYI it has been like this for years, lots of people are using it and have no problems, including me. I even do not remember when I switched to 2.2, it was so long time ago.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
jrussia
Tux's lil' helper
Tux's lil' helper


Joined: 29 Aug 2012
Posts: 89
Location: Chicago

PostPosted: Mon Oct 29, 2012 10:05 pm    Post subject: Reply with quote

More detailed information here:

http://blogs.gentoo.org/zmedico/category/gentoo/

like
Code:
Official EAPI 5 support in portage-2.1.11.19 and 2.2.0_alpha130
Back to top
View user's profile Send private message
Mad Merlin
Veteran
Veteran


Joined: 09 May 2005
Posts: 1143

PostPosted: Sat Nov 03, 2012 1:00 am    Post subject: Reply with quote

Lightangel wrote:
By the way beware that the old portage release candidates 2.2_* don't support EAPI > 2.
For example my portage-2.2_rc33 doesn't support EAPI greater than 2.
Of course currently you may not find it in the gentoo-portage repository, but just to let you know.


portage-2.2_rc33 is really really old though. They went up to rc100 or something and then went back to alpha1 (currently at alpha142).
_________________
Game! - Where the stick is mightier than the sword!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum