Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome 3.2 Installation Problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
silhard
n00b
n00b


Joined: 01 Nov 2012
Posts: 6

PostPosted: Thu Nov 01, 2012 3:08 pm    Post subject: Gnome 3.2 Installation Problem Reply with quote

Hi gentoo folks
today installed gentoo on a virtual guest using virtualbox on my laptop. thanks to the great documentations i managed to get it running including gnome 2. now i tried to update gnome to the version 3 as described here: http://en.gentoo-wiki.com/wiki/Gnome_3. I run the following command:
Code:
pilatus ~ # emerge -av gnome


and got the following message back:
Code:
!!! All ebuilds that could satisfy ">=dev-db/sqlite-3.7.14[threadsafe]" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-db/sqlite-3.7.14.1::gentoo (masked by: EAPI 5)

The current version of portage supports EAPI '4'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
(dependency required by "app-misc/tracker-0.14.3" [ebuild])
(dependency required by "gnome-base/gnome-extra-apps-3.4.1[tracker]" [ebuild])
(dependency required by "gnome-base/gnome-3.2.1[extras]" [ebuild])
(dependency required by "=gnome-3.2.1" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


this is my first time using gentoo so im not so familiar with the whole portage thing yet but i think this means i need to unmask the >=dev-db/sqlite-3.7.14[threadsafe] package right? I tried this adding the following line to /etc/portage/package.unmask
Code:
>=dev-db/sqlite-3.7.14[threadsafe]


unfortunately i still get the same message back. Can anyone help me with this?
Back to top
View user's profile Send private message
silhard
n00b
n00b


Joined: 01 Nov 2012
Posts: 6

PostPosted: Fri Nov 02, 2012 7:17 am    Post subject: Reply with quote

I just found out that I get the same message back if I try to update portage. I updated portage before I tried to update gnome and it worked. So maybe the update messed something up.

Code:
emerge --update --deep --with-bdeps=y --newuse world


Message Back:
Code:

!!! All ebuilds that could satisfy ">=dev-db/sqlite-3.7.14[threadsafe]" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-db/sqlite-3.7.14.1::gentoo (masked by: EAPI 5)

The current version of portage supports EAPI '4'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
(dependency required by "app-misc/tracker-0.14.3" [ebuild])
(dependency required by "gnome-base/gnome-extra-apps-3.4.1[tracker]" [ebuild])
(dependency required by "gnome-base/gnome-3.4.1[extras]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Any Ideas?
Back to top
View user's profile Send private message
silhard
n00b
n00b


Joined: 01 Nov 2012
Posts: 6

PostPosted: Mon Nov 05, 2012 11:08 pm    Post subject: Reply with quote

today i got tried another time. i went back to a snapshot before the gnome emerge and emerged it another time. i get gnome 2 successfully to work but when i try to emerge gnome version 3 i get the same error message again:

Code:

!!! All ebuilds that could satisfy ">=dev-db/sqlite-3.7.14[threadsafe]" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-db/sqlite-3.7.14.1::gentoo (masked by: EAPI 5)

The current version of portage supports EAPI '4'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
(dependency required by "app-misc/tracker-0.14.3" [ebuild])
(dependency required by "gnome-base/gnome-extra-apps-3.4.1[tracker]" [ebuild])
(dependency required by "gnome-base/gnome-3.4.1[extras]" [ebuild])
(dependency required by "gnome" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


How can I unmask ">=dev-db/sqlite-3.7.14[threadsafe]" ?
I tried to put this line into /etc/portage/package.unmask but this doesent work.

How comes the ">=dev-db/sqlite-3.7.14[threadsafe]" package isn't listed in /usr/portage/profiles? shouldn't all masked packages be listed there?

Is there a way to force the sqlite package to be installed without unmasking it?
Back to top
View user's profile Send private message
silhard
n00b
n00b


Joined: 01 Nov 2012
Posts: 6

PostPosted: Wed Nov 07, 2012 1:57 pm    Post subject: Reply with quote

ok i got it working. I went to the the lib to update portage first as eapi 5 was required for the newer sqlite version then i emerged sqlite and after that i was able to update to gnome 3.4. I guess its not the best way to emerge from the lib folder.... but im happy it works now.


Code:

emerge portage-2.1.11.31.ebuild
emerge sqlite-3.7.14.1.ebuild
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum