Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Tp-link Wifi Adapter Problem (Solved)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
steelblue93
n00b
n00b


Joined: 11 Jul 2014
Posts: 3
Location: United States

PostPosted: Fri Jul 11, 2014 4:53 pm    Post subject: Tp-link Wifi Adapter Problem (Solved) Reply with quote

I'm having some difficulty getting my usb wifi adapter to perform well. The same hardware booted into windows works great but in linux I'm seeing massive delays. Hopefully I've just configured something wrong. I'm using wicd although I've used wpa_supplicant and get the same results. A couple screenshots capture the problem:

On linux:

http://postimg.org/image/5do4uyqdr/

Meanwhile, over in windows land:

http://postimg.org/image/yeyrurjab/

Various info:

Code:
steelblue ~ # ifconfig
enp1s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 00:25:22:f5:f3:f7  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        loop  txqueuelen 0  (Local Loopback)
        RX packets 1977  bytes 180059 (175.8 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1977  bytes 180059 (175.8 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp0s22f2u2: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.2.5  netmask 255.255.255.0  broadcast 192.168.2.255
        ether 54:e6:fc:95:a8:78  txqueuelen 10  (Ethernet)
        RX packets 33245  bytes 26756557 (25.5 MiB)
        RX errors 0  dropped 28  overruns 0  frame 0
        TX packets 32901  bytes 12744455 (12.1 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


Code:
steelblue ~ # iwconfig
wlp0s22f2u2  IEEE 802.11bgn  ESSID:"Skynet1" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: B4:75:0E:EE:B6:A7   
          Bit Rate=150 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=53/70  Signal level=-57 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:2511   Missed beacon:0


Code:
steelblue ~ # dmesg | grep ath
[    3.764006] md: multipath personality registered for level -4
[   11.762163] usb 3-2: ath9k_htc: Firmware htc_9271.fw requested
[   11.762188] usbcore: registered new interface driver ath9k_htc
[   12.255138] usb 3-2: ath9k_htc: Transferred FW: htc_9271.fw, size: 51272
[   12.492073] ath9k_htc 3-2:1.0: ath9k_htc: HTC initialized with 33 credits
[   12.722798] ath9k_htc 3-2:1.0: ath9k_htc: FW Version: 1.3
[   12.722801] ath: EEPROM regdomain: 0x809c
[   12.722802] ath: EEPROM indicates we should expect a country code
[   12.722803] ath: doing EEPROM country->regdmn map search
[   12.722804] ath: country maps to regdmn code: 0x52
[   12.722805] ath: Country alpha2 being used: CN
[   12.722805] ath: Regpair used: 0x52


Code:
steelblue ~ # lsmod | grep ath
ath9k_htc              52818  0
ath9k_common            8382  1 ath9k_htc
ath9k_hw              388091  2 ath9k_common,ath9k_htc
ath                    18923  3 ath9k_common,ath9k_htc,ath9k_hw
mac80211              277734  1 ath9k_htc
cfg80211              208945  4 ath,ath9k_common,mac80211,ath9k_htc
multipath               6247  0
usbcore               158916  13 yealink,uhci_hcd,snd_usb_audio,usb_storage,ohci_hcd,ohci_pci,snd_usbmidi_lib,ehci_hcd,ehci_pci,usbhid,ath9k_htc,xhci_hcd,sl811_hcd


Last edited by steelblue93 on Tue Jul 15, 2014 9:13 pm; edited 1 time in total
Back to top
View user's profile Send private message
steelblue93
n00b
n00b


Joined: 11 Jul 2014
Posts: 3
Location: United States

PostPosted: Fri Jul 11, 2014 5:25 pm    Post subject: Reply with quote

Some more info:

Code:

Speed test statistics
---------------------
Download speed: 180 kbps
Upload speed: 1104 kbps
Download consistency of service: 31 %
Upload consistency of service: 90 %
Download test type: socket
Upload test type: socket
Maximum TCP delay: 970 ms
Average download pause: 163 ms
Minimum round trip time to server: 33 ms
Average round trip time to server: 42 ms
Estimated download bandwidth: 811 kbps
Route concurrency: 4.492425
Download TCP forced idle: 0 %
Maximum route speed: 15887 kbps
TCP MTU: 1492
Pkts Norder: 87
Bytes Norder  : 124880
Pkts XWindow: 0
Bytes XWindow: 0
Pkts Dup: 0
Bytes Dup: 0
Pkts Part Dup: 0
Bytes Part Dup: 0
Pkts CRC errors: 0
Pkts bad offset: 0
Pkts too short: 0
Wnd probes recvd: 0
Zero Wnd updates: 0
Bytes lost: 5808
Retransmit timeouts: 8
Fast Retransmits: 1
Packets retransmitted: 22
Bytes retransmitted: 31944
Send Wnd Closed: 0
Pure Wnd Updates: 1
Acks for unsent: 0
Dup acks: 21
Wnd probes sent: 0
Persist timeouts: 0


Also, I didn't change any QoS setting:

Code:
steelblue ~ # tc qdisc show
qdisc pfifo_fast 0: dev enp1s0 root refcnt 2 bands 3 priomap  1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1
qdisc mq 0: dev wlp0s22f2u2 root
qdisc pfifo_fast 0: dev wlp0s22f2u2 parent :1 bands 3 priomap  1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1
qdisc pfifo_fast 0: dev wlp0s22f2u2 parent :2 bands 3 priomap  1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1
qdisc pfifo_fast 0: dev wlp0s22f2u2 parent :3 bands 3 priomap  1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1
qdisc pfifo_fast 0: dev wlp0s22f2u2 parent :4 bands 3 priomap  1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1
Back to top
View user's profile Send private message
steelblue93
n00b
n00b


Joined: 11 Jul 2014
Posts: 3
Location: United States

PostPosted: Tue Jul 15, 2014 9:13 pm    Post subject: solved Reply with quote

Just a quick followup, putting "options ath9k_htc nohwcrypt=1" in modprobe.d fixed it for me, as per:

https://bugzilla.kernel.org/show_bug.cgi?id=78581#c3
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum