Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
laptop speaker gets muted randomly
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
vootey
n00b
n00b


Joined: 24 Jul 2010
Posts: 29
Location: Austria

PostPosted: Fri Oct 26, 2012 5:19 pm    Post subject: laptop speaker gets muted randomly Reply with quote

Recently it happens that my laptop's speakers gets completely muted while e.g. watching a movie at random times. But headphones are working.
When going to sleep and waking up again the speakers are working again.

Anyone got an idea, what's going on here? I don't even know where I should start looking for the culprit.

Some system informations:
Code:
$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
01:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)


Code:
$ uname -a
Linux vootop 3.6.1-gentoo #1 SMP Fri Oct 12 17:27:25 CEST 2012 x86_64 Intel(R) Core(TM) i7 CPU Q 720 @ 1.60GHz GenuineIntel GNU/Linux


Code:
$ lsmod | grep -i snd
snd_hda_codec_hdmi     21182  4
snd_hda_codec_conexant    40159  1
snd_hda_intel          20968  5
snd_hda_codec          69288  3 snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_hda_intel
snd_hwdep               5178  1 snd_hda_codec
Back to top
View user's profile Send private message
vootey
n00b
n00b


Joined: 24 Jul 2010
Posts: 29
Location: Austria

PostPosted: Thu Feb 07, 2013 2:50 pm    Post subject: Reply with quote

Here I am again. The issue unfortunately didn't disappear magically.

In the meantime I tried different kernels (3.0.57, 3.4.24, 3.7.3, 3.7.6): No change here.

I found out that restarting pulseaudio (often) works to get the speakers back, but not always (the more restarts the higher the chance of sucess).
Pulseaudio's debug logs indicate exactly nothing at the moment the speakers mute.
This is the case with pulseaudio 2.1-r1 and 3.0 (I cannot tests 1.1-r1 since it won't compile with current udev-versions).

Another weird thing is that I have already used pulseaudio 2.1 in the past and there I didn't have any problems.
Maybe it is worth mentioning that I notice quiet "sound scratches" when starting pulseaudio which also didn't exist in earlier times.

Help! :P
Back to top
View user's profile Send private message
syn0ptik
Apprentice
Apprentice


Joined: 09 Jan 2013
Posts: 221

PostPosted: Sat Feb 16, 2013 6:51 am    Post subject: Reply with quote

may be it kernel configuration parameter for alsa sleep
CONFIG_SND_HDA_POWER_SAVE_DEFAULT=5
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum