Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
eselect python set 1 error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
drieu
n00b
n00b


Joined: 25 Oct 2012
Posts: 8

PostPosted: Thu Oct 25, 2012 9:03 pm    Post subject: eselect python set 1 error Reply with quote

Hi,

I want to use Play framework 1.2.5 on Gentoo.
However Play framework 1.2.5 doesn't work with Python 3.
That's why, I want to use python2.7.
Now, I have python3.2 :

Code:
eselect python list
Available Python interpreters:
  [1]   python2.7
  [2]   python3.2 *


If I type the following command :

Code:
eselect python set 1
!!! Error: Cannot remove symlinks
exiting


I didn't know python ...
So where are theses symlinks ?
What can I do for it succeeds ?

thanks,
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4563
Location: Saint Amant, Acadiana

PostPosted: Thu Oct 25, 2012 9:19 pm    Post subject: Reply with quote

Welcome, drieu!

You need to run this as root, e. g.
Code:
sudo eselect python set 1

_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
drieu
n00b
n00b


Joined: 25 Oct 2012
Posts: 8

PostPosted: Sat Oct 27, 2012 4:26 pm    Post subject: Reply with quote

Thanks !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum