Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't install VLC & virtualbox[solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
blakdeath
Guru
Guru


Joined: 21 Sep 2012
Posts: 462

PostPosted: Tue Oct 23, 2012 6:45 pm    Post subject: Can't install VLC & virtualbox[solved] Reply with quote

I'm having a really hard time installing software on Gentoo, any help would be appreciated
I'm using Gnome as a graphical desktop environment, I'm new to gentoo so I probably did not supply enough information, I'm doing my best though
This is what I get when i type "emerge vlc":
--- Invalid atom in /etc/portage/package.use: ffmpeg
--- Invalid atom in /etc/portage/package.use: skins

* IMPORTANT: 5 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Calculating dependencies... done!
[ebuild N ] media-libs/libdvbpsi-0.2.2 USE="-doc -static-libs"
[ebuild N ] media-libs/x264-0.0.20111220 USE="interlaced threads -10bit -custom-cflags -debug -pic -static-libs"
[ebuild N ] media-libs/xvid-1.3.2 USE="threads -examples -pic"
[ebuild R ] sys-libs/zlib-1.2.7 USE="minizip*"
[ebuild N ] media-libs/vo-aacenc-0.1.2 USE="-examples (-neon) -static-libs"
[ebuild N ] media-video/ffmpeg-0.10.3 USE="X aac alsa bzip2 encode hardcoded-tables mmx mp3 pulseaudio sdl truetype vorbis x264 xvid zlib -3dnow -3dnowext -aacplus (-altivec) -amr -avx -bindist -cdio (-celt) -cpudetection -debug -dirac -doc -faac -frei0r -gnutls -gsm -ieee1394 -jack -jpeg2k -libass -libv4l -mmxext -modplug (-neon) -network -openal -openssl -oss -pic -rtmp -schroedinger -speex -ssse3 -static-libs -test -theora -threads -v4l -vaapi -vdpau (-vis) -vpx" FFTOOLS="aviocat cws2fws ffeval graph2dot ismindex pktdumper qt-faststart trasher"
[ebuild N ] virtual/ffmpeg-0.10.2-r1 USE="X encode mp3 sdl truetype x264 -jpeg2k -theora -threads -vaapi -vdpau"
[ebuild N ] media-video/vlc-2.0.3 USE="X a52 aac alsa avcodec avformat cdda dbus dts dvbpsi dvd encode ffmpeg flac gcrypt gnome libnotify mmx mp3 mpeg ncurses ogg opengl png postproc pulseaudio sdl sse svg swscale truetype udev vorbis x264 xcb xml xv -aalib (-altivec) -atmo (-audioqueue) -avahi -bidi -bluray -cddb -dc1394 -debug -dirac (-direct2d) -directfb (-directx) (-dshow) -dvb (-dxva2) -egl -fbosd -fluidsynth -fontconfig -gme -gnutls -growl -httpd -ieee1394 (-ios-vout) -jack -kate -kde -libass -libcaca -libproxy -libsamplerate -libtar -libtiger -linsys -lirc -live -lua (-macosx) (-macosx-audio) (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) (-macosx-vout) -matroska (-media-library) -modplug -mtp -musepack (-neon) -omxil -optimisememory -oss -portaudio -projectm -pvr -qt4 -rtsp -run-as-root -samba -schroedinger -sdl-image -shine -shout -sid -skins -speex -sqlite -switcher -taglib -theora -twolame -upnp -v4l -vaapi -vcdx -vlm (-waveout) (-win32codecs) (-wingdi) -wma-fixed -xosd -zvbi"

The following USE changes are necessary to proceed:
#required by media-video/vlc-2.0.3, required by vlc (argument)
>=sys-libs/zlib-1.2.7 minizip

Use --autounmask-write to write changes to config files (honoring CONFIG_PROTECT).


and this is what I get when i type "emerge virtualbox-bin", I have already installed vbox and vbox modules:
--- Invalid atom in /etc/portage/package.use: ffmpeg
--- Invalid atom in /etc/portage/package.use: skins

* IMPORTANT: 5 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Calculating dependencies... done!
[ebuild U ~] app-emulation/virtualbox-modules-4.2.0-r1 [4.1.22]
[ebuild N ~] app-emulation/virtualbox-bin-4.2.0 USE="additions chm -debug -headless -python -rdesktop-vrdp -sdk -vboxwebsrv"
[blocks B ] app-emulation/virtualbox-bin ("app-emulation/virtualbox-bin" is blocking app-emulation/virtualbox-4.1.22)
[blocks B ] app-emulation/virtualbox-bin ("app-emulation/virtualbox-bin" is blocking app-emulation/virtualbox-additions-4.1.22)
[blocks B ] app-emulation/virtualbox-additions ("app-emulation/virtualbox-additions" is blocking app-emulation/virtualbox-bin-4.2.0)
[blocks B ] app-emulation/virtualbox ("app-emulation/virtualbox" is blocking app-emulation/virtualbox-bin-4.2.0)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

app-emulation/virtualbox-modules:0

(app-emulation/virtualbox-modules-4.2.0-r1::gentoo, ebuild scheduled for merge) pulled in by
~app-emulation/virtualbox-modules-4.2.0 required by (app-emulation/virtualbox-bin-4.2.0::gentoo, ebuild scheduled for merge)

(app-emulation/virtualbox-modules-4.1.22::gentoo, installed) pulled in by
~app-emulation/virtualbox-modules-4.1.22 required by (app-emulation/virtualbox-4.1.22::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


help is greatly appreciated
Adel


Last edited by blakdeath on Thu Oct 25, 2012 4:26 am; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31711
Location: 56N 3W

PostPosted: Tue Oct 23, 2012 8:31 pm    Post subject: Reply with quote

blakdeath,

Code:
and this is what I get when i type "emerge virtualbox-bin", I have already installed vbox and vbox modules:
--- Invalid atom in /etc/portage/package.use: ffmpeg
--- Invalid atom in /etc/portage/package.use: skins

Means exactly what is says on the tin. The entries are of the form <catagory>/<package> flag1 flag2 ...
If you give a comparsion operator, you must give a version too. Each flag may be preceded by a - to indicate that it is to be off.

Ypu may install app-emulation/virtualbox-bin or app-emulation/virtualbox but not both. Its make your mind up time.
As I am /no-multilib/ I must use the -bin as Vbox is a 32 bit program.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
blakdeath
Guru
Guru


Joined: 21 Sep 2012
Posts: 462

PostPosted: Thu Oct 25, 2012 4:25 am    Post subject: Reply with quote

Ah thanks, that was very helpful, I have finally installed vbox

I've also been able to install vlc by using the emerge --autounmask-write option
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum