Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kernel 3.4.9 lässt sich nicht bauen
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
tazinblack
l33t
l33t


Joined: 23 Jan 2005
Posts: 926
Location: Baden / Germany

PostPosted: Fri Oct 12, 2012 7:14 am    Post subject: Kernel 3.4.9 lässt sich nicht bauen Reply with quote

Hallo zusammen,

ich habe mit dieser Version Probleme den Kernel mit genkernel zu bauen.
Ist für mich etwas undurchsichtig, was das Problem verursacht.
Das hab ich jetzt schon auf dem zweiten Rechner. Auf dem Ersten läuft amd64,
hier x86.

Code:

genkernel --makeopts="-j2" --menuconfig all
* Gentoo Linux Genkernel; Version 3.4.24_p2
* Running with options: --makeopts=-j2 --menuconfig all

* Linux Kernel 3.4.9-gentoo for x86_64...
* kernel: Using config from /etc/kernels/kernel-config-x86_64-3.4.9-gentoo
*         Previous config backed up to .config--2012-10-12--08-39-04.bak
* kernel: >> Running mrproper...
*         >> Running oldconfig...
* kernel: >> Cleaning...
* kernel: >> Invoking menuconfig...
#
# configuration written to .config
#


*** End of the configuration.
*** Execute 'make' to start the build or try 'make help'.

*         >> Compiling 3.4.9-gentoo bzImage...
*         >> Not installing firmware as it's included in the kernel already (CONFIG_FIRMWARE_IN_KERNEL=y)...
*         >> Compiling 3.4.9-gentoo modules...
* ERROR: Failed to compile the "modules" target...

* -- Grepping log... --

  Thermal Zone (ACPI_THERMAL) [M/n/?] m
  Debug Statements (ACPI_DEBUG) [N/y/?] n
  PCI slot detection driver (ACPI_PCI_SLOT) [N/m/y/?] n
  Container and Module Devices (EXPERIMENTAL) (ACPI_CONTAINER) [M/y/?] m
  Smart Battery System (ACPI_SBS) [N/m/y/?] n
  Hardware Error Device (ACPI_HED) [N/m/y/?] n
  Boottime Graphics Resource Table support (ACPI_BGRT) [N/m/y/?] (NEW)   ACPI Platform Error Interface (APEI) (ACPI_APEI) [N/y/?] n
--
* Bus options (PCI etc.)
*
PCI support (PCI) [Y/n/?] y
  Support mmconfig PCI config space access (PCI_MMCONFIG) [Y/n] y
  PCI Express support (PCIEPORTBUS) [Y/n/?] y
    Root Port Advanced Error Reporting support (PCIEAER) [Y/n/?] y
      PCI Express ECRC settings control (PCIE_ECRC) [N/y/?] n
      PCIe AER error injector support (PCIEAER_INJECT) [N/m/y/?] n
--
Print additional diagnostics on RCU CPU stall (RCU_CPU_STALL_INFO) [N/y/?] (NEW) Enable tracing for RCU (RCU_TRACE) [N/y/?] n
Self test for the backtrace code (BACKTRACE_SELF_TEST) [N/m/y/?] n
Force extended block device numbers and spread them (DEBUG_BLOCK_EXT_DEVT) [N/y/?] n
Force weak per-cpu definitions (DEBUG_FORCE_WEAK_PER_CPU) [N/y/?] n
Debug access to per_cpu maps (DEBUG_PER_CPU_MAPS) [N/y/?] n
CPU notifier error injection module (CPU_NOTIFIER_ERROR_INJECT) [N/m/y/?] n
--
  CC [M]  drivers/scsi/libiscsi.o
  CC [M]  net/sunrpc/rpc_pipe.o
  CC [M]  drivers/scsi/iscsi_boot_sysfs.o
  CC [M]  net/sunrpc/svc_xprt.o
  CC [M]  drivers/scsi/advansys.o
drivers/scsi/advansys.c:71:2: Warnung: #warning this driver is still not properly converted to the DMA API
--
  CC [M]  drivers/scsi/qla2xxx/qla_os.o
  CC [M]  drivers/scsi/lpfc/lpfc_mbox.o
  CC [M]  drivers/scsi/lpfc/lpfc_nportdisc.o
  CC [M]  drivers/scsi/qla2xxx/qla_init.o
  CC [M]  drivers/scsi/lpfc/lpfc_scsi.o
cc1: warnings being treated as errors
--
  LD [M]  drivers/usb/storage/ums-usbat.o
make: *** [drivers] Fehler 2
* Gentoo Linux Genkernel; Version 3.4.24_p2
* Running with options: --makeopts=-j2 --menuconfig all

* ERROR: Failed to compile the "modules" target...

* -- End log... --

* Please consult /var/log/genkernel.log for more information and any
* errors that were reported above.

* Report any genkernel bugs to bugs.gentoo.org and
* assign your bug to genkernel@gentoo.org. Please include
* as much information as you can in your bug report; attaching
* /var/log/genkernel.log so that your issue can be dealt with effectively.
*
* Please do *not* report compilation failures as genkernel bugs!
*


Wenn ich den Advansys Treiber raus nehme, hängts an den qlogic Treibern.
Hat das noch jemand?
_________________
Gruß / Regards
tazinblack
_______________________________________________________
told you so
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3900
Location: Irgendwo im Nirgendwo

PostPosted: Fri Oct 12, 2012 10:36 am    Post subject: Reply with quote

Liegt am CFLAG "-Werror":
Code:
cc1: warnings being treated as errors

Ich erinner mich ganz dumpf daran, hier in dem Zusammenhang (genkernel <-> -Werror) schonmal einen Post gesehen zu haben...

// aha ;)
http://forums.gentoo.org/viewtopic-t-924342-start-0.html
http://forums.gentoo.org/viewtopic-t-924334-start-0.html
-> downgrade auf genkernel-3.4.20 - aber vielleicht gibt es auch eine Option, mit der sich das Verhalten abschalten lässt.
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay


Last edited by franzf on Fri Oct 12, 2012 10:45 am; edited 1 time in total
Back to top
View user's profile Send private message
tazinblack
l33t
l33t


Joined: 23 Jan 2005
Posts: 926
Location: Baden / Germany

PostPosted: Fri Oct 12, 2012 10:40 am    Post subject: Reply with quote

franzf wrote:
Liegt am CFLAG "-Werror":
Code:
cc1: warnings being treated as errors

Ich erinner mich ganz dumpf daran, hier in dem Zusammenhang (genkernel <-> -Werror) schonmal einen Post gesehen zu haben...


Wenn Du mir noch sagst, wieso das auf einmal an ist, dann versteh ich das vielleicht !?!
Auch wär ich für einen Tipp froh, wo ich das wieder abschalte.
_________________
Gruß / Regards
tazinblack
_______________________________________________________
told you so
Back to top
View user's profile Send private message
tazinblack
l33t
l33t


Joined: 23 Jan 2005
Posts: 926
Location: Baden / Germany

PostPosted: Fri Oct 12, 2012 10:44 am    Post subject: Reply with quote

Wenn Du den hier meinst http://forums.gentoo.org/viewtopic-t-924342-highlight-werror.html,

leider wurde dort die Ursache nicht gefunden :-(
_________________
Gruß / Regards
tazinblack
_______________________________________________________
told you so
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3900
Location: Irgendwo im Nirgendwo

PostPosted: Fri Oct 12, 2012 10:49 am    Post subject: Reply with quote

Wie oben bereits geschrieben -> downgrade.
Alternativ kann es durchaus sein, dass du über die /etc/genkernel.conf gehen kannst. Ich verwende kein genkernel drum kann ich nur raten ;)
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3900
Location: Irgendwo im Nirgendwo

PostPosted: Fri Oct 12, 2012 11:07 am    Post subject: Reply with quote

Ich denke es liegt an den CFLAGS eines der mitgelieferten Abhängigkeiten:
Code:
[13:03] $ deepgrep Werror /var/distfiles/genkernel-3.4.43.tar.bz2
[13:03] $ deepgrep Werror /var/distfiles/unionfs-fuse-0.24.tar.bz2
[13:03] $ deepgrep Werror /var/distfiles/open-iscsi-2.0-872.tar.gz
[13:03] $ deepgrep Werror /var/distfiles/mdadm-3.1.5.tar.bz2
/var/distfiles/mdadm-3.1.5.tar.bz2/mdadm-3.1.5/Makefile:CWFLAGS = -Wall -Werror -Wstrict-prototypes -Wextra -Wno-unused-parameter
[13:04] $ deepgrep Werror /var/distfiles/gnupg-1.4.11.tar.bz2
/var/distfiles/gnupg-1.4.11.tar.bz2/gnupg-1.4.11/aclocal.m4:      # or remarks (even with -Werror).  So we grep stderr for any message
/var/distfiles/gnupg-1.4.11.tar.bz2/gnupg-1.4.11/configure:      # or remarks (even with -Werror).  So we grep stderr for any message
/var/distfiles/gnupg-1.4.11.tar.bz2/gnupg-1.4.11/configure:      # or remarks (even with -Werror).  So we grep stderr for any message
[13:04] $ deepgrep Werror /var/distfiles/fuse-2.8.6.tar.gz
[13:04] $ deepgrep Werror /var/distfiles/dmraid-1.0.0.rc16-3.tar.bz2
[13:04] $ deepgrep Werror /var/distfiles/busybox-1.20.2.tar.bz2
/var/distfiles/busybox-1.20.2.tar.bz2/busybox-1.20.2/Makefile.flags:CFLAGS += $(call cc-option,-Werror,)
/var/distfiles/busybox-1.20.2.tar.bz2/busybox-1.20.2/configs/android_defconfig:# -Werror=return-type -Werror=non-virtual-dtor -Werror=address
/var/distfiles/busybox-1.20.2.tar.bz2/busybox-1.20.2/configs/android_defconfig:# -Werror=sequence-point -Wstrict-aliasing=2 -Wno-undef -Wno-shadow
/var/distfiles/busybox-1.20.2.tar.bz2/busybox-1.20.2/Config.in:   Selecting this will add -Werror to gcc command line.
/var/distfiles/busybox-1.20.2.tar.bz2/busybox-1.20.2/networking/httpd_ssi.c:-Wall -Wshadow -Wwrite-strings -Wundef -Wstrict-prototypes -Werror \
/var/distfiles/busybox-1.20.2.tar.bz2/busybox-1.20.2/networking/httpd_indexcgi.c:-Wall -Wshadow -Wwrite-strings -Wundef -Wstrict-prototypes -Werror \
[13:04] $ deepgrep Werror /var/distfiles/LVM2.2.02.88.tgz

Also entweder mdadm oder busybox - beide setzen -Werror.
(deepgrep kommt mit strigi).
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
tazinblack
l33t
l33t


Joined: 23 Jan 2005
Posts: 926
Location: Baden / Germany

PostPosted: Mon Oct 15, 2012 5:48 am    Post subject: Reply with quote

Also ich hab genkernel jetzt downgegraded bis
Code:
equery l genkernel
 * Searching for genkernel ...
[IP-] [  ] sys-kernel/genkernel-3.4.16:0


Weiter zurück gehts nicht. Und das Problem besteht weiter. :-(
Ich denke eher, dass sich wie Du schon sagtest, das Problem über mdadm oder busybox eingeschleust hat.
_________________
Gruß / Regards
tazinblack
_______________________________________________________
told you so
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3900
Location: Irgendwo im Nirgendwo

PostPosted: Mon Oct 15, 2012 7:29 am    Post subject: Reply with quote

genkernel bringt halt seine eigenen Abhängigkeiten mit und installiert sie irgendwo in /usr/lib64 (o.Ä., schau mal mit qlist genkernel). Darunter eben auch mdadm und busybox.
Es gibt ja schon einige reports auf bgo, aber keiner versucht den (mMn. absolut unnötigen) -Werror zu fixen. Bei dir war es ja nichtmal ein wirklicher "Fehler" (unused variable, deprecated conversion, o.Ä.) sondern ein extra gesetztes "#warning" als Hinweis für die kernel devs. Das sollte echt nicht fehlschlagen :(
Ich sehs nur schon kommen, dass ein neuer bug gleich als "DUP" geschlossen wird. Vielleicht hab ich ja heut mal Zeit zum genkernel-rumbasteln...
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
tazinblack
l33t
l33t


Joined: 23 Jan 2005
Posts: 926
Location: Baden / Germany

PostPosted: Wed Oct 17, 2012 8:04 am    Post subject: Reply with quote

Hab gestern trotzdem mal nen Bugreport aufgemacht -> https://bugs.gentoo.org/show_bug.cgi?id=438542
_________________
Gruß / Regards
tazinblack
_______________________________________________________
told you so
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum