Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
eix colors changed
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
krigstask
n00b
n00b


Joined: 27 Feb 2007
Posts: 41
Location: Rampova, Inkerimaa, Venämaa

PostPosted: Mon Dec 24, 2012 3:59 pm    Post subject: Reply with quote

mv wrote:
Having remote hosts which have ancient ncurses versions and thus do not know current TERM settings is kludgy. Thus to workaround this "bug" in the corresponding startup script on the machine (by setting to a wrong but at least recognized TERM) is probably the best which can be done.

I was under impression that for host to know about TERM=rxvt-unicode256 it should have rxvt-unicode installed.
Quote:
Quote:
Nope, it's just regular "login to X, start urxvt, run eix" scenario.

What does echo $COLORFGBG output? If it outputs nothing, it is presumably unset in some of your startup scripts - this should be avoided.

Code:
 % echo $COLORFGBG
15;default;0
Back to top
View user's profile Send private message
mv
Advocate
Advocate


Joined: 20 Apr 2005
Posts: 4217

PostPosted: Mon Dec 24, 2012 4:38 pm    Post subject: Reply with quote

krigstask wrote:
I was under impression that for host to know about TERM=rxvt-unicode256 it should have rxvt-unicode installed.

No: TERM only tells the application which escape sequences can be used and what they mean.
Quote:
Code:
 % echo $COLORFGBG
15;default;0

Now I see: WIth XPM support, COLORFGBG has a different syntax which is currently not interpreted correctly by eix. As a workaround you can set
Code:
COLORFGBG_DARK=';0?[02-689]$ ;1[0-46]$ ;[a-km-vxz][a-z]*$'

I guess this will be default in >=eix-0.27.7
Back to top
View user's profile Send private message
krigstask
n00b
n00b


Joined: 27 Feb 2007
Posts: 41
Location: Rampova, Inkerimaa, Venämaa

PostPosted: Mon Dec 24, 2012 4:46 pm    Post subject: Reply with quote

mv wrote:
krigstask wrote:
I was under impression that for host to know about TERM=rxvt-unicode256 it should have rxvt-unicode installed.

No: TERM only tells the application which escape sequences can be used and what they mean.

I know, but I distinctly remember ssh'ing to a up-to-date Gentoo system (but without urxvt) and failng because of $TERM. Fixed by installing rxvt-unicode. But maybe I made a mistake or misrecalled something.

Quote:
Quote:
Code:
 % echo $COLORFGBG
15;default;0

Now I see: WIth XPM support, COLORFGBG has a different syntax which is currently not interpreted correctly by eix. As a workaround you can set
Code:
COLORFGBG_DARK=';0?[02-689]$ ;1[0-46]$ ;[a-km-vxz][a-z]*$'

I guess this will be default in >=eix-0.27.7

I think I'll stick with setting BG1=none for the time being. Good that it would be fixed, though, thanks!
Back to top
View user's profile Send private message
mv
Advocate
Advocate


Joined: 20 Apr 2005
Posts: 4217

PostPosted: Sat Apr 06, 2013 8:15 am    Post subject: Reply with quote

Solarized users should be aware of an important change in app-portage/eix-0.28.4:

Please just set (or export from the shell) SOLARIZED=true (or light or dark). This will give you a special color scheme for solarized in 16 and 256 color terminals.

The previous recommendations to set TERM_ALT[0-3] or COLORSCHEME[0-3] for solarized users are obsolete!
If you have set these variable previously in your /etc/eixrc (or exported them), please remove them again! (It produces now suboptimal results.)
Back to top
View user's profile Send private message
Letharion
Veteran
Veteran


Joined: 13 Jun 2005
Posts: 1259
Location: Sweden

PostPosted: Wed Jul 17, 2013 11:47 am    Post subject: Reply with quote

I didn't have large issues with my colors, but googled gentoo and solariezed and ended up here.

How awesome it was to find that if I upgrade I can just set SOLARIZED=true and eix will "just work".

Really really nice, thanks. :)
Back to top
View user's profile Send private message
lkraav
Tux's lil' helper
Tux's lil' helper


Joined: 13 Oct 2004
Posts: 121
Location: Estonia

PostPosted: Sat Oct 26, 2013 12:50 pm    Post subject: Reply with quote

mv wrote:
Solarized users should be aware of an important change in app-portage/eix-0.28.4:

Please just set (or export from the shell) SOLARIZED=true (or light or dark). This will give you a special color scheme for solarized in 16 and 256 color terminals.

The previous recommendations to set TERM_ALT[0-3] or COLORSCHEME[0-3] for solarized users are obsolete!
If you have set these variable previously in your /etc/eixrc (or exported them), please remove them again! (It produces now suboptimal results.)


This definitely is my "f yeah" moment of the day \o/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page Previous  1, 2, 3
Page 3 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum