Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO]Problema l'installazione di gnome-shell...
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Rodolfo Mariotti
n00b
n00b


Joined: 17 Sep 2012
Posts: 4
Location: San Salvo, Chieti, Abruzzo

PostPosted: Wed Oct 10, 2012 12:06 pm    Post subject: [RISOLTO]Problema l'installazione di gnome-shell... Reply with quote

Cercando di installare GNOME ho seguito questa guida:
http://www.gentoo.org/doc/it/gnome-config.xml
non essendi riuscito ad installare gnome usandi il metido descritto dalla guida di cui sopra mi sono rivolto alla seguente guida:
http://en.gentoo-wiki.com/wiki/Gnome_3
Prima dell'installazione mi si presentano degli errori riguardo alcuni pacchetti bloccati, pensando che fossero pacchetti installati dal tentativo precedente si nistallare GNOME li ho disinstallati
ora l'installazione di gnome seguendo la seconda guida si blocca al quartultimo pacchetto: GDM restituendo il seguente errore
Code:
>>> Emerging (1 of 4) gnome-base/gdm-3.4.1-r3
 * gdm-3.4.1.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) ...                 [ ok ]
 * gdm-gentoo-2012.09.25.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) ...     [ ok ]
 * Adding group 'gdm' to your system ...
 *  - Groupid: next available
/usr/portage/eclass/user.eclass: line 343: groupadd: command not found
 * ERROR: gnome-base/gdm-3.4.1-r3 failed (setup phase):
 *   (no error message)
 *
 * Call stack:
 *             ebuild.sh, line  85:  Called pkg_setup
 *   gdm-3.4.1-r3.ebuild, line 132:  Called enewgroup 'gdm'
 *           user.eclass, line 343:  Called die
 * The specific snippet of code:
 *         groupadd -r ${opts} "${egroup}" || die
 *
 * If you need support, post the output of `emerge --info '=gnome-base/gdm-3.4.1-r3'`,
 * the complete build log and the output of `emerge -pqv '=gnome-base/gdm-3.4.1-r3'`.
 * The complete build log is located at '/var/tmp/portage/gnome-base/gdm-3.4.1-r3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/gnome-base/gdm-3.4.1-r3/temp/die.env'.
 * Working directory: '/var/tmp/portage/gnome-base/gdm-3.4.1-r3'
 * S: '/var/tmp/portage/gnome-base/gdm-3.4.1-r3/work/gdm-3.4.1'

>>> Failed to emerge gnome-base/gdm-3.4.1-r3, Log file:

>>>  '/var/tmp/portage/gnome-base/gdm-3.4.1-r3/temp/build.log'

 * Messages for package gnome-base/gdm-3.4.1-r3:

 * ERROR: gnome-base/gdm-3.4.1-r3 failed (setup phase):
 *   (no error message)
 *
 * Call stack:
 *             ebuild.sh, line  85:  Called pkg_setup
 *   gdm-3.4.1-r3.ebuild, line 132:  Called enewgroup 'gdm'
 *           user.eclass, line 343:  Called die
 * The specific snippet of code:
 *         groupadd -r ${opts} "${egroup}" || die
 *
 * If you need support, post the output of `emerge --info '=gnome-base/gdm-3.4.1-r3'`,
 * the complete build log and the output of `emerge -pqv '=gnome-base/gdm-3.4.1-r3'`.
 * The complete build log is located at '/var/tmp/portage/gnome-base/gdm-3.4.1-r3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/gnome-base/gdm-3.4.1-r3/temp/die.env'.
 * Working directory: '/var/tmp/portage/gnome-base/gdm-3.4.1-r3'
 * S: '/var/tmp/portage/gnome-base/gdm-3.4.1-r3/work/gdm-3.4.1'

Ora gnome si avvia attraverso slim ed è tutto funzionante.
1° domanda come posso risolvere il problema sopra ripotato
2° (PIU IMPORTANTE) domanda dopo i vari magheggi per installare gnome il comando su non funziona più ovvero restituisce l'errore unknow command
:oops: :oops: penso che la colpa sia dei pacchetti che ho rimosso poichè bloccavano gli altri :oops: :oops: ma il problema più grave e che non mi ricordo quali fossero e non so come reperire i loro nomi
grazie a tutti quelli che mi risponderanno


Last edited by Rodolfo Mariotti on Thu Oct 11, 2012 2:54 pm; edited 1 time in total
Back to top
View user's profile Send private message
fturco
Apprentice
Apprentice


Joined: 08 Dec 2010
Posts: 284
Location: Italy

PostPosted: Wed Oct 10, 2012 12:53 pm    Post subject: Reply with quote

Sia "groupadd" sia "su" sono comandi che appartengono al pacchetto "shadow". Verifica se è correttamente installato sul tuo sistema con:
Code:
equery check shadow

Se non hai "equery" installa il pacchetto "gentoolkit" e riprova, oppure guarda anche soltanto l'output di:
Code:
emerge -pv shadow
Back to top
View user's profile Send private message
Rodolfo Mariotti
n00b
n00b


Joined: 17 Sep 2012
Posts: 4
Location: San Salvo, Chieti, Abruzzo

PostPosted: Wed Oct 10, 2012 1:25 pm    Post subject: Reply with quote

shadow non era installato ora provando ad emergelo esce:


Code:
rodolfo@supertux ~ $ sudo emerge shadow

 * IMPORTANT: 8 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


 * IMPORTANT: config file '/etc/portage/package.keywords/package.keywords.file' needs updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.
Calculating dependencies... done!
[ebuild  N     ] sys-apps/shadow-4.1.4.3  USE="cracklib nls pam -audit (-selinux) -skey"
[blocks B      ] <sys-apps/shadow-4.1.5-r1 ("<sys-apps/shadow-4.1.5-r1" is blocking sys-auth/pambase-20120417-r1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/shadow-4.1.4.3::gentoo, ebuild scheduled for merge) pulled in by
    shadow


allora provo a rimuovere sys-auth/pambase-20120417-r1 che bloacca shadow

poi provando nuovamente a emergerlo esce:
rodolfo@supertux ~ $ sudo emerge shadow

* IMPORTANT: 8 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


* IMPORTANT: config file '/etc/portage/package.keywords/package.keywords.file' needs updating.
* See the CONFIGURATION FILES section of the emerge
* man page to learn how to update config files.
Calculating dependencies... done!
[ebuild N ~] sys-auth/pambase-20120417-r1 USE="consolekit cracklib gnome-keyring sha512 -debug -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc (-selinux) -systemd"
[ebuild N ] sys-apps/shadow-4.1.4.3 USE="cracklib nls pam -audit (-selinux) -skey"
[blocks B ] <sys-apps/shadow-4.1.5-r1 ("<sys-apps/shadow-4.1.5-r1" is blocking sys-auth/pambase-20120417-r1)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(sys-apps/shadow-4.1.4.3::gentoo, ebuild scheduled for merge) pulled in by
shadow


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant)
http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
[/code]
Da cio che ho capito è la dipendenza di shadow sys-auth/pambase-20120417-r1 che blocca shadow
Devo provare a mascherare sys-auth/pambase-20120417-r1??

----EDIT----
ho mascherato il pacchetto e ora funziona come posso fare ad installare GDM
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1494
Location: Cosenza, Italy

PostPosted: Wed Oct 10, 2012 2:28 pm    Post subject: Reply with quote

Rodolfo Mariotti wrote:
----EDIT----
ho mascherato il pacchetto e ora funziona come posso fare ad installare GDM


Avere slim o gdm è la stessa cosa. Se hai reinstallato shadow prova a rilanciare l'emerge di gdm
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
fturco
Apprentice
Apprentice


Joined: 08 Dec 2010
Posts: 284
Location: Italy

PostPosted: Wed Oct 10, 2012 6:24 pm    Post subject: Reply with quote

Rodolfo Mariotti wrote:
Code:
 * IMPORTANT: 8 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Non è direttamente legato al problema iniziale, però io al posto tuo controllerei le news, non si sa mai.
Back to top
View user's profile Send private message
fturco
Apprentice
Apprentice


Joined: 08 Dec 2010
Posts: 284
Location: Italy

PostPosted: Wed Oct 10, 2012 6:35 pm    Post subject: Reply with quote

@Rodolfo: Per quanto riguarda il conflitto con emerge, sembra che pambase sia una dipendenza di shadow, però pambase-20120417-r1 (che è l'ultima versione disponibile) vuole una versione di shadow che sia almeno la 4.1.5-r1, mentre sembra che emerge voglia installare la 4.1.4.3. Quindi la soluzione penso che non stia nel mascherare o rimuovere pambase, bensì nell'installare una versione recente di shadow.
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1494
Location: Cosenza, Italy

PostPosted: Wed Oct 10, 2012 6:38 pm    Post subject: Reply with quote

fturco wrote:
@Rodolfo: Per quanto riguarda il conflitto con emerge, sembra che pambase sia una dipendenza di shadow, però pambase-20120417-r1 (che è l'ultima versione disponibile) vuole una versione di shadow che sia almeno la 4.1.5-r1, mentre sembra che emerge voglia installare la 4.1.4.3. Quindi la soluzione penso che non stia nel mascherare o rimuovere pambase, bensì nell'installare una versione recente di shadow.

Non si fanno 2 post di fila, si edita il precedente =)
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
Rodolfo Mariotti
n00b
n00b


Joined: 17 Sep 2012
Posts: 4
Location: San Salvo, Chieti, Abruzzo

PostPosted: Thu Oct 11, 2012 2:52 pm    Post subject: Reply with quote

Un grazie a tutti per le vostre tempestive risposte ho installato l'ultima versione di shadow e non ho più problemi con esso e le sue dipendenze.
Per Gnome invece ho disinstallato tutto modificando la flag USE per rimuovere gnome e il profilo di portage poi ho aggiornato tutto e poi ho seguito di nuovo la seconda guida e tutto è andato per il meglio.
Ho anche letto le news di portage :D :D

Grazie ha tutti problema risolto
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum