Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Virtuelles Mailhosting - Kein Login möglich
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
xenobyte
n00b
n00b


Joined: 30 Nov 2011
Posts: 14

PostPosted: Fri Sep 28, 2012 5:23 pm    Post subject: Virtuelles Mailhosting - Kein Login möglich Reply with quote

Moin,

Ich hab nach diesem Guide hier (http://www.gentoo.org/doc/en/virt-mail-howto.xml) ein virtuelles Mailsystem aufgesetzt. Die Installation lief problemlos. Allerdings ist es mir weder über SquirrelMail noch über andere Mailclients möglich mich in das System einzuloggen. SpuirrelMail sagt: ERROR: Connection dropped by IMAP server.

Die Dienste laufen alle...

Code:

server ~ # nmap localhost

Starting Nmap 5.51 ( http://nmap.org ) at 2012-09-28 19:19 CEST
Nmap scan report for localhost (127.0.0.1)
Host is up (0.0000050s latency).
rDNS record for 127.0.0.1: localhost.localdomain
Not shown: 994 closed ports
PORT     STATE SERVICE
22/tcp   open  ssh
25/tcp   open  smtp
80/tcp   open  http
443/tcp  open  https
993/tcp  open  imaps
3306/tcp open  mysql

Nmap done: 1 IP address (1 host up) scanned in 0.18 seconds


In /var/log/mailog finde ich keine brauchbaren Informationen. Hat jemand nen Tipp wo ich nachschauen kann, was nicht stimmt?
_________________
Ich neige zur Redundanz und manchmal wiederhole ich mich auch
Back to top
View user's profile Send private message
Hollowman
Guru
Guru


Joined: 19 Apr 2007
Posts: 584

PostPosted: Sun Sep 30, 2012 9:31 am    Post subject: Reply with quote

Hi

Ich arbeite mit Dovecot, also kann ich dir zu Courier-imap nicht wirklich was sagen.

Guck doch bitte mal ob du unter /var/log irgendwo ein spezielles Log zu Courier-imap hast.

Wenn du nix findest, mach mal ein grep -rsl USERNAME /var/log. Wobei USERNAME durch den Benutzer zu ersetzen ist mit dem du dich am IMAP anmelden willst.

Die mysql DB läuft?

Sebastian
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1088
Location: Buchholz/GER

PostPosted: Sun Sep 30, 2012 11:34 am    Post subject: Reply with quote

Ich hätte eher den saslauthd im Verdacht ... aber in der Tat, ohne Logfiles wird das schwierig. Irgendwo muss was sein, ansonsten mal gucken, wo und wie man den Debuglevel von courier hochsetzen kann. Irgendwann muss was im maillog auftauchen.
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
xenobyte
n00b
n00b


Joined: 30 Nov 2011
Posts: 14

PostPosted: Wed Oct 10, 2012 8:28 pm    Post subject: Reply with quote

Ich hab nochmal 'n bisschen dran gebastelt. Mit meinem lokalen Account kann ich mich ohne Probleme einloggen. Ich hab allerdings einen virtuellen (für meine Mailinglisten) erstellt. Ich hab festgestellt das ich im Eifer des Gefechts wirklich ein

Code:

# mkdir -p /home/vmail/virt-domain.com/foo
# chown -R vmail:vmail /home/vmail/virt-domain.com
# maildirmake /home/vmail/virt-domain.com/foo/.maildir


vergessen hatte. Das Verzeichnis existiert also.

(domain.com, HOSTNAME und foo sind natürlich nur beispielhaft und haben sonst konkrete Werte)

In der MySQL-DB steht für den Benutzer folgendes

Code:

id  email                          clear                  name  uid      gid      homedir         maildir
2   lists@domain.com   meinPasswort   lists    1101   1101   /home/vmail   /home/vmail/domain.com/foo/.maildir/



Wenn ich mich jetzt via SquirrelMail einloggen möchte, kommt wieder die Fehlermeldung: ERROR: Connection dropped by IMAP server.

Ein grep -rsl USERNAME /var/log bringt in /var/log/maillog nur Meldungen über Mails die nicht zugestellt werden konnten, nichts über einen fehlerhaften Login.

Code:

2012-10-01T02:01:34.935234+02:00 hostname postfix/smtp[1256]: 7CF6FEE064: to=<gentoo-announce+bounces-probe-lists=domain.com@lists.gentoo.org>, relay=lists.gentoo.org[208.92.234.80]:25, delay=1.4, delays=0/0.01/1.2/0.24, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 78FBE21C0B0)


Irgendwelche Vorschläge? Ich spiele sonst mit dem Gedanken den User "lists" vorerst lokal einzurichten, damit ich zumindest die Mails kriege, aber wäre halt schön, wenn ich das gleich virtuell einrichten könnte...
_________________
Ich neige zur Redundanz und manchmal wiederhole ich mich auch
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4123

PostPosted: Thu Oct 11, 2012 6:12 am    Post subject: Reply with quote

eventuell kann man in der konfiguration von Courier-imap logging aktivieren.
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
xenobyte
n00b
n00b


Joined: 30 Nov 2011
Posts: 14

PostPosted: Thu Oct 11, 2012 9:28 am    Post subject: Reply with quote

firefly wrote:
eventuell kann man in der konfiguration von Courier-imap logging aktivieren.


Ich hab dahingehend nichts brauchbares finden können, außer über /etc/authdaemonrc und den verwende ich nicht...

Wenn ich mich via telnet einloggen will bekomme ich sowas

Code:

hostname ~ # telnet localhost 443
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
login lists meinpasswort
Connection closed by foreign host.


Der Server sollte aber wohl sowas wie

Code:


Connected to imap.example.com.
Escape character is '^]'.
* OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THRE
AD=REFERENCES SORT QUOTA IDLE AUTH=CRAM-MD5 SMAP1 KEYWORDS ACL ACL2=UNION STARTT
LS XMAGICTRASH] Courier-IMAP ready. Copyright 1998-2008 Double Precision, Inc. 
See COPYING for distribution information.


zurückgeben.

In der /var/log/mailog finde ich (wenn ich mich via telnet einlogge) auch was

Code:

2012-10-10T22:34:47.174788+02:00 hostname imapd-ssl: LOGIN FAILED, user=lists, ip=[::ffff:8.16.12.140]
2012-10-10T22:37:35.331202+02:00 hostname imapd-ssl: LOGIN FAILED, user=lists, ip=[::ffff:8.16.12.140]
2012-10-10T22:41:33.816461+02:00 hostname imapd-ssl: LOGIN FAILED, user=lists, ip=[::ffff:8.16.12.140]
2012-10-10T22:51:11.761084+02:00 hostname imapd-ssl: LOGIN FAILED, user=lists, ip=[::ffff:8.16.12.140]
2012-10-10T22:55:58.235292+02:00 hostname imapd-ssl: LOGIN FAILED, user=lists, ip=[::ffff:8.16.12.140]

_________________
Ich neige zur Redundanz und manchmal wiederhole ich mich auch
Back to top
View user's profile Send private message
bbgermany
Veteran
Veteran


Joined: 21 Feb 2005
Posts: 1483
Location: Oranienburg/Germany

PostPosted: Thu Oct 11, 2012 9:49 am    Post subject: Reply with quote

xenobyte wrote:
firefly wrote:
eventuell kann man in der konfiguration von Courier-imap logging aktivieren.


Ich hab dahingehend nichts brauchbares finden können, außer über /etc/authdaemonrc und den verwende ich nicht...

Wenn ich mich via telnet einloggen will bekomme ich sowas

Code:

hostname ~ # telnet localhost 443
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
login lists meinpasswort
Connection closed by foreign host.




Wieso versuchst du ein Telnet auf HTTPS? Wolltest du nicht 993 (IMAPS)?


xenobyte wrote:

Der Server sollte aber wohl sowas wie

Code:


Connected to imap.example.com.
Escape character is '^]'.
* OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THRE
AD=REFERENCES SORT QUOTA IDLE AUTH=CRAM-MD5 SMAP1 KEYWORDS ACL ACL2=UNION STARTT
LS XMAGICTRASH] Courier-IMAP ready. Copyright 1998-2008 Double Precision, Inc. 
See COPYING for distribution information.


zurückgeben.

In der /var/log/mailog finde ich (wenn ich mich via telnet einlogge) auch was

Code:

2012-10-10T22:34:47.174788+02:00 hostname imapd-ssl: LOGIN FAILED, user=lists, ip=[::ffff:8.16.12.140]
2012-10-10T22:37:35.331202+02:00 hostname imapd-ssl: LOGIN FAILED, user=lists, ip=[::ffff:8.16.12.140]
2012-10-10T22:41:33.816461+02:00 hostname imapd-ssl: LOGIN FAILED, user=lists, ip=[::ffff:8.16.12.140]
2012-10-10T22:51:11.761084+02:00 hostname imapd-ssl: LOGIN FAILED, user=lists, ip=[::ffff:8.16.12.140]
2012-10-10T22:55:58.235292+02:00 hostname imapd-ssl: LOGIN FAILED, user=lists, ip=[::ffff:8.16.12.140]


Bei sowas habe ich meistens auch den saslauthd im Verdacht.

MfG. Stefan
_________________
1st: i5-4440 3.1GHz, 16GB, 900GB, HD4850
2nd: Celeron 2.6GHz, 2GB, 500GB, HD4350
3rd: TP X220, 2,5GHz, 8GB, 320GB, HD3000
4th: Athlon X2 BE-2300, 4GB, 64GB + 3TB DATA + 4TB BACKUP
5th: Samung N350, 2GB, 250GB, HD3150
6th: Rasperry Pi, 512MB, 32GB SD
Back to top
View user's profile Send private message
xenobyte
n00b
n00b


Joined: 30 Nov 2011
Posts: 14

PostPosted: Thu Oct 11, 2012 9:59 am    Post subject: Reply with quote

bbgermany wrote:


Wieso versuchst du ein Telnet auf HTTPS? Wolltest du nicht 993 (IMAPS)?


NARF! Dummer copy&paste Fehler. Das war die Ausgabe von Port 993. Ist also alles identisch.

Ich hab in der /etc/conf.d/saslauthd mal log_level auf 5 gesetzt. Kann bisher keine weiteren Infos aus der maillog entnehmen.

Nachtrag: Ich hab noch folgendes gefunden:
Code:

2012-10-11T12:38:45.085474+02:00 hostname imapd-ssl: An unexpected TLS packet was received.


spricht das jetzt für courier-imap oder für saslauthd?
_________________
Ich neige zur Redundanz und manchmal wiederhole ich mich auch
Back to top
View user's profile Send private message
xenobyte
n00b
n00b


Joined: 30 Nov 2011
Posts: 14

PostPosted: Fri Oct 12, 2012 11:51 am    Post subject: Reply with quote

*push*

Ich habe aufgegeben und auf diese Lösung hier gesetzt: http://en.gentoo-wiki.com/wiki/Mail_server_using_Postfix_and_Dovecot#Dovecot_Integration_-_LDA

Resultat ist leider das Selbe, aber die Fehlermeldungen sind ansprechender:

Code:

2012-10-12T13:30:40.330320+02:00 t3227 dovecot: auth-worker(27440): Error: sql(xenobyte@domain.com,88.888.888.88): Password query failed: Table 'mailsql.users' doesn't exist (using built-in default password_query: SELECT username, domain, password FROM users WHERE username = '%n' AND domain = '%d')


Okay... die Tabelle die dovecot abfragen soll heißt auch "mailbox" und nicht users. Ich kann die Stelle leider nicht finden, wo ich diese Tabelle angeben muss.

EDIT: Ich hab einfach mal password_query in /etc/dovecot/dovecot-sql.conf.ext gesetzt. Die Meldung ist auch weg.

nun kommt

Code:

2012-10-12T14:00:41.202515+02:00 t3227 dovecot: imap-login: Aborted login (no auth attempts in 0 secs): user=<>, rip=31.187.111.45, lip=18.254.5.76, session=<S8DSb9vLKgBQu28t>


sollte bei "user" nicht vielleicht mein Benutzername stehen? Geht der unterwegs verloren?!
_________________
Ich neige zur Redundanz und manchmal wiederhole ich mich auch
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum