Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
failed to emerge media-fonts/urw-fonts-2.4.9
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
LoTeK
Apprentice
Apprentice


Joined: 26 Jul 2012
Posts: 270

PostPosted: Sun Nov 04, 2012 6:02 pm    Post subject: failed to emerge media-fonts/urw-fonts-2.4.9 Reply with quote

hi
after a fresh gentoo install, I'm trying to install "terminator" and after setting new use flags:
    cairo, gtk3, python

and running
Code:
emerge --update --deep --newuse world

afterwards, I get the following error message:
http://bpaste.net/show/55795


Last edited by LoTeK on Sun Nov 04, 2012 7:22 pm; edited 3 times in total
Back to top
View user's profile Send private message
LoTeK
Apprentice
Apprentice


Joined: 26 Jul 2012
Posts: 270

PostPosted: Sun Nov 04, 2012 6:08 pm    Post subject: Reply with quote

I've just seen this thread:
http://forums.gentoo.org/viewtopic-t-905950-start-0.html

but
Code:
 emerge --sync
doesn't solve the problem.
output of
Code:
emerge --info '=media-fonts/urw-fonts-2.4.9'


http://bpaste.net/show/55799
Back to top
View user's profile Send private message
LoTeK
Apprentice
Apprentice


Joined: 26 Jul 2012
Posts: 270

PostPosted: Sun Nov 04, 2012 10:00 pm    Post subject: Reply with quote

first: sorry for not posting in "programming and portage". in the heat of the battle I thought it has something to do with installing...

well this is at least the fifth time I do a reinstall and never occured such a strange problem. on my other machine
Code:
media-fonts/urw-fonts-2.4.9

was installed without problems and now its an *.rpm file..!?
anyway after sweating and crying I've managed to convert the file with
Code:
rpm2tar

then I've installed it normaly.
So I'm fine after spending the whole sunday with our beloved distribution, at least for the moment... :D
Back to top
View user's profile Send private message
cach0rr0
Moderator
Moderator


Joined: 13 Nov 2008
Posts: 4122
Location: Houston, Republic of Texas

PostPosted: Sun Nov 04, 2012 10:32 pm    Post subject: Reply with quote

LoTeK wrote:
first: sorry for not posting in "programming and portage".


no worries. moved :)

(sorry i have no idea about your issue - if the ebuild is looking for tar, but the package is an rpm, the ebuild is broken and someone must fix it!)
_________________
Lost configuring your system?
dump lspci -n here | see Pappy's guide | Link Stash
Back to top
View user's profile Send private message
LoTeK
Apprentice
Apprentice


Joined: 26 Jul 2012
Posts: 270

PostPosted: Sun Nov 04, 2012 10:39 pm    Post subject: Reply with quote

Quote:
(sorry i have no idea about your issue - if the ebuild is looking for tar, but the package is an rpm, the ebuild is broken and someone must fix it!)

yes, but strangly it worked without problems as I've installed gentoo on my desktop only one week ago..
Back to top
View user's profile Send private message
khayyam
Advocate
Advocate


Joined: 07 Jun 2012
Posts: 2248

PostPosted: Mon Nov 05, 2012 4:09 pm    Post subject: Reply with quote

LoTeK ... for whatever reason your missing app-arch/rpm2targz or the binary/link (/usr/bin/rpm2tar -> rpm2targz) is broken ... this package is a dependency for media-fonts/urw-fonts so it should be installed prior:

Code:
# equery depends app-arch/rpm2targz
 * These packages depend on app-arch/rpm2targz:
media-fonts/urw-fonts-2.4.9 (>=app-arch/rpm2targz-9.0.0.3g)

So, I would perhaps 'emerge --oneshot rpm2targz' and see if this fixes it. Also, as rpm2targz is not only for tgz but lzma, bzip2, etc, perhaps the difference between your respective machines is one has app-arch/xz-utils and the problem machine not (though I can't say for sure as I'm not sure what format the src.rpm is in).

best ... khay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum