Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Randomly getting black screens on bootup
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
deutronium
n00b
n00b


Joined: 15 Jan 2008
Posts: 16

PostPosted: Thu Oct 11, 2012 12:44 pm    Post subject: Randomly getting black screens on bootup Reply with quote

The console randomly becomes black during startup. I believe this is due to having both
an Intel and AMD graphics card.

I've compiled the Intel device driver into the kernel, with modesetting.
But not the radeon driver to avoid conflicts with fglrx.

I've pasted my kernel config here http://bpaste.net/show/50551/

I've setup support for VGA switcheroo, but the device doesn't seem to be created in /sys.

Thanks in advance
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5256

PostPosted: Thu Oct 11, 2012 1:23 pm    Post subject: Reply with quote

I'm not sure you can have more than one card enabled at a time. Have you tried turning one of them off in the BIOS?
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
deutronium
n00b
n00b


Joined: 15 Jan 2008
Posts: 16

PostPosted: Thu Oct 11, 2012 1:32 pm    Post subject: Reply with quote

Sorry yeah, they can't be enabled both at once, it's called 'switchable graphics' apparently.
There aren't any BIOS settings unfourtunately.
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8911

PostPosted: Fri Oct 12, 2012 1:24 am    Post subject: Reply with quote

Does it work if you have only one graphics driver? The phrasing of your first post implies that you are attempting to use both the open Intel driver and the proprietary AMD driver.
Back to top
View user's profile Send private message
deutronium
n00b
n00b


Joined: 15 Jan 2008
Posts: 16

PostPosted: Fri Oct 12, 2012 7:57 pm    Post subject: Reply with quote

Even with fglrx blacklisted i still randomly get black screens at startup which is really frustrating!
Back to top
View user's profile Send private message
deutronium
n00b
n00b


Joined: 15 Jan 2008
Posts: 16

PostPosted: Sat Oct 13, 2012 6:04 pm    Post subject: Reply with quote

I've enabled a framebuffer, and found there seems to be a bug when the intel driver is loading which sometimes seems to make the display go blank.

Weirdly if you load i915, fglrx and X straight away the display then works.

#!/bin/bash
sudo insmod /lib/modules/3.4.9-gentoo/kernel/drivers/gpu/drm/i915/i915.ko
sudo modprobe fglrx
startxfce4

But I don't think this is an especially good solution.
Back to top
View user's profile Send private message
Matias Jose Seco
n00b
n00b


Joined: 24 Sep 2011
Posts: 22

PostPosted: Sat Oct 13, 2012 9:46 pm    Post subject: Reply with quote

Are you encountering the following dmesg alert?

Code:
[Firmware Bug]: ACPI: No _BQC method, cannot determine initial brightness


If so, your issue could be the same as described here
Moreover, if that's the case, there where proposed some workarounds
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum