Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Steam breaks with latest app-emulation/emul-linux-x86-opengl
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 10154
Location: Córdoba (Spain)

PostPosted: Sun Jan 11, 2015 12:38 pm    Post subject: Steam breaks with latest app-emulation/emul-linux-x86-opengl Reply with quote

Hi.

I can't report the bug right now, will do later.

But in case someone else hits this (Sunday is truly a bad day for Steam to break :lol:)...

Today, I updated app-emulation/emul-linux-x86-opengl-20140508 to app-emulation/emul-linux-x86-opengl-20140508-r1 on a machine that's using nvidia's binary blob. The latest driver pushes eselect-opengl-1.3.1-r1, both from ~arch.

After that, steam won't work, and it outputted something about it trying to use the swrast opengl driver.

When trying to revert to app-emulation/emul-linux-x86-opengl-20140508 I found that eselect-opengl-1.3.1 has been ripped out of portage. Can't bother to check why right now. What I did was to pick it from the attic of dead ebuilds and put it in my local overlay, after that I downgraded eselect-opengl and app-emulation/emul-linux-x86-opengl and now Steam works again.

This might help someone who hits the same problem. I will report the bug when I have the time, in the while you might want to mask any versions above app-emulation/emul-linux-x86-opengl-20140508 and eselect-opengl-1.3.1, though that's obviously not a proper solution. Still it will allow you to spend a happy Synday :lol:
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
tw04l124
Veteran
Veteran


Joined: 03 Oct 2006
Posts: 1868
Location: A t z e l, lower austria

PostPosted: Sun Jan 11, 2015 12:46 pm    Post subject: Reply with quote

Hello,

Is this maybe an issue about this? http://forums.gentoo.org/viewtopic-p-7681260.html#7681260

Is glx working for you?
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 10154
Location: Córdoba (Spain)

PostPosted: Sun Jan 11, 2015 12:49 pm    Post subject: Reply with quote

I don't think it's related. 64-bit stuff works, and dri is working as well. It's only 32 bits stuff which fails, an downgrading the opengl emul package 'fixes' it.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum