Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
digikam:leer escribir sidecar files deshabilitado[SOLUCIONAD
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
carlos.gentoo
n00b
n00b


Joined: 16 Sep 2012
Posts: 13

PostPosted: Sun Sep 23, 2012 9:02 am    Post subject: digikam:leer escribir sidecar files deshabilitado[SOLUCIONAD Reply with quote

Pues os comento un nuevo problema con mi reciente instalación de gentoo (quizás esta vez no tenga nada que ver con Gentoo y sea un problema de digikam ...).
El caso es que me instalé este programa (digikam 2.6.0) y en las opciones de configuración, en el apartado de 'Reading and Writing Metadata' me aparecen todas las opciones deshabilitadas (quiero decir, aparecen en gris y no puedo cambiar sus valores).

En /etc/portage/package.use tengo la linea:

Code:
media-gfx/digikam addressbook thumbnails video gphoto2


Mis USE flags:

Code:
USE="X unicode samba ppds ssl cups nls qt4 kde dvd alsa cdr consolekit dbus policykit udev udisks sse sse2 mmx dri cups opencl opengl tiff png raw pdf jpeg jpeg2k xmp exif ffmpeg -gtk -gnome "


¿Alguna idea?


Last edited by carlos.gentoo on Mon Oct 01, 2012 10:09 pm; edited 1 time in total
Back to top
View user's profile Send private message
cohone
Tux's lil' helper
Tux's lil' helper


Joined: 27 Mar 2006
Posts: 113

PostPosted: Mon Sep 24, 2012 11:25 am    Post subject: Reply with quote

Prueba a instalar los kipi-plugins, aunque no estoy seguro que sea eso, ahora no tengo mi gentoo a mano, pero sí se que uno de los plugins es un editor de metadata.
Back to top
View user's profile Send private message
carlos.gentoo
n00b
n00b


Joined: 16 Sep 2012
Posts: 13

PostPosted: Tue Sep 25, 2012 2:28 pm    Post subject: Reply with quote

He instalado los kipi-plugins pero no hubo suerte, las opciones siguen deshabilitadas. He mirado en la configuración de los complementos kipi dentro de digikam y efectivamente me aparece uno 'Editar metadatos' que, según su descripción, permite la edición de datos XMP. Lo tengo activado (lo he desactivado y vuelto a activar por si acaso... pero nada).
Otra cosa que he visto, para ver los datos de una imagen (botón 'Metadatos' de la barra derecha), me aparecen 3 pestañas (EXIF, Notas del fabricante, IPTC). Aquí debería aparecer también la pestaña de datos XMP (al menos en la versión que tenía sobre OpenSuse aparecía, aunque creo que ahí la versión que tenía era la 2.5.0 ).
¿Igual falta alguna opción para que compile con soporte XMP? (aunque tengo activado el flag XMP en las USE)
Back to top
View user's profile Send private message
carlos.gentoo
n00b
n00b


Joined: 16 Sep 2012
Posts: 13

PostPosted: Mon Oct 01, 2012 10:07 pm    Post subject: Solución Reply with quote

Finalmente el equipo de Digikam me contestaron que debía existir algún problema con la librería libkexiv2 (aunque tengo el flag para compilar con soporte XMP, quizás esta llibrería se instaló antes de que lo activara...).
En cualquier caso, reinstalé esta librería y se solucionó el problema.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum