Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome randomly crashing.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
dromero
n00b
n00b


Joined: 24 Mar 2011
Posts: 7
Location: México

PostPosted: Thu Jun 13, 2013 5:53 pm    Post subject: Gnome randomly crashing. Reply with quote

Recently I upgraded my Gnome to 3.6.2. However, since the upgrading I have been experimenting random crashings of the Gnome-Shell (I guess), causing it to restart X-Server. It is very difficult for me to isolate the cause of these crashings (or the events that trigger them), but I can tell for sure that it ALWAYS happens when I change the brightness of the screen on my laptop very quicly, same thing with volume control (using multimedia keys). These, of course, are not the only circumstances where a crashing occurs.

I would appreciate if someone can tell me where can I find some logs for Gnome, in order to have an idea of the problem.
I have never submitted a question in the forums and I have never filled a bug report, so I have no idea what kind of support you need in order to help me.

Thanks in advance.
_________________
Gentoo: the fastest underwater swimming penguins, reaching speeds of 36 km/h.
Gentoo are built for very harsh cold climates.

--Wikipedia
Back to top
View user's profile Send private message
dE_logics
Advocate
Advocate


Joined: 02 Jan 2009
Posts: 2200
Location: $TERM

PostPosted: Thu Jun 13, 2013 6:23 pm    Post subject: Reply with quote

This does not appear to be a Gnome problem, instead a X problem. A crash of Gnome should not restart X unless the DM is playing around.

Post output of /var/log/Xorg.0.log, dmesg just after the crash.

Also was X upgraded? If it was upgraded after Gnome, there could be an ABI mismatch which can be fixed by remerging all Gnome libraries.
_________________
Buy from companies supporting opensource -- IBM, Dell, HP, Hitachi, Google etc...
Disfavor companies supporting only Win -- Logitech, Epson, Pioneer, Kingston, WD, Yahoo, MSI, XFX, Huawei
My blog
Back to top
View user's profile Send private message
dromero
n00b
n00b


Joined: 24 Mar 2011
Posts: 7
Location: México

PostPosted: Thu Jun 13, 2013 9:33 pm    Post subject: Reply with quote

The last 100 lines of DMESG (I hope is enough)

Code:
[   25.709490] tg3 0000:0b:00.0: eth0: attached PHY is 5761 (10/100/1000Base-T Ethernet) (WireSpeed[1], EEE[0])
[   25.709493] tg3 0000:0b:00.0: eth0: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] TSOcap[1]
[   25.709494] tg3 0000:0b:00.0: eth0: dma_rwctrl[76180000] dma_mask[64-bit]
[   25.720442] systemd-udevd[1463]: renamed network interface eth0 to enp11s0
[   25.728468] HDA Intel 0000:00:1b.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
[   25.728539] HDA Intel 0000:00:1b.0: irq 42 for MSI/MSI-X
[   25.728568] HDA Intel 0000:00:1b.0: setting latency timer to 64
[   26.095994] wl: module license 'MIXED/Proprietary' taints kernel.
[   26.095997] Disabling lock debugging due to kernel taint
[   26.100777] wl 0000:02:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[   26.100788] wl 0000:02:00.0: setting latency timer to 64
[   26.135617] INFO @wl_cfg80211_attach : Registered CFG80211 phy
[   26.173232] lib80211_crypt: registered algorithm 'TKIP'
[   26.173523] eth0: Broadcom BCM4727 802.11 Hybrid Wireless Controller 6.30.223.30 (r390414)
[   26.181298] systemd-udevd[1466]: renamed network interface eth0 to wlp2s0
[   26.535734] Bluetooth: Core ver 2.16
[   26.535753] NET: Registered protocol family 31
[   26.535754] Bluetooth: HCI device and connection manager initialized
[   26.535756] Bluetooth: HCI socket layer initialized
[   26.545840] Linux video capture interface: v2.00
[   26.551694] uvcvideo: Found UVC 1.00 device Laptop_Integrated_Webcam_2M (0c45:6419)
[   26.560478] input: Laptop_Integrated_Webcam_2M as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4/1-1.4:1.0/input/input9
[   26.560528] usbcore: registered new interface driver uvcvideo
[   26.560530] USB Video Class driver (v1.1.0)
[   26.715598] Bluetooth: Generic Bluetooth USB driver ver 0.6
[   26.715842] usbcore: registered new interface driver btusb
[   27.069765] cfg80211: World regulatory domain updated:
[   27.069768] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   27.069770] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   27.069771] cfg80211:     (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   27.069773] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   27.069774] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   27.069775] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   27.090664] HDMI status: Pin=4 Presence_Detect=0 ELD_Valid=0
[   27.091033] HDMI status: Pin=5 Presence_Detect=0 ELD_Valid=0
[   27.094830] input: HDA Intel Mic at Sep Left Jack as /devices/pci0000:00/0000:00:1b.0/sound/card0/input10
[   27.094912] input: HDA Intel Mic at Ext Left Jack as /devices/pci0000:00/0000:00:1b.0/sound/card0/input11
[   27.094966] input: HDA Intel Line Out at Sep Left Jack as /devices/pci0000:00/0000:00:1b.0/sound/card0/input12
[   27.095053] input: HDA Intel HP Out at Ext Left Jack as /devices/pci0000:00/0000:00:1b.0/sound/card0/input13
[   27.095194] input: HDA Intel HDMI/DP as /devices/pci0000:00/0000:00:1b.0/sound/card0/input14
[   27.095281] input: HDA Intel HDMI/DP as /devices/pci0000:00/0000:00:1b.0/sound/card0/input15
[   28.991088] EXT4-fs (sda7): re-mounted. Opts: user_xattr
[   29.084104] Adding 4096536k swap on /dev/sda6.  Priority:-1 extents:1 across:4096536k
[   35.981751] tg3 0000:0b:00.0: irq 43 for MSI/MSI-X
[   40.317994] [drm:i915_gem_execbuffer2] *ERROR* copy 1 exec entries failed 56
[   60.698321] ata1.00: configured for UDMA/133
[   60.698328] ata1: EH complete
[   61.632289] EXT4-fs (sda7): re-mounted. Opts: user_xattr,commit=0
[  305.623762] kworker/u:0 used greatest stack depth: 3808 bytes left
[  834.419147] cfg80211: Calling CRDA to update world regulatory domain
[  834.424074] cfg80211: World regulatory domain updated:
[  834.424076] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[  834.424078] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  834.424080] cfg80211:     (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  834.424081] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  834.424083] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  834.424084] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 1274.475805] fuse init (API version 7.16)
[ 6344.220492] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6344.220608] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6350.206456] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6350.206470] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6356.192397] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6356.192409] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6362.177293] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6362.177306] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6368.162313] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6368.162324] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6374.147261] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6374.147273] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6380.132272] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6380.132284] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6386.117184] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6386.117195] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6392.102138] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6392.102150] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6398.086996] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6398.087009] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6404.072058] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6404.072069] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6410.057011] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6410.057023] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6416.041968] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6416.041979] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6422.026929] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6422.026941] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6428.011845] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6428.011856] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6433.996853] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6433.996866] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6439.981787] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6439.981800] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6445.966753] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6445.966765] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6451.951675] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6451.951687] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6457.936632] ERROR @wl_cfg80211_get_station : Wrong Mac address
[ 6457.936645] ERROR @wl_cfg80211_get_station : Wrong Mac address
[13108.980764] [drm:i915_gem_execbuffer2] *ERROR* copy 1 exec entries failed 56
[13150.353153] mission-control[3392]: segfault at 0 ip 00007f3540333300 sp 00007fffa0bd4e88 error 4 in libglib-2.0.so.0.3400.3[7f35402f8000+123000]


And the last 100 lines of Xorg.0.log:
Code:
[    47.171] (**) DualPoint Stick: (accel) keeping acceleration scheme 1
[    47.171] (**) DualPoint Stick: (accel) acceleration profile 0
[    47.171] (**) DualPoint Stick: (accel) acceleration factor: 2.000
[    47.171] (**) DualPoint Stick: (accel) acceleration threshold: 4
[    47.172] (II) config/udev: Adding input device DualPoint Stick (/dev/input/mouse0)
[    47.172] (**) DualPoint Stick: Applying InputClass "keyboard-all"
[    47.172] (II) Using input driver 'evdev' for 'DualPoint Stick'
[    47.172] (**) DualPoint Stick: always reports core events
[    47.172] (**) evdev: DualPoint Stick: Device: "/dev/input/mouse0"
[    47.172] (EE) evdev: DualPoint Stick: ioctl EVIOCGBIT for bitmask in EvdevOpenMTDev failed: Inappropriate ioctl for device
[    47.172] (EE) DualPoint Stick: Couldn't open mtdev device
[    47.190] (EE) PreInit returned 2 for "DualPoint Stick"
[    47.190] (II) UnloadModule: "evdev"
[    47.190] (II) config/udev: Adding input device AlpsPS/2 ALPS DualPoint TouchPad (/dev/input/event7)
[    47.190] (**) AlpsPS/2 ALPS DualPoint TouchPad: Applying InputClass "evdev touchpad catchall"
[    47.190] (**) AlpsPS/2 ALPS DualPoint TouchPad: Applying InputClass "touchpad catchall"
[    47.190] (**) AlpsPS/2 ALPS DualPoint TouchPad: Applying InputClass "Default clickpad buttons"
[    47.190] (**) AlpsPS/2 ALPS DualPoint TouchPad: Applying InputClass "keyboard-all"
[    47.190] (**) AlpsPS/2 ALPS DualPoint TouchPad: Applying InputClass "touchpad catchall"
[    47.190] (II) LoadModule: "synaptics"
[    47.190] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
[    47.214] (II) Module synaptics: vendor="X.Org Foundation"
[    47.214]    compiled for 1.14.1.901, module version = 1.7.1
[    47.214]    Module class: X.Org XInput Driver
[    47.214]    ABI class: X.Org XInput driver, version 19.1
[    47.214] (II) Using input driver 'synaptics' for 'AlpsPS/2 ALPS DualPoint TouchPad'
[    47.214] (**) AlpsPS/2 ALPS DualPoint TouchPad: always reports core events
[    47.214] (**) Option "Device" "/dev/input/event7"
[    47.235] (II) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: ignoring touch events for semi-multitouch device
[    47.235] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: x-axis range 0 - 2000 (res 0)
[    47.235] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: y-axis range 0 - 1400 (res 0)
[    47.235] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: pressure range 0 - 127
[    47.235] (II) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: device does not report finger width.
[    47.235] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: buttons: left right middle double triple
[    47.235] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: Vendor 0x2 Product 0x8
[    47.235] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: invalid finger width range.  defaulting to 0 - 15
[    47.235] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: touchpad found
[    47.235] (**) AlpsPS/2 ALPS DualPoint TouchPad: always reports core events
[    47.245] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input7/event7"
[    47.245] (II) XINPUT: Adding extended input device "AlpsPS/2 ALPS DualPoint TouchPad" (type: TOUCHPAD, id 14)
[    47.245] (**) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[    47.245] (**) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: (accel) MaxSpeed is now 1.75
[    47.245] (**) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: (accel) AccelFactor is now 0.082
[    47.245] (**) AlpsPS/2 ALPS DualPoint TouchPad: (accel) keeping acceleration scheme 1
[    47.245] (**) AlpsPS/2 ALPS DualPoint TouchPad: (accel) acceleration profile 1
[    47.245] (**) AlpsPS/2 ALPS DualPoint TouchPad: (accel) acceleration factor: 2.000
[    47.245] (**) AlpsPS/2 ALPS DualPoint TouchPad: (accel) acceleration threshold: 4
[    47.245] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: touchpad found
[    47.245] (II) config/udev: Adding input device AlpsPS/2 ALPS DualPoint TouchPad (/dev/input/mouse1)
[    47.245] (**) AlpsPS/2 ALPS DualPoint TouchPad: Ignoring device from InputClass "touchpad ignore duplicates"
[    48.590] (II) intel(0): EDID vendor "LGD", prod id 585
[    48.590] (II) intel(0): Printing DDC gathered Modelines:
[    48.590] (II) intel(0): Modeline "1280x800"x0.0   74.80  1280 1334 1378 1472  800 809 817 846 +hsync -vsync (50.8 kHz eP)
[    48.590] (II) intel(0): Modeline "1280x800"x0.0   49.87  1280 1334 1378 1472  800 809 817 846 +hsync -vsync (33.9 kHz e)
[    58.613] (II) intel(0): EDID vendor "LGD", prod id 585
[    58.613] (II) intel(0): Printing DDC gathered Modelines:
[    58.613] (II) intel(0): Modeline "1280x800"x0.0   74.80  1280 1334 1378 1472  800 809 817 846 +hsync -vsync (50.8 kHz eP)
[    58.613] (II) intel(0): Modeline "1280x800"x0.0   49.87  1280 1334 1378 1472  800 809 817 846 +hsync -vsync (33.9 kHz e)
[  1266.047] (II) intel(0): switch to mode 1024x768 on pipe 0 using eDP1
[  1267.561] (II) intel(0): switch to mode 1024x768 on pipe 1 using VGA1
[  1277.252] (II) intel(0): EDID vendor "LGD", prod id 585
[  1277.252] (II) intel(0): Printing DDC gathered Modelines:
[  1277.252] (II) intel(0): Modeline "1280x800"x0.0   74.80  1280 1334 1378 1472  800 809 817 846 +hsync -vsync (50.8 kHz eP)
[  1277.252] (II) intel(0): Modeline "1280x800"x0.0   49.87  1280 1334 1378 1472  800 809 817 846 +hsync -vsync (33.9 kHz e)
[  1277.954] (II) intel(0): resizing framebuffer to 2880x900
[  1277.954] (II) intel(0): switch to mode 1024x768 on pipe 0 using eDP1
[  1278.027] (II) intel(0): switch to mode 1024x768 on pipe 1 using VGA1
[  1278.079] (II) intel(0): switch to mode 1280x800 on pipe 0 using eDP1
[  1280.417] (II) intel(0): switch to mode 1600x900 on pipe 1 using VGA1
[  1282.549] (II) intel(0): EDID vendor "LGD", prod id 585
[  1282.549] (II) intel(0): Printing DDC gathered Modelines:
[  1282.549] (II) intel(0): Modeline "1280x800"x0.0   74.80  1280 1334 1378 1472  800 809 817 846 +hsync -vsync (50.8 kHz eP)
[  1282.549] (II) intel(0): Modeline "1280x800"x0.0   49.87  1280 1334 1378 1472  800 809 817 846 +hsync -vsync (33.9 kHz e)
[  5953.565] (II) intel(0): switch to mode 1280x800 on pipe 0 using eDP1
[  5955.069] (II) intel(0): switch to mode 1600x900 on pipe 1 using VGA1
[  7492.813] (II) intel(0): switch to mode 1280x800 on pipe 0 using eDP1
[  7494.323] (II) intel(0): switch to mode 1600x900 on pipe 1 using VGA1
[  8819.186] (II) intel(0): EDID vendor "LGD", prod id 585
[  8819.186] (II) intel(0): Printing DDC gathered Modelines:
[  8819.186] (II) intel(0): Modeline "1280x800"x0.0   74.80  1280 1334 1378 1472  800 809 817 846 +hsync -vsync (50.8 kHz eP)
[  8819.186] (II) intel(0): Modeline "1280x800"x0.0   49.87  1280 1334 1378 1472  800 809 817 846 +hsync -vsync (33.9 kHz e)
[  8821.032] (II) intel(0): resizing framebuffer to 1280x800
[  8821.041] (II) intel(0): switch to mode 1280x800 on pipe 0 using eDP1
[ 11531.448] (II) intel(0): switch to mode 1280x800 on pipe 0 using eDP1
[ 13135.389] (II) AIGLX: Suspending AIGLX clients for VT switch
[ 13182.575] (II) AIGLX: Resuming AIGLX clients after VT switch
[ 13183.021] (EE) intel(0): drmSetMaster failed: Invalid argument
[ 13183.021] (EE)
Fatal server error:
[ 13183.021] (EE) EnterVT failed for screen 0
[ 13183.021] (EE)
[ 13183.021] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[ 13183.021] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 13183.021] (EE)
[ 13183.021] (II) AIGLX: Suspending AIGLX clients for VT switch
[ 13183.021] (WW) intel(0): drmDropMaster failed: Invalid argument
[ 13183.129] (EE) Server terminated with error (1). Closing log file.

_________________
Gentoo: the fastest underwater swimming penguins, reaching speeds of 36 km/h.
Gentoo are built for very harsh cold climates.

--Wikipedia
Back to top
View user's profile Send private message
dE_logics
Advocate
Advocate


Joined: 02 Jan 2009
Posts: 2200
Location: $TERM

PostPosted: Fri Jun 14, 2013 7:20 am    Post subject: Reply with quote

This appears to be an Intel driver problem --

Code:
[drm:i915_gem_execbuffer2] *ERROR* copy 1 exec entries failed 56


Code:
intel(0): drmSetMaster failed: Invalid argument


Are you using mutter (in which composting is mandatory)?

Can you try the Gnome fallback mode to see if it doesn't crash?

Also try software rendering using eselect mesa (i915).
_________________
Buy from companies supporting opensource -- IBM, Dell, HP, Hitachi, Google etc...
Disfavor companies supporting only Win -- Logitech, Epson, Pioneer, Kingston, WD, Yahoo, MSI, XFX, Huawei
My blog
Back to top
View user's profile Send private message
dromero
n00b
n00b


Joined: 24 Mar 2011
Posts: 7
Location: México

PostPosted: Sun Jun 16, 2013 10:54 pm    Post subject: Reply with quote

Thank you very much!!

These were the steps I took to repair the damage:
1.- Upgraded the kernel to 3.9.4 (kernel recompilation would sufficed, IMHO).
2.- Changed the mesa libraries to gallium.
3.- Did
Code:
 emerge @x11-module-rebuild.


I have been testing for a couple of days and everything is going great.
One final question... what are the differences between Classic and Gallium mesa?[/code]
_________________
Gentoo: the fastest underwater swimming penguins, reaching speeds of 36 km/h.
Gentoo are built for very harsh cold climates.

--Wikipedia
Back to top
View user's profile Send private message
dE_logics
Advocate
Advocate


Joined: 02 Jan 2009
Posts: 2200
Location: $TERM

PostPosted: Mon Jun 17, 2013 5:46 am    Post subject: Reply with quote

I don't appear to have a good idea.

I think it has to do with making some parts of all kernel DRI drivers common.
_________________
Buy from companies supporting opensource -- IBM, Dell, HP, Hitachi, Google etc...
Disfavor companies supporting only Win -- Logitech, Epson, Pioneer, Kingston, WD, Yahoo, MSI, XFX, Huawei
My blog
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum