Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] xorg-drivers fail!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
rpil
Guru
Guru


Joined: 23 May 2008
Posts: 311

PostPosted: Mon Oct 01, 2012 7:59 pm    Post subject: [SOLVED] xorg-drivers fail! Reply with quote

Fresh install on desktop. Trying to emerge xorg drivers:

Code:
# emerge xorg-drivers

Calculating dependencies... done!

>>> Verifying ebuild manifests
>>> Running pre-merge checks for x11-drivers/xf86-input-synaptics-1.6.2
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/3.3.8-gentoo/build
 * Found sources for kernel version:
 *     3.3.8-gentoo

>>> Starting parallel fetch

>>> Emerging (1 of 4) x11-libs/libXi-1.6.1
 * Fetching files in the background. To view fetch progress, run
 * `tail -f /var/log/emerge-fetch.log` in another terminal.
>>> Downloading 'http://distfiles.gentoo.org/distfiles/libXi-1.6.1.tar.bz2'
--2012-10-01 22:48:01--  http://distfiles.gentoo.org/distfiles/libXi-1.6.1.tar.bz2
Resolving distfiles.gentoo.org... failed: Name or service not known.
wget: unable to resolve host address `distfiles.gentoo.org'
>>> Downloading 'http://xorg.freedesktop.org/releases/individual/lib/libXi-1.6.1.tar.bz2'
--2012-10-01 22:48:01--  http://xorg.freedesktop.org/releases/individual/lib/libXi-1.6.1.tar.bz2
Resolving xorg.freedesktop.org... failed: Name or service not known.
wget: unable to resolve host address `xorg.freedesktop.org'
!!! Couldn't download 'libXi-1.6.1.tar.bz2'. Aborting.
 * Fetch failed for 'x11-libs/libXi-1.6.1', Log file:
 *  '/var/tmp/portage/x11-libs/libXi-1.6.1/temp/build.log'

>>> Failed to emerge x11-libs/libXi-1.6.1, Log file:

>>>  '/var/tmp/portage/x11-libs/libXi-1.6.1/temp/build.log'

 * Messages for package x11-libs/libXi-1.6.1:

 * Fetch failed for 'x11-libs/libXi-1.6.1', Log file:
 *  '/var/tmp/portage/x11-libs/libXi-1.6.1/temp/build.log'


This is the /var/tmp/portage/x11-libs/libXi-1.6.1/temp/build.log:
Code:
>>> Downloading 'http://distfiles.gentoo.org/distfiles/libXi-1.6.1.tar.bz2'
--2012-10-01 22:49:25--  http://distfiles.gentoo.org/distfiles/libXi-1.6.1.tar.$
Resolving distfiles.gentoo.org... failed: Name or service not known.
wget: unable to resolve host address `distfiles.gentoo.org'
>>> Downloading 'http://xorg.freedesktop.org/releases/individual/lib/libXi-1.6.$
--2012-10-01 22:49:25--  http://xorg.freedesktop.org/releases/individual/lib/li$
Resolving xorg.freedesktop.org... failed: Name or service not known.
wget: unable to resolve host address `xorg.freedesktop.org'
!!! Couldn't download 'libXi-1.6.1.tar.bz2'. Aborting.
^[[31;01m * ^[[39;49;00mFetch failed for 'x11-libs/libXi-1.6.1', Log file:
^[[31;01m * ^[[39;49;00m '/var/tmp/portage/x11-libs/libXi-1.6.1/temp/build.log'


Last edited by rpil on Tue Oct 02, 2012 5:28 am; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32320
Location: 56N 3W

PostPosted: Mon Oct 01, 2012 8:06 pm    Post subject: Reply with quote

rpil,

Code:
Resolving xorg.freedesktop.org... failed: Name or service not known.
wget: unable to resolve host address `xorg.freedesktop.org


suggests that something has trampled over /etc/resolv.conf or that your dhcp server does not send you nameserver entries.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Mon Oct 01, 2012 8:41 pm    Post subject: Reply with quote

rpil,

You can temporarily use google's public dns servers 8.8.8.8 and 8.8.4.4 :wink:
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
rpil
Guru
Guru


Joined: 23 May 2008
Posts: 311

PostPosted: Tue Oct 02, 2012 5:27 am    Post subject: Reply with quote

Well, thanks, guys, I still was chroot when I tried this. I made some corrections in the kernel, I booted in command prompt and now it compiles normally. :wink:
Back to top
View user's profile Send private message
Deathwing00
Moderator
Moderator


Joined: 13 Jun 2003
Posts: 4079
Location: Dresden, Germany

PostPosted: Fri Oct 05, 2012 10:04 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Desktop Environments.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum