Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Bus Error when trying to write file system
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
guruwannabe
n00b
n00b


Joined: 04 Oct 2012
Posts: 2

PostPosted: Thu Oct 04, 2012 6:12 pm    Post subject: Bus Error when trying to write file system Reply with quote

Hi, I am installing Gentoo to try and learn Linux but am stuck at Para 4 of the installation guide.

I am installing Gentoo in VirtualBox on an Ubuntu 11.04 host using an AMD64 ISO.

I have created my partitions and am now trying to allocate the file system to them but I keep getting a Bus Error:

livecd ~ # mkfs.ext4 /dev/sda1
Bus Error

Does anyone know what this is and how to solve it?

Instructions for dummies are appreciated.

Thanks
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6656
Location: Goose Creek SC

PostPosted: Thu Oct 04, 2012 7:26 pm    Post subject: Reply with quote

AMD64 ISO has fallen on hard times
use system rescue cd instead
_________________
Defund the FCC.
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4296

PostPosted: Thu Oct 04, 2012 8:12 pm    Post subject: Re: Bus Error when trying to write file system Reply with quote

If you feel more comfy with ubuntu, just create partitions and filesystems with it.
Back to top
View user's profile Send private message
guruwannabe
n00b
n00b


Joined: 04 Oct 2012
Posts: 2

PostPosted: Fri Oct 05, 2012 6:46 pm    Post subject: Reply with quote

After being made aware the problem was with reading information from the ISO CD, I created a new VM and mounted the ISO image in it so Gentoo could read from this instead of having to use the CD. It seems to have done the trick as I have now managed to successfully write the file system to the partitions and complete Chap 4.

Thanks for your help
Back to top
View user's profile Send private message
jlpoole
Apprentice
Apprentice


Joined: 01 Nov 2005
Posts: 232
Location: Napa, CA

PostPosted: Wed Oct 23, 2013 5:12 pm    Post subject: Reply with quote

I had the very same problem. My AMD had an old HP CD reader on it. So I tried the referenced RescueCD, but I couldn't even get the CD to read. So I swapped out CD readers on the machine and then used the Gentoo ISO and I was able to mkfs.ext2 /dev/sda1 and mkfs.ext4 /dev/sda3. So let my posting demonstrate that the CD reader itself, may be the culprit.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum