Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ldd reveals that firefox depends on some missing libraries
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
fturco
Apprentice
Apprentice


Joined: 08 Dec 2010
Posts: 290
Location: Italy

PostPosted: Wed Oct 03, 2012 5:11 pm    Post subject: ldd reveals that firefox depends on some missing libraries Reply with quote

I'm running Firefox 15.0.1 with no apparent problems. Anyway I found that the following files seems to be linked to missing libraries:
Code:
/usr/lib64/firefox/components/libbrowsercomps.so
/usr/lib64/firefox/components/libmozgnome.so
/usr/lib64/firefox/components/libdbusservice.so
/usr/lib64/firefox/plugin-container
/usr/lib64/firefox/libxpcom.so
/usr/lib64/firefox/libxul.so

For example:
Code:
ldd /usr/lib64/firefox/libxul.so | grep "not found"
   libmozsqlite3.so => not found
   libmozalloc.so => not found

Some info about the firefox package:
Code:
emerge -pv firefox

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] www-client/firefox-15.0.1  USE="alsa dbus gstreamer ipc jit minimal webm wifi -bindist -custom-cflags -custom-optimization -debug -libnotify -pgo (-selinux) -startup-notification -system-sqlite" LINGUAS="-af -ak -ar -as -ast -be -bg -bn_BD -bn_IN -br -bs -ca -cs -csb -cy -da -de -el -en_GB -en_ZA -eo -es_AR -es_CL -es_ES -es_MX -et -eu -fa -fi -fr -fy_NL -ga_IE -gd -gl -gu_IN -he -hi_IN -hr -hu -hy_AM -id -is -it -ja -kk -km -kn -ko -ku -lg -lt -lv -mai -mk -ml -mr -nb_NO -nl -nn_NO -nso -or -pa_IN -pl -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv_SE -ta -ta_LK -te -th -tr -uk -vi -zh_CN -zh_TW -zu" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

Is this normal? Should I file a bug report perhaps?

Thank you.
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4280

PostPosted: Wed Oct 03, 2012 6:15 pm    Post subject: Reply with quote

You don't have to filebug if any of your program is broken, except if it was made by the ebuild itself.

For your problem, revdep-rebuild should catch it
Back to top
View user's profile Send private message
fturco
Apprentice
Apprentice


Joined: 08 Dec 2010
Posts: 290
Location: Italy

PostPosted: Wed Oct 03, 2012 8:36 pm    Post subject: Reply with quote

Unfortunately revdep-rebuild doesn't want to rebuild anything. I'd really like to know if anybody else having Mozilla Firefox can confirm this problem.
Back to top
View user's profile Send private message
gentoo_ram
Guru
Guru


Joined: 25 Oct 2007
Posts: 398
Location: San Diego, California USA

PostPosted: Wed Oct 03, 2012 11:46 pm    Post subject: Reply with quote

I get the same thing. Those libraries are in /usr/lib64/firefox. But that path isn't on your default loader library path. I'm sure when you start firefox your LD_LIBRARY_PATH gets modified to include the firefox directory and then everything works. In other words, it's normal.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum