Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sys-fs/lvm2-2.02.88 fails to emerge[SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
todd93
Guru
Guru


Joined: 30 Oct 2006
Posts: 455
Location: Missouri

PostPosted: Tue Oct 02, 2012 8:39 pm    Post subject: sys-fs/lvm2-2.02.88 fails to emerge[SOLVED] Reply with quote

Hi, I tried to keep from having to post a new thread on this, as I had found a thread that had a similar failure, but I was told to start a new thread. So here goes, I have been having trouble with lvm2, it fails during the revdep-rebuild phase and will not emerge. I have also noticed that it fails to start at boot. The failure I get during emerge is the following:
Code:

:
(.text.util_lookup_user+0xc6): warning: Using 'getpwnam_r' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libudev.a(util.o): In function `lookup_uid':
(.text.lookup_uid+0x8b): warning: Using 'getpwuid_r' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
dmsetup.o: In function `main':
dmsetup.c:(.text.startup+0x96d): undefined reference to `udev_get_dev_path'
collect2: ld returned 1 exit status
make[1]: *** [dmsetup.static] Error 1
make[1]: Leaving directory `/var/tmp/portage/sys-fs/lvm2-2.02.88/work/LVM2.2.02.88/tools'
make: *** [tools.device-mapper] Error 2
emake failed
 * ERROR: sys-fs/lvm2-2.02.88 failed (compile phase):
 *   compile fail
 *
 * Call stack:
 *     ebuild.sh, line  85:  Called src_compile
 *   environment, line 3539:  Called die
 * The specific snippet of code:
 *       emake || die "compile fail"
 *
 * If you need support, post the output of `emerge --info '=sys-fs/lvm2-2.02.88'`,
 * the complete build log and the output of `emerge -pqv '=sys-fs/lvm2-2.02.88'`.
 * The complete build log is located at '/var/tmp/portage/sys-fs/lvm2-2.02.88/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-fs/lvm2-2.02.88/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-fs/lvm2-2.02.88/work/LVM2.2.02.88'
 * S: '/var/tmp/portage/sys-fs/lvm2-2.02.88/work/LVM2.2.02.88'

>>> Failed to emerge sys-fs/lvm2-2.02.88, Log file:

>>>  '/var/tmp/portage/sys-fs/lvm2-2.02.88/temp/build.log'

 * Messages for package sys-fs/lvm2-2.02.88:

 * Warning, we no longer overwrite /sbin/lvm and /sbin/dmsetup with
 * their static versions. If you need the static binaries,
 * you must append .static to the filename!
 * ERROR: sys-fs/lvm2-2.02.88 failed (compile phase):
 *   compile fail
 *
 * Call stack:
 *     ebuild.sh, line  85:  Called src_compile
 *   environment, line 3539:  Called die
 * The specific snippet of code:
 *       emake || die "compile fail"
 *
 * If you need support, post the output of `emerge --info '=sys-fs/lvm2-2.02.88'`,
 * the complete build log and the output of `emerge -pqv '=sys-fs/lvm2-2.02.88'`.
 * The complete build log is located at '/var/tmp/portage/sys-fs/lvm2-2.02.88/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-fs/lvm2-2.02.88/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-fs/lvm2-2.02.88/work/LVM2.2.02.88'
 * S: '/var/tmp/portage/sys-fs/lvm2-2.02.88/work/LVM2.2.02.88'
 * revdep-rebuild failed to emerge all packages.
 * you have the following choices:
 * - If emerge failed during the build, fix the problems and re-run revdep-rebuild.
 * - Use /etc/portage/package.keywords to unmask a newer version of the package.
 *   (and remove 5_order.rr to be evaluated again)
 * - Modify the above emerge command and run it manually.
 * - Compile or unmerge unsatisfied packages manually,
 *   remove temporary files, and try again.
 *   (you can edit package/ebuild list first) 

I have tried to keyword a newer version, and it fails in the same manner. I would deeply appreciate any and all help I can get on this!!

Thanks!

Todd


Last edited by todd93 on Wed Oct 03, 2012 9:44 am; edited 1 time in total
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6415
Location: Goose Creek SC

PostPosted: Wed Oct 03, 2012 12:32 am    Post subject: Reply with quote

Code:
gcc-config -l
post result
Code:
emerge -e system
results?
_________________
Defund the FCC.
Back to top
View user's profile Send private message
todd93
Guru
Guru


Joined: 30 Oct 2006
Posts: 455
Location: Missouri

PostPosted: Wed Oct 03, 2012 12:42 am    Post subject: Reply with quote

DONAHUE wrote:
Code:
gcc-config -l
post result

Code:

# gcc-config -l
 [1] x86_64-pc-linux-gnu-4.6.3 *

Quote:
Code:
emerge -e system
results?

Okay, this one is emerging 331 packages, I will let this run through the night, and report back tomorrow!

Thanks

Todd
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8824

PostPosted: Wed Oct 03, 2012 1:15 am    Post subject: Reply with quote

Do you need lvm to be static? This may not be the cause of your immediate problem, but generally you should use non-static binaries whenever practical.
Back to top
View user's profile Send private message
khayyam
Advocate
Advocate


Joined: 07 Jun 2012
Posts: 2154

PostPosted: Wed Oct 03, 2012 6:00 am    Post subject: Re: sys-fs/lvm2-2.02.88 fails to emerge Reply with quote

todd93 wrote:
Code:
dmsetup.c:(.text.startup+0x96d): undefined reference to `udev_get_dev_path'

todd93 ... from this commit it seems that udev_get_dev_path has been removed from systemd-udev. I asume from this that the version of udev you have installed nolonger has this, but that lvm-2 2.02.88 expects it, so the build fails. If this is the case you can either downgrade sys-fs/udev or try with lvm2-2.02.97.

best ... khay
Back to top
View user's profile Send private message
todd93
Guru
Guru


Joined: 30 Oct 2006
Posts: 455
Location: Missouri

PostPosted: Wed Oct 03, 2012 9:43 am    Post subject: Re: sys-fs/lvm2-2.02.88 fails to emerge Reply with quote

khayyam wrote:
todd93 wrote:
Code:
dmsetup.c:(.text.startup+0x96d): undefined reference to `udev_get_dev_path'

todd93 ... from this commit it seems that udev_get_dev_path has been removed from systemd-udev. I asume from this that the version of udev you have installed nolonger has this, but that lvm-2 2.02.88 expects it, so the build fails. If this is the case you can either downgrade sys-fs/udev or try with lvm2-2.02.97.

best ... khay


thanks, khay, I upgraded to lvm2-2.02.97, emerged just fine! this one is solved!!

Todd
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum