Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] USB automount with udev
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 793
Location: Greece

PostPosted: Fri Sep 28, 2012 8:39 am    Post subject: [SOLVED] USB automount with udev Reply with quote

Hi there,
Could anyone point me a guide for USB automount features using udev? In my previous Gentoo instalation the automount feature was so straightforward that I can't even recall having done any extra configuration at all.

Is this guide up-to-date?
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)


Last edited by Holysword on Sat Sep 29, 2012 2:44 pm; edited 1 time in total
Back to top
View user's profile Send private message
greyspoke
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jan 2010
Posts: 98

PostPosted: Sat Sep 29, 2012 7:59 am    Post subject: Reply with quote

Automounter may be overkill for what you want to do.

An alternative is to write your own udev rules, as set out here. That's what I did until I discovered uam, which is in portage and does pretty much what I was trying to do with my rules, only better. You can configure it to name things how you like, but the defaults work for me.
Back to top
View user's profile Send private message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 793
Location: Greece

PostPosted: Sat Sep 29, 2012 2:43 pm    Post subject: Reply with quote

greyspoke wrote:
Automounter may be overkill for what you want to do.

An alternative is to write your own udev rules, as set out here. That's what I did until I discovered uam, which is in portage and does pretty much what I was trying to do with my rules, only better. You can configure it to name things how you like, but the defaults work for me.

Neat, greyspoke. I had forgot about it, but uam is the reason why in my previous Gentoo installation I haven't had any configuration for having automount!
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)
Back to top
View user's profile Send private message
greyspoke
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jan 2010
Posts: 98

PostPosted: Sun Sep 30, 2012 9:21 am    Post subject: Reply with quote

Glad to help. Actually I had to rummage around to remember the name "uam". It needs something a bit more memorable and descriptive.
Back to top
View user's profile Send private message
turtles
Veteran
Veteran


Joined: 31 Dec 2004
Posts: 1234

PostPosted: Tue Oct 02, 2012 5:32 am    Post subject: Reply with quote

uam looks cool haven't tried it.

I have been using
Code:
sys-fs/udisks-glue

I had a little problem with something not loading modules ntfs when I insert a ntfs formatted drive.
A little kernel adjustment and now its fine.
I think it was a usb suspend option under acpi.
VFAT I just compiled into the kernel since thats what most of those little buggers are.
_________________
Donate to Gentoo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum