Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
LibreOffice + icu + mdds... failed emerge
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
pking
n00b
n00b


Joined: 11 Sep 2009
Posts: 49

PostPosted: Wed Jul 24, 2013 4:21 pm    Post subject: LibreOffice + icu + mdds... failed emerge Reply with quote

I build LibreOffice rather than libreoffice-bin since I got tired of the problems with icu.

But as of yesterday, I have a new problem.

Portage tells me the following for an emerge -avuNDt @world:

Code:

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild  rR    ] media-libs/harfbuzz-0.9.12  USE="-static-libs" 0 kB
[ebuild  rR   ~] app-text/calibre-0.9.40  USE="udisks" 0 kB
[ebuild  rR    ] app-office/libreoffice-4.0.4.2  USE="branding cups dbus gtk opengl postgres vba webdav (-aqua) -bluetooth -debug -eds -gnome -gstreamer -java -jemalloc -kde -mysql -odk -telepathy {-test}" LIBREOFFICE_EXTENSIONS="presenter-minimizer -nlpsolver -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python2_7 (-python3_3)" PYTHON_TARGETS="python2_7 (-python3_3)" 0 kB
[ebuild  rR    ]  media-libs/libvisio-0.0.28  USE="-doc -static-libs" 0 kB
[ebuild  rR    ]  media-libs/libcdr-0.0.14  USE="-doc -static-libs" 0 kB
[ebuild  rR    ]  app-text/libmspub-0.0.6  USE="-doc -static-libs" 0 kB
[ebuild  rR    ] media-libs/raptor-2.0.9:2  USE="curl unicode -debug -json -static-libs" 0 kB
[ebuild  r  U ~]  dev-libs/icu-51.2:0/51.2 [51.1:0/51.1] USE="-debug -doc -examples -static-libs" 0 kB

Total: 8 packages (1 upgrade, 7 reinstalls), Size of downloads: 0 kB

WARNING: One or more updates have been skipped due to a dependency conflict:

dev-util/mdds:0

  (dev-util/mdds-0.8.1::gentoo, ebuild scheduled for merge) conflicts with
    <dev-util/mdds-0.8.0 required by (app-office/libreoffice-4.0.4.2::gentoo, ebuild scheduled for merge)


So it seems like the icu update triggers lots of rebuilds, and lands me in a situation with
mdds. If I accept the skipped update of mdds, the emerge of icu fails, with a patch failure --
little information beyond that, but I assume it's because I haven't updated to mdds-0.8.1. So
I'm stuck in the old same place, it seems, of having an icu update break on libreoffice, but
this time not breaking the binary but even upgrading from source, since the source, as it says,
requires mdds-0.8.0 or less.

Any advice? I suppose I could simply mask icu-51.2, but down that road I could simply install
libreoffice-bin and mask icu updates regularly, too.

There has to be a Better Way...
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1156

PostPosted: Wed Jul 24, 2013 6:02 pm    Post subject: Reply with quote

1. keep icu stable for now
2. mask >dev-util/mdds-0.8 as portage stated
_________________
fun2gen2
Back to top
View user's profile Send private message
pking
n00b
n00b


Joined: 11 Sep 2009
Posts: 49

PostPosted: Wed Jul 24, 2013 8:05 pm    Post subject: Reply with quote

Thanks ulenrich; that is a workaround. Pity at having to mask mdds, but it's
better than throwing everything else out of whack!
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1156

PostPosted: Wed Jul 24, 2013 8:54 pm    Post subject: Reply with quote

mdds is an important helper for libreoffice-4.0, see
equery d mdds

They developed libreoffice with mdds-0.7 in mind. I don't know what about
libreoffice-4.1 in that respect.

Regarding icu the Gentoo maintainer is frustrated about every minor icu
release breaking the abi without announcing ...
_________________
fun2gen2
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum