Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Audacity can't start [gnome, pulseaudio]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Hexorg
Tux's lil' helper
Tux's lil' helper


Joined: 29 Oct 2009
Posts: 103

PostPosted: Tue Aug 21, 2012 2:25 pm    Post subject: Audacity can't start [gnome, pulseaudio] Reply with quote

Hello,
I'm trying to get audacity running. At first when I try to start it, it says "Audacity could not find a place to store temporary files. Please enter an appropriate directory in the preferences dialog." Then after I press OK, it would crash with segmentation fault.

I found somewhere online that it needs "bug buddy" to report crashes. After I installed bug buddy, there is no segmentation fault anymore, but I still can't start it. And I can't see absolutely any error logs, except that warning about temporary files.

Interesting enough, though, is that I can start it from root just fine. I've found that /dev/dsp may deny access to my user account, but I don't even have /dev/dsp
What else can I try?
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5282

PostPosted: Tue Aug 28, 2012 12:02 pm    Post subject: Reply with quote

Do you have any audio devices attached to your computer (USB speakers, mixers, microphones, etc.)?
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Sat Sep 29, 2012 1:30 am    Post subject: Reply with quote

I'm getting the same error... (root runs fine, but not the normal user)



PLEASE HELP!!
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Sat Sep 29, 2012 9:08 pm    Post subject: Reply with quote

ahgblopes wrote:
I'm getting the same error... (root runs fine, but not the normal user)



PLEASE HELP!!


SOLVED!

FOR ME, this was causing the error:

I had an user called ah, but for obscure reasons i removed it and made another user. Days later, i created again an user called ah, but...

This folder: /var/tmp/audacity-ah was without write permission, so i simply remove it (as root) and created it again (as normal user). Everything runs fine now.


Yes, this IS a bug. Audacity should tell us about permissions, not about location not found!!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum