Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201209-24 ] PostgreSQL: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1539

PostPosted: Fri Sep 28, 2012 1:26 pm    Post subject: [ GLSA 201209-24 ] PostgreSQL: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: PostgreSQL: Multiple vulnerabilities (GLSA 201209-24)
Severity: normal
Exploitable: remote
Date: September 28, 2012
Updated: January 20, 2014
Bug(s): #406037, #419727, #431766
ID: 201209-24

Synopsis

Multiple vulnerabilities have been found in PostgreSQL which may
allow a remote attacker to conduct several attacks.



Background

PostgreSQL is an open source object-relational database management
system.


Affected Packages

Package: dev-db/postgresql-server
Vulnerable: < 9.1.5
Unaffected: >= 9.1.5
Unaffected: >= 9.0.9 < 9.0.10
Unaffected: >= 8.4.13 < 8.4.14
Unaffected: >= 8.3.20 < 8.3.21
Unaffected: >= 8.4.17 < 8.4.18
Unaffected: >= 8.4.19 < 8.4.20
Unaffected: >= 9.0.13 < 9.0.14
Unaffected: >= 9.0.14 < 9.0.15
Unaffected: >= 9.0.15 < 9.0.16
Unaffected: >= 8.4.14 < 8.4.15
Unaffected: >= 8.4.15 < 8.4.16
Unaffected: >= 8.4.16 < 8.4.17
Unaffected: >= 9.0.16 < 9.0.17
Unaffected: >= 9.0.17 < 9.0.18
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in PostgreSQL. Please
review the CVE identifiers referenced below for details.


Impact

A remote attacker could spoof SSL connections. Furthermore, a remote
authenticated attacker could cause a Denial of Service, read and write
arbitrary files, inject SQL commands into dump scripts, or bypass
database restrictions to execute database functions.
A context-dependent attacker could more easily obtain access via
authentication attempts with an initial substring of the intended
password.


Workaround

There is no known workaround at this time.

Resolution

All PostgreSQL 9.1 server users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-db/postgresql-server-9.1.5"
   
All PostgreSQL 9.0 server users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-db/postgresql-server-9.0.9"
   
All PostgreSQL 8.4 server users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-db/postgresql-server-8.4.13"
   
All PostgreSQL 8.3 server users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-db/postgresql-server-8.3.20"
   


References

CVE-2012-0866
CVE-2012-0867
CVE-2012-0868
CVE-2012-2143
CVE-2012-2655
CVE-2012-3488
CVE-2012-3489


Last edited by GLSA on Mon Jan 20, 2014 9:59 am; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum