Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
-Solved- My graphics don't feel right.
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
rabcor
Apprentice
Apprentice


Joined: 05 Apr 2012
Posts: 200

PostPosted: Sat Oct 06, 2012 4:47 pm    Post subject: Reply with quote

I don't quite get how or where i'm supposed to do that, the only "blanking" option i can find is Vblank Syncing

And my Sync to VBlank option has been on for a while now, and doesn't help, you probably knew that already so what exactly do you mean i should do?

Note: i tried running glxgears again now without Vblank syncing on, and i'm getting it up to around 22-23k fps now, so i'm getting the performance i should.)
_________________
This picture was my biggest reason for ever trying Gentoo <3
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32328
Location: 56N 3W

PostPosted: Sat Oct 06, 2012 8:14 pm    Post subject: Reply with quote

rabcor,

rabcor wrote:
I don't quite get how or where i'm supposed to do that, the only "blanking" option i can find is Vblank Syncing

Thats the option. If is on, its not being used, as its not mentioned in your Xorg.0.log.
As has already been pointed out, glxgears can indicate if its on by the FPS you get.

You need to read the NVIDIA stuff in /usr/share/doc/... to find out why not.

This thread may also help.
Google would have found that for you.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
rabcor
Apprentice
Apprentice


Joined: 05 Apr 2012
Posts: 200

PostPosted: Sun Oct 07, 2012 5:57 pm    Post subject: Reply with quote

Like i said, glxgears gave me an output of roughly 60fps when i had it on, which is the correct value i'd want with the blanking on. it was working, just not helping.

Also, like i said before, a video is traditionally only 22-24fps. but i was getting this on there. even if my xorg wasn't using the blanking option, if it was a framerate related problem it shouldn't have appeared in a video.

glxgears is using it....


I found a fix, while looking into how to force xorg to use vblanking, i found this here: http://askubuntu.com/questions/125245/how-do-i-stop-video-tearing-nvidia-prop-driver-non-compositing-window-manager

And i tried most of the stuff in there until i found someone suggesting to add this

Code:
Section "Extensions"
    Option "Composite" "Disable"
EndSection


and This under the Device section.

Code:
Option "UseEvents" "True"


This solved my issue. Basically... nvidia proprietary drivers dislike Composite... I don't mind not using composite, but.... if at all possible i''d like to solve the issue with compositing on. just in case i'd want to have it turned on or if someone else having this issue absolutely wants to have some extra eyecandy..... so i will not mark it as solved just yet and keep working on it.

I did not manage to find out how to force xorg to use vblank syncing, it does say that i can use __GL_SYNC_DISPLAY_DEVICE to specify which display device opengl should sync, this option if use should be set to a "Connected display device(s):" option from the xorg logfile, but since i'm using only one display, i doubt this will help with anything.

But then next, i found something useful.

Quote:
The Composite extension also causes problems with other driver components:

o In X servers prior to X.Org 7.1, Xv cannot draw into pixmaps that have
been redirected offscreen and will draw directly onto the screen instead.
For some programs you can work around this issue by using an alternative
video driver. For example, "mplayer -vo x11" will work correctly, as will
"xine -V xshm". If you must use Xv with an older server, you can also
disable the compositing manager and re-enable it when you are finished.

On X.Org 7.1 and higher, the driver will properly redirect video into
offscreen pixmaps. Note that the Xv adaptors will ignore the
sync-to-vblank option when drawing into a redirected window.

o Workstation overlays, stereo visuals, and the unified back buffer (UBB)
are incompatible with Composite. These features will be automatically
disabled when Composite is detected.

o The Composite extension is currently incompatible with Xinerama, due to
limitations in the X.Org X server. Composite will be automatically
disabled when Xinerama is enabled.


Using that example mplayer option in mplayer did solve the issue, therefore this is happening because something somewhere in my xorg-server is outdated, i will have to try emerging xorg-x11 to see if that'll fix anything (its in version 7.4 current stable)
_________________
This picture was my biggest reason for ever trying Gentoo <3
Back to top
View user's profile Send private message
rabcor
Apprentice
Apprentice


Joined: 05 Apr 2012
Posts: 200

PostPosted: Mon Oct 08, 2012 1:28 am    Post subject: Reply with quote

Doing this did not fix it.

...

By chance, i found an option that fixed this.

System Settings - Desktop Effects - Advanced

Compositing Type

By default this was set to XRender. Setting it to OpenGL fixed the whole thing.

Glad to know nothing i had done so far was wrong, and nothing was outdated, but the default options in the system were simply bad.

I'll mark this as solved.

Thanks everyone for your help up till this point, even if it was by chance that i found a solution after finally pretty much giving up, i learned a lot here.
_________________
This picture was my biggest reason for ever trying Gentoo <3
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum