Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]upgrade nagios core from 3.2.3 to 3.4.1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
midway
Apprentice
Apprentice


Joined: 01 Jun 2012
Posts: 181
Location: somewhr in the blighty

PostPosted: Mon Aug 13, 2012 3:34 pm    Post subject: [solved]upgrade nagios core from 3.2.3 to 3.4.1 Reply with quote

Hello All,
I am trying to upgrade my nagios core from 3.2.3 to 3.4.1. I have performed following steps:

Code:


~ wget http://sourceforge.net/projects/nagios/files/nagios-3.x/nagios-3.4.1/nagios-3.4.1.tar.gz
~ tar xzf nagios-3.4.1.tar.gz
~ ./configure --with-command-group=nagcmd
~ make all
~ make install
~ nagios - v nagios.cfg (to test config)
~ /etc/init.d/nagios reload (all fine)
~ /etc/init.d/nagios restart (this works however throws warning)



My nagios directory is under /root/nagios.
Code:

nagios # /etc/init.d/nagios restart
 * Caching service dependencies ...
/etc/init.d/aoe: line 8: add_suffix: command not found                                                                         [ ok ]
 * Stopping nagios ...                                                                                                                        [ ok ]
 * Starting nagios ... 


There was 1 more warning which I have sorted. it complained about "startas" and asked me to replace it with "exec" under /etc/init.d/nagios.


Last edited by midway on Thu Sep 27, 2012 3:27 pm; edited 1 time in total
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 443
Location: Kraków, PL

PostPosted: Mon Aug 13, 2012 3:48 pm    Post subject: Reply with quote

You will corrupt your Gentoo soon if you will install things like this without at least minimal knowledge about the system internals.

I am not sure if 'make install' installs anything into /etc/init.d/, so you may be using init script from your old nagios (probably installed from ebuild) with the new nagios installation (probably make install put the files under /usr, not /usr/local).

I'd suggest to stick to Portage tree, there is nagios 3.3.1 there (what is so new in 3.4 that you need it?).
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
midway
Apprentice
Apprentice


Joined: 01 Jun 2012
Posts: 181
Location: somewhr in the blighty

PostPosted: Tue Aug 14, 2012 9:23 am    Post subject: Reply with quote

gorkypl, my portage update doesn't tell me the version 3.3.1 is available otherwise i would have done that. also, there are several feature enhancements since 3.2.3 which I want on my nagios box. I was following this nagios guide which I have followed on my other red hat boxes too. I am on Portage version 2.1.11.9
http://nagios.sourceforge.net/docs/3_0/upgrading.html
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 443
Location: Kraków, PL

PostPosted: Tue Aug 14, 2012 9:51 pm    Post subject: Reply with quote

nitish.anand wrote:
gorkypl, my portage update doesn't tell me the version 3.3.1 is available otherwise i would have done that.

Then you must be doing something wrong
http://packages.gentoo.org/package/net-analyzer/nagios-core

Also I will repeat once again - mixing packages installed from source and from the Portage tree is something that will surely broke your installation.
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
midway
Apprentice
Apprentice


Joined: 01 Jun 2012
Posts: 181
Location: somewhr in the blighty

PostPosted: Thu Sep 27, 2012 3:26 pm    Post subject: Reply with quote

gorkypl wrote:
nitish.anand wrote:
gorkypl, my portage update doesn't tell me the version 3.3.1 is available otherwise i would have done that.

Then you must be doing something wrong
http://packages.gentoo.org/package/net-analyzer/nagios-core

Also I will repeat once again - mixing packages installed from source and from the Portage tree is something that will surely broke your installation.


upgraded to 3.3.1, thx.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum