Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Hp Officejet 4500 is failing to print [given up - solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1491

PostPosted: Tue Sep 25, 2012 12:00 am    Post subject: Hp Officejet 4500 is failing to print [given up - solved] Reply with quote

I have an HP Officejet 4500 connected via Ethernet.

I had to manually enter the ip address to get the hplip application to see it. There is no router, just a basic local area network setup by my box. I can scan, but when I try to print a test page I get about 10 pages with JZJZ4♥$ZZ printed in the upper left corner (I cancelled it before more pages where ruined).

Here is how hplip and cups are built:
Code:
net-print/cups-1.6.1  USE="X acl avahi dbus filters gnutls java kerberos pam ssl threads usb zeroconf -debug -python (-selinux) -static-libs -systemd -xinetd" LINGUAS="-ca -es -ja"
net-print/hplip-3.12.9-r1  USE="X hpcups hpijs libnotify parport qt4 scanner snmp -doc -fax -kde -minimal -policykit -static-ppds"

and hp-check only complains about policykit not being installed, which is intentional.

The quarter starts in a few days and I really need to get this working. A USB cable is out of the question because the printer needs to be about 2 meters from the computer and I don't have one long enough.

If you need any more information, please ask. Thank you in advance to anyone who can help.

EDIT: given the time scale on which I need this to work I have purchased a USB cable and have given up on the network cable. While I cannot confirm that this is the solution to the problem, it seems removing the hpjis use flag may be the correct solution.
_________________
First things first, but not necessarily in that order.


Last edited by The Doctor on Thu Sep 27, 2012 7:56 pm; edited 2 times in total
Back to top
View user's profile Send private message
alienjon
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1533

PostPosted: Wed Sep 26, 2012 12:01 am    Post subject: Reply with quote

I had this problem recently in Ubuntu when setting up remote printing through Vista - so this might be a bit different from your network. The solution for me was to change the driver used in CUPS (I had the wrong one selected).
_________________
He who laughs last, laughs hardest
He who laughs hardest has milk come out of his nose
He who has milk come out of his nose gets laughed at
Can you see the catch 22 here?
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1491

PostPosted: Wed Sep 26, 2012 5:27 am    Post subject: Reply with quote

alienjon wrote:
I had this problem recently in Ubuntu when setting up remote printing through Vista - so this might be a bit different from your network. The solution for me was to change the driver used in CUPS (I had the wrong one selected).


In hind sight, I do agree that this may well have been the issue, but hplip was properly identifying the model I expected better on the driver matching. After I changed to USB I recompiled hplip with -hpijs and the proper usb driver was selected.

In any case, one new usb cable and 15 pieces of paper and the printer is working. I hesitate to mark this thread as [solved] since I never actually got it to work using Ethernet.

Thank you for the response. I really do appreciate it.
_________________
First things first, but not necessarily in that order.


Last edited by The Doctor on Thu Sep 27, 2012 7:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
morten.dynamite
n00b
n00b


Joined: 11 Nov 2007
Posts: 4
Location: Charlottenberg, Sweden

PostPosted: Thu Sep 27, 2012 5:14 pm    Post subject: Reply with quote

I have an HP Photosmart B109n with the exact same problem.

I solved it by using hpcups instead of hpijs driver the hp-setup tool choose hpijs if both are available.

You can try to recompile hplip with USE="-hpijs" and install the printer with hp-setup.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum