Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
CONFIG_TMPFS menuconfig option?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
rabcor
Apprentice
Apprentice


Joined: 05 Apr 2012
Posts: 200

PostPosted: Sun Sep 23, 2012 6:22 pm    Post subject: CONFIG_TMPFS menuconfig option? Reply with quote

I looked all over the .config menuconfig for this setting, but its almost like trying to find a needle in a large living room (haystack would be overdoing it i think)

so...

What is the menuconfig option for CONFIG_TMPFS as its now off by default (how did this happen...) and i need it to be able to boot my system properly

or, is there a command i could use to edit this option without going to the menu?
_________________
This picture was my biggest reason for ever trying Gentoo <3
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32439
Location: 56N 3W

PostPosted: Sun Sep 23, 2012 6:42 pm    Post subject: Reply with quote

rabcor,

Write out 100 times ... I must never use $EDITOR on the kernel .config file.

In menuconfig, / is your friend - I told you about that in your eth0 thread.
Code:

───────────────────────────────────────────────────────────────────────────────────────────────────────────────────────
  ┌───────────────────────────────────────────────── Search Results ─────────────────────────────────────────────────┐
  │ Symbol: DEVTMPFS [=y]                                                                                            │ 
  │ Type  : boolean                                                                                                  │ 
  │ Prompt: Maintain a devtmpfs filesystem to mount at /dev                                                          │ 
  │   Defined at drivers/base/Kconfig:24                                                                             │ 
  │   Depends on: HOTPLUG [=y]                                                                                       │ 
  │   Location:                                                                                                      │ 
  │     -> Device Drivers                                                                                            │ 
  │       -> Generic Driver Options                                                                                  │ 
  │                                                                                                                  │ 
  │                                                                                                                  │ 
  │ Symbol: DEVTMPFS_MOUNT [=y]                                                                                      │ 
  │ Type  : boolean                                                                                                  │ 
  │ Prompt: Automount devtmpfs at /dev, after the kernel mounted the rootfs                                          │ 
  │   Defined at drivers/base/Kconfig:44                                                                             │ 
  │   Depends on: DEVTMPFS [=y]                                                                                      │ 
  │   Location:                                                                                                      │ 
  │     -> Device Drivers                                                                                            │ 
  │       -> Generic Driver Options                                                                                  │ 
  │         -> Maintain a devtmpfs filesystem to mount at /dev (DEVTMPFS [=y])                                       │ 


OK, its not perfect. When you have a Depends on set incorrectly, the option you want does not appear in the search output.

_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
rabcor
Apprentice
Apprentice


Joined: 05 Apr 2012
Posts: 200

PostPosted: Sun Sep 23, 2012 7:05 pm    Post subject: Reply with quote

the dependancy was disabled, so i had to recompile my kernel anyways, but you have my thanks, thanks to you and khayyam i can now successfully boot my system without any errors! (well, there were more, but not with this particular installation)

thanks a ton!
_________________
This picture was my biggest reason for ever trying Gentoo <3
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum