Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Konfiguracja jądra GRUB + ext4 (sda3)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt
View previous topic :: View next topic  
Author Message
Karmazyn
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2005
Posts: 133
Location: Dąbrowa Górnicza [pl_PL.UTF-8]

PostPosted: Sat Sep 22, 2012 10:05 am    Post subject: [SOLVED] Konfiguracja jądra GRUB + ext4 (sda3) Reply with quote

Witam!

Problem w tym, iż jądro widzi poprawnie dysk i rozpoznaje na nim 4 partycje (mam tylko podstawowe).

Partycja systemowa to /dev/sda3 i sformatowana na system plików ext4.

Jądro nie potrafi zamontować /

Bez przerwy krzyczy: "No filesystem could mount root tried: ble ble ble ext4"

Śmieszna jest też próba montowania partycji dla systemów plików jakie nie zostały wkompilowane do jądro 8)

Nie pomaga opcja w GRUBie rootfstype=ext4

W jądrze stanu czystego (make clean, make mrproper) dodałem następujące sterowniki:
- NVIDIA SATA Support (jak oznajmiłem poprawnie widzi dysk)
- Ext4 Filesystem (bez obsługi partycji typu ext2 ext3, na cholere)

Oczywiście wszystko wmontowane na stałe.

Próbowałem też z wywaloną opcją Generic ATA support (brak skutku).


Last edited by Karmazyn on Sun Sep 23, 2012 5:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2837

PostPosted: Sat Sep 22, 2012 4:15 pm    Post subject: Reply with quote

Uzyj initramfs do debugownia to, z https://github.com/slashbeast/better-initramfs/downloads mozesz pobrac gotowe binarne obrazy, najczesciej wystarczy rozpakowac, z-gzipowac initramfs.cpio i dodac do bootloadera.

Gdy podczas bootu poleci ten blad, sprawdz, czy z szela do ktorego dostep dostajesz widac /dev/sda*, czy mozesz to zamontowac, jak nie, sprawdz dmesg czy nie ma tam podanego powodu i tak dalej.
_________________
BitBucket -- better-initramfs
Back to top
View user's profile Send private message
Karmazyn
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2005
Posts: 133
Location: Dąbrowa Górnicza [pl_PL.UTF-8]

PostPosted: Sun Sep 23, 2012 3:01 pm    Post subject: Reply with quote

Dobry pomysł :)

Lecz...

Kernel wystartował i dostałem dostęp do shella.

Code:
rescueshell / # mount
...
/dev/sda3 on / type ext4 (0)


Więc już nic nie rozumiem...

Coś mnie tchneło i zrobiłem wszystkie sterowniki do dysków jakie były oznaczone jako "< >" na modularne.
System wystartował...

Jaka przyczyna?

BTW. nie mam genkernela ani własnego initramfs, więc żaden z modułów nie powinien być załadowany.
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2837

PostPosted: Sun Sep 23, 2012 3:33 pm    Post subject: Reply with quote

Z to conajmniej ciekawe, initramfs nie powinien do / nic montowac chyba, ze juz po starcie systemu, Lepiej patfrz w /proc/mounts zamiast 'mount'. Mount czyta plik /etc/mtab ktory nie zawsze jest swiezy czy w ogole ma sens.
_________________
BitBucket -- better-initramfs
Back to top
View user's profile Send private message
Karmazyn
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2005
Posts: 133
Location: Dąbrowa Górnicza [pl_PL.UTF-8]

PostPosted: Sun Sep 23, 2012 3:40 pm    Post subject: Reply with quote

Dobra, initramfs odstawmy teraz na bok :)
System się poprawnie uruchomił gdy wszystko < > zamieniłem na moduły (chodzi o dział SATA w jądrze), ale gdy w systemie wykonałem lsmod to odpowiedział, żaden moduł nie jest wykorzystywany.

Ad x00:
:lol: Co za głupota, GRUB nie potrafi czytać haszy # które nie znajdują się na początku linii tj.
Code:
kernel /boot/bzImage root=/dev/sda3 # root=/dev/ram0 real_root=/dev/sda3

Właśnie ta linijka wywołała błąd jądra i nie pozwoliła na prawidłowe zamontowanie partycji...

Chciałem ją zachować na przyszłość, gdybym wykorzystał genkernela, ale widać GRUB mi nie pozwoli zrobić tego w ten sposób.

SOLVED
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum