Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] /etc/profile spostato erronamente: disastro
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3020
Location: ROMA

PostPosted: Thu Sep 20, 2012 9:16 am    Post subject: [RISOLTO] /etc/profile spostato erronamente: disastro Reply with quote

Salve gente,

ho erroneamente effettuato l'aggiornamento alla versione di portage in oggetto, e ora qualcosa si deve essere incasinato di brutto.
Infatti emerge non funziona più e anche quando faccio eselect profile list o emerge, o ebuild, ottengo questo output:
Code:
Traceback (most recent call last):
  File "/usr/bin/emerge", line 47, in <module>
    retval = emerge_main()
  File "/usr/lib64/portage/pym/_emerge/main.py", line 1650, in emerge_main
    settings, trees, mtimedb = load_emerge_config()
  File "/usr/lib64/portage/pym/_emerge/actions.py", line 3039, in load_emerge_config
    trees = portage.create_trees(trees=trees, **kwargs)
  File "/usr/lib64/portage/pym/portage/__init__.py", line 511, in create_trees
    env=env, eprefix=eprefix)
  File "/usr/lib64/portage/pym/portage/proxy/objectproxy.py", line 31, in __call__
    return result(*args, **kwargs)
  File "/usr/lib64/portage/pym/portage/package/ebuild/config.py", line 456, in __init__
    verify_eapi=True) for x in self.profiles]
  File "/usr/lib64/portage/pym/portage/package/ebuild/config.py", line 456, in <listcomp>
    verify_eapi=True) for x in self.profiles]
  File "/usr/lib64/portage/pym/portage/util/__init__.py", line 440, in grabfile_package
    pkgs=grabfile(myfilename, compatlevel, recursive=recursive, remember_source_file=True)
  File "/usr/lib64/portage/pym/portage/util/__init__.py", line 123, in grabfile
    mylines=grablines(myfilename, recursive, remember_source_file=True)
  File "/usr/lib64/portage/pym/portage/util/__init__.py", line 497, in grablines
    mode='r', encoding=_encodings['content'], errors='replace')
IOError: [Errno 20] Not a directory: '/etc/portage/profile/packages'


Ho spostato /etc/make.conf e /etc/make.profile in /etc/portage, anche se non era necessario, ma non è cambiato nulla.
Ho letto anche questo thread, ma non vorrei fare modifiche di cui non sono sicuro.

Qualcuno sa cos'è successo e come riparare il danno?
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered


Last edited by fbcyborg on Thu Sep 20, 2012 9:57 am; edited 1 time in total
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2909
Location: Parma (Italy)

PostPosted: Thu Sep 20, 2012 9:44 am    Post subject: Reply with quote

non ne so niente, ma dall'errore che si legge proverei con
Code:
# mkdir /etc/portage/profile/packages

_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3020
Location: ROMA

PostPosted: Thu Sep 20, 2012 9:56 am    Post subject: Reply with quote

Cavolo,

non so come sia potuto accadere ma avevo mosso erroneamente /etc/profile in /etc/portage ! Cacchio!

Grazie!
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum