Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst]elogv findet summary.log nicht
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
strangerthandreams
Tux's lil' helper
Tux's lil' helper


Joined: 12 Feb 2008
Posts: 105

PostPosted: Sat Sep 22, 2012 8:59 am    Post subject: [gelöst]elogv findet summary.log nicht Reply with quote

Hi Leute.

Ich habe mir einen neuen Rechner inkl. Gentoo eingerichtet und stehe nun vor dem Problem, dass ich elogv nicht richtig nutzen kann.

Es wird zwar eine summary angelegt und da steht auch was drin:

ls /var/log/portage/elog/summary.log
Code:

/var/log/portage/elog/summary.log


cat /var/log/portage/elog/summary.log (gekürzt)
Code:

...

To operate properly this software needs the directory
/var/log/portage/elog created, belonging to group portage.
To start the software as a user, add yourself to the portage
group.


>>> Messages generated by process 29850 on 2012-09-22 12:52:40 CEST for package sys-devel/gdb-7.3.1:

INFO: setup
Package:    sys-devel/gdb-7.3.1
Repository: gentoo
Maintainer: toolchain@gentoo.org
USE:        amd64 consolekit elibc_glibc kernel_linux multilib nls policykit python userland_GNU
FEATURES:   ccache sandbox userpriv usersandbox
Package:    sys-devel/gdb-7.3.1
Repository: gentoo
Maintainer: toolchain@gentoo.org
USE:        amd64 consolekit elibc_glibc kernel_linux multilib nls policykit python userland_GNU
FEATURES:   ccache sandbox userpriv usersandbox
INFO: prepare
Applying various patches (bugfixes/updates) ...
  05_all_readline-headers.patch ...
  40_all_x32.patch ...
Done with patching

...


aber wenn ich dann die Meldungen ordentlich lesen will mit elogv, dann bekomme ich die Meldung:

elogv
Code:
Keine elog-Dateien gefunden /var/log/portage/elog



Meine Einträge in der make.conf sehen so aus:

cat /etc/make.conf
Code:

PORTAGE_ELOG_CLASSES="warn error log info"
PORTAGE_ECLASS_WARNING_ENABLE="0"
POTAGE_ELOG_SYSTEM="echo:log, info, warn, error save:warn,info,error"
PORT_LOGDIR="/var/log/portage/"


Fehlt mir irgendwas?
_________________
Hier könnte Ihre Werbung stehen!


Last edited by strangerthandreams on Sat Sep 22, 2012 3:59 pm; edited 1 time in total
Back to top
View user's profile Send private message
lituxer
Tux's lil' helper
Tux's lil' helper


Joined: 04 Aug 2007
Posts: 90
Location: Sauerland

PostPosted: Sat Sep 22, 2012 11:53 am    Post subject: Reply with quote

Einfach mal ins blaue geraten.

Kann es sein, das der Pfad Deiner make.conf falsch ist? Das ganze ist ja jetzt nach /etc/portage/ gewandert.
_________________
GentooFreunde
Back to top
View user's profile Send private message
strangerthandreams
Tux's lil' helper
Tux's lil' helper


Joined: 12 Feb 2008
Posts: 105

PostPosted: Sat Sep 22, 2012 12:04 pm    Post subject: Reply with quote

Die make.conf liegt noch in /etc, da ja laut

eselect news read 6
Code:

Starting next week, new stages will have make.conf and make.profile
moved from /etc to /etc/portage. This is a change in the installation
defaults, that will only affect new installs so it doesn't affect
current systems.

Current users don't need to do anything. But if you want to follow the
preferred location, you may want to take the chance to move the files
in your system(s) to the new location.


ganz eindeutig steht, dass man am bestehenden System nichts zu unternehmen braucht.

Ich kann aber gern mal die Dateien verschieben, wenn es dabei keine Wechselwirkungen gibt.
_________________
Hier könnte Ihre Werbung stehen!
Back to top
View user's profile Send private message
bell
Guru
Guru


Joined: 27 Nov 2007
Posts: 426

PostPosted: Sat Sep 22, 2012 1:48 pm    Post subject: Reply with quote

Nimm mal die PORT_LOGDIR Zeile aus der make.conf raus. Bleibe beim Standard. Eventuell bring diese Einstellung was durcheinander.
Back to top
View user's profile Send private message
lituxer
Tux's lil' helper
Tux's lil' helper


Joined: 04 Aug 2007
Posts: 90
Location: Sauerland

PostPosted: Sat Sep 22, 2012 3:40 pm    Post subject: Reply with quote

Code:
PORTAGE_ELOG_CLASSES="warn error log info"
PORTAGE_ECLASS_WARNING_ENABLE="0"
POTAGE_ELOG_SYSTEM="echo:log, info, warn, error save:warn,info,error"
PORT_LOGDIR="/var/log/portage/"


Kann es sein, das ein Schreibfehler vorliegt.
In der 3 Zeile wird POTAGE statt PORTAGE geschrieben.
_________________
GentooFreunde
Back to top
View user's profile Send private message
strangerthandreams
Tux's lil' helper
Tux's lil' helper


Joined: 12 Feb 2008
Posts: 105

PostPosted: Sat Sep 22, 2012 3:56 pm    Post subject: Reply with quote

Quote:
Kann es sein, das ein Schreibfehler vorliegt.
In der 3 Zeile wird POTAGE statt PORTAGE geschrieben.


Oh man dankeschön. Da brech ich mir hier einen ab und habs nicht gesehen. Läuft endlich. 8)

Ich habe das PORT_LOGDIR wieder entfernt, was ich aus lauter Verzweiflung reinnahm. Und PORTAGE_ELOG_SYSTEM läuft jetzt auch wieder - wie ursprünglich - mit "save_summary" und gut ist.
_________________
Hier könnte Ihre Werbung stehen!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum