Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] No ebuilds!!!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
rpil
Guru
Guru


Joined: 23 May 2008
Posts: 311

PostPosted: Wed Sep 19, 2012 8:53 am    Post subject: [SOLVED] No ebuilds!!! Reply with quote

I have installed fluxbox in my new laptop install.
I tried to install thunar, but I received this message from portage:

Code:
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy ">=sys-fs/udev-180[gudev,hwdb]"
(dependency required by "sys-fs/udisks-1.99.0-r1" [ebuild])
(dependency required by "gnome-base/gvfs-1.12.3[udisks]" [ebuild])
(dependency required by "xfce-base/thunar-1.4.0[dbus,xfce_plugins_trash" [ebuild])
(dependency required by "thunar" [argument])

I've tried every combination between /package.use, /package.mask, /make.conf!
Always the same mesage! HELP!


Last edited by rpil on Thu Sep 20, 2012 7:03 am; edited 1 time in total
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3959
Location: Irgendwo im Nirgendwo

PostPosted: Wed Sep 19, 2012 9:24 am    Post subject: Reply with quote

First, thunar is NOT a window manager but a file manager.
That said you have 3 options:
* take "gnome-base/gvfs" out of your package.accept_kewords
* set "gnome-base/gvfs -udisks" into your package.use
* set "sys-fs/udev" into you package.accept_keywords AND "sys-fs/udev gudev hwdb" in your package.use
I assume you know what each of the options does.
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
wjb
Guru
Guru


Joined: 10 Jul 2005
Posts: 356
Location: Fife, Scotland

PostPosted: Wed Sep 19, 2012 9:43 am    Post subject: Reply with quote

Fourthly, rpil could maybe remove dbus and xfce_plugins_trash from thunar

Fifthly, franzf, a stable thunar build is pulling in unstable ebuilds. Which is unusual enough to be a bug.
Back to top
View user's profile Send private message
rpil
Guru
Guru


Joined: 23 May 2008
Posts: 311

PostPosted: Thu Sep 20, 2012 7:03 am    Post subject: Reply with quote

It was more simple after all. I deactivated udev and udisks USE flags and thunar emerged perfectly!
Thanks for your trouble, gyus. :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum