Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Compiz-0.9.8.0: string sub-command REPLACE requires at least
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 482

PostPosted: Fri Sep 14, 2012 4:37 pm    Post subject: Compiz-0.9.8.0: string sub-command REPLACE requires at least Reply with quote

Hi all,
I am trying to update compiz from 0.9.7.8 to 0.9.8.0 using this ebuild https://github.com/shiznix/unity-gentoo/tree/master/unity-base/compiz.
But 0.9.8.0 gives me this error http://pastebin.com/raw.php?i=FnTbfsb2, seems to be releated to python but I don't know what to do.

Any ideas?[/code]
_________________
Gentoo Linux ~x86, Kernel 3.11.2, Enermax Revolutions85+ 850W, AMD Athlon 64 X2 5000+ BE, Corsair XMS2 PC6400 3GB, ASUS M2R32, Sapphire HD6870, Creative X-Fi Platinum, WD Raptor 150GB, WD 2.5 320GB, Asus DRW-24B1ST
Back to top
View user's profile Send private message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 482

PostPosted: Sat Sep 15, 2012 9:02 am    Post subject: Reply with quote

According to this bug https://bugs.launchpad.net/compiz/+bug/1004592, I should force the ebuild to use python 2. How can I do that?
_________________
Gentoo Linux ~x86, Kernel 3.11.2, Enermax Revolutions85+ 850W, AMD Athlon 64 X2 5000+ BE, Corsair XMS2 PC6400 3GB, ASUS M2R32, Sapphire HD6870, Creative X-Fi Platinum, WD Raptor 150GB, WD 2.5 320GB, Asus DRW-24B1ST
Back to top
View user's profile Send private message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 482

PostPosted: Sat Sep 15, 2012 9:20 am    Post subject: Reply with quote

If I "eselect python set python2.7" the problem is solved. But I want to set python3.2 for my system and python2.7 for compiz.
_________________
Gentoo Linux ~x86, Kernel 3.11.2, Enermax Revolutions85+ 850W, AMD Athlon 64 X2 5000+ BE, Corsair XMS2 PC6400 3GB, ASUS M2R32, Sapphire HD6870, Creative X-Fi Platinum, WD Raptor 150GB, WD 2.5 320GB, Asus DRW-24B1ST
Back to top
View user's profile Send private message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 482

PostPosted: Sat Sep 15, 2012 11:17 am    Post subject: Reply with quote

Solved adding on top of ebuild:

Code:
PYTHON_DEPEND="2:2.7"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.*"

_________________
Gentoo Linux ~x86, Kernel 3.11.2, Enermax Revolutions85+ 850W, AMD Athlon 64 X2 5000+ BE, Corsair XMS2 PC6400 3GB, ASUS M2R32, Sapphire HD6870, Creative X-Fi Platinum, WD Raptor 150GB, WD 2.5 320GB, Asus DRW-24B1ST
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum