Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Reboot issue after minimal cd amd64
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
jk1217NIU
n00b
n00b


Joined: 10 Sep 2012
Posts: 5
Location: DeKalb, IL

PostPosted: Mon Sep 10, 2012 11:34 pm    Post subject: Reboot issue after minimal cd amd64 Reply with quote

I apologize if this has been asked. I scoured the forum and couldn't find my particular issue.

After I went through the minimal livecd for amd64 I rebooted and the boot freezes with a screen that says:


Booting 'Gentoo Linux 3.4.9'

root (hd0,0)
Filesystem type is ext2fs, partition type 0x83
kernel /boot/kernel-genkernel-x86_64-3.4.9-gentoo real_root=/dev/sda3
[Linux-bzImage, setup=0x3400, size=0x324810]
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6543
Location: Goose Creek SC

PostPosted: Mon Sep 10, 2012 11:55 pm    Post subject: Reply with quote

appears to be a bad grub.conf --
boot cd, enter chroot
Code:
mount /dev/sda3 /mnt/gentoo
mount /dev/sda1 /mnt/gentoo/boot
cp /etc/resolv.conf /mnt/gentoo/etc/resolv.conf
mount -t proc none /mnt/gentoo/proc
mount --rbind /sys /mnt/gentoo/sys
mount --rbind /dev /mnt/gentoo/dev
chroot /mnt/gentoo /bin/bash
env-update
source /etc/profile
export PS1="(chroot) $PS1"
emerge wgetpaste
wgetpaste  /boot/grub/grub.conf
ls -l /boot | wgetpaste
post the url's returned
_________________
Defund the FCC.
Back to top
View user's profile Send private message
jk1217NIU
n00b
n00b


Joined: 10 Sep 2012
Posts: 5
Location: DeKalb, IL

PostPosted: Tue Sep 11, 2012 12:48 pm    Post subject: Reply with quote

Here they are:

from grub.conf--

http://bpaste.net/show/44921/

from list in /boot--

http://bpaste.net/show/44923/
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Tue Sep 11, 2012 1:58 pm    Post subject: Reply with quote

jk1217NIU.

Try changing the grub kernel line to:
Code:
kernel /boot/kernel-genkernel-x86_64-3.4.9-gentoo root=/dev/ram0 real_root=/dev/sda3

_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
jk1217NIU
n00b
n00b


Joined: 10 Sep 2012
Posts: 5
Location: DeKalb, IL

PostPosted: Tue Sep 11, 2012 5:54 pm    Post subject: Reply with quote

BillWho,

I made the change you suggested, sadly the problem still remains. The only change from the initial problem is that now the kernel line includes root=/dev/ram0
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Tue Sep 11, 2012 6:26 pm    Post subject: Reply with quote

jk1217NIU,

Try appending rootfstype=ext3 or whatever your '/' partition type is. If that fails, try removing root=/dev/ram0
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
jk1217NIU
n00b
n00b


Joined: 10 Sep 2012
Posts: 5
Location: DeKalb, IL

PostPosted: Tue Sep 11, 2012 6:41 pm    Post subject: Reply with quote

BillWho,

I apologize but I am unclear. Where should I make these changes?
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Tue Sep 11, 2012 6:49 pm    Post subject: Reply with quote

jk1217NIU,

Code:
kernel /boot/kernel-genkernel-x86_64-3.4.9-gentoo root=/dev/ram0 real_root=/dev/sda3 rootfstype=ext3

or
Code:
kernel /boot/kernel-genkernel-x86_64-3.4.9-gentoo real_root=/dev/sda3 rootfstype=ext3

If your '/' partition is ext4 then rootfstype=ext4 :wink:
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
jk1217NIU
n00b
n00b


Joined: 10 Sep 2012
Posts: 5
Location: DeKalb, IL

PostPosted: Tue Sep 11, 2012 8:43 pm    Post subject: Reply with quote

the 2nd option with addition of rootfstype=ext3 and removal of root=/dev/ram0 appears to have worked.

Onto The next stages!

Thank you very much
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum