Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
I like Gnome 3, switched from Nouveau to nVidia [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
splurben
Tux's lil' helper
Tux's lil' helper


Joined: 03 Feb 2004
Posts: 146
Location: Augusta, Southwest Western Australia

PostPosted: Mon Sep 10, 2012 5:09 am    Post subject: I like Gnome 3, switched from Nouveau to nVidia [SOLVED] Reply with quote

I'm running a Gentoo AMD64 System, kernel 3.5.3-gentoo

I am on Gnome 3, my shell version is 3.4.2 (Just noticed Gnome 3.4.2 in latest sync so I'm updating this post.)

(That's right, I actually liked the clean, efficient Gnome 3 interface.)

I was using Nouveau for my nVidia card but I got really tired of all the tearing on video so I switched back to the nVidia proprietary drivers (304.43). The proprietary nVidia drivers are definitely installed and running, see link: http://rehost.splurben.com/lf/nvidia-window1.jpg

During the switch Gnome 3 dropped into F@#%ING fallback mode and I cannot for the life of me find a way to restore full Gnome 3.

I have another Gentoo AMD64 system with the exact same video card [GeForce 8500 GT] and it's using Gnome 3 Shell without fallback.

I really like the clean Gnome 3 interface and less dependency on the mouse.

How the heck do I get Gnome3 / GDM to forget about fallback mode? I've tried tons of things, I've reinstalled Gnome, removed all the configuration files I can find or have located on various other posts relating to Gnome 3 and I'm just totally stumped.

After the upgrade to Gnome 3.4, I am now able to manually start Gnome Shell at the command line with the following command:
Code:
gnome-shell --replace
Before the upgrade to Gnome 3.4, starting gnome-shell from the command line only produced errors but the normal log-in with GDM doesn't even seem to try.

So, now the question is, how do I tell GDM to try to execute gnome-shell once it's decided it has to fall back?

Surely there's a line in a GDM or GCONF configuration that just needs to be changed back to default for Gnome Shell. I'll be damned if I can find it.
_________________
--=>Like... Goodness had nothing to do with it.<=--


Last edited by splurben on Tue Sep 11, 2012 3:27 am; edited 1 time in total
Back to top
View user's profile Send private message
epsilon72
Guru
Guru


Joined: 20 Sep 2007
Posts: 558

PostPosted: Mon Sep 10, 2012 7:19 am    Post subject: Reply with quote

Just to make sure...
You've checked that 3D acceleration is working in other programs, right?
I've ran Gentoo+nvidia for several years and sometimes I still forget to do 'eselect opengl set nvidia' for new installs...
Back to top
View user's profile Send private message
splurben
Tux's lil' helper
Tux's lil' helper


Joined: 03 Feb 2004
Posts: 146
Location: Augusta, Southwest Western Australia

PostPosted: Tue Sep 11, 2012 4:04 am    Post subject: Gnome 3 back from fallback mode Reply with quote

epsilon72 wrote:
Just to make sure...
You've checked that 3D acceleration is working in other programs, right?
I've ran Gentoo+nvidia for several years and sometimes I still forget to do 'eselect opengl set nvidia' for new installs...


Wow, do I feel stupid. Yes, my OpenGL had reverted to XORG-X11.

I know I checked this a while back, but it should have been the first thing I checked when I couldn't get Gnome 3 back up.
Code:
#eselect opengl set nvidia
needed to be set.

I don't do anything in 3D (i.e. Blender or gaming) so I don't think about that aspect of things very often.

By this point I had also completely uninstalled Gnome and wiped every configuration file I could find to do with Gnome.

I'm a little confused about what is being reported by the nvidia-settings because they were reporting that the nVidia driver was fully loaded. I guess that doesn't mean that X11 is passing it to the window manager.

Big CHEERS to EPSILON72,

Kirk
_________________
--=>Like... Goodness had nothing to do with it.<=--
Back to top
View user's profile Send private message
tustylish
n00b
n00b


Joined: 14 Sep 2012
Posts: 2

PostPosted: Wed Sep 19, 2012 4:57 am    Post subject: Reply with quote

I also like that, I forget 'eselect opengl set nvidia' for new installs.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum