Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Strange vobcopy behavior [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Nicias
Guru
Guru


Joined: 06 Dec 2005
Posts: 397

PostPosted: Sat Sep 08, 2012 10:26 pm    Post subject: Strange vobcopy behavior [solved] Reply with quote

I am using vobcopy to pull vobs from and .iso image. When I run a command like this:
Code:
$vobcopy -n 06 -i file.iso -o vob-folder
it works fine for titles 6, 7, 10, 11, 12 and 13. It doesn't work on 8 and 9. On those I get this:
Code:
$vobcopy -n 08 -i file.iso -o vob-folder
[Hint] You use -i. Normally this is not necessary, vobcopy finds the input dir by itself. This option is only there if vobcopy makes trouble.
[Hint] If vobcopy makes trouble, please mail me so that I can fix this (robos@muon.de). Thanks
Vobcopy 1.2.0 - GPL Copyright (c) 2001 - 2009 robos@muon.de
[Hint] All lines starting with "libdvdread:" are not from vobcopy but from the libdvdread-library
[Error] Could not find the provided path (file.iso), typo?
[Error] Could not get the device which belongs to the given path!
[Hint] Will try to open it as a directory/image file

[Info] Path to dvd: file.iso
libdvdread: Using libdvdcss version 1.2.12 for DVD access
[Info] Name of the dvd: DISK_TITLE (actuallyt the real title)
[Info] There are 13 titles on this DVD.
[Error] Invalid title 0.


What gives?


Last edited by Nicias on Sun Sep 09, 2012 7:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
Nicias
Guru
Guru


Joined: 06 Dec 2005
Posts: 397

PostPosted: Sun Sep 09, 2012 7:55 pm    Post subject: Reply with quote

Ok, super weird. It looks like vobcopy can't deal with the argument to -n being written in certain ways. If it starts with a 0, vobcopy things that the number is in octal. So, 06, 07, are no problem, but it borks on 08 and 09. Removing the zeros fixes the problem.
Back to top
View user's profile Send private message
BradN
Advocate
Advocate


Joined: 19 Apr 2002
Posts: 2383
Location: Wisconsin (USA)

PostPosted: Tue Sep 25, 2012 5:11 am    Post subject: Reply with quote

I don't understand who even uses octal for anything but file permissions...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum