Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Error de compilación modulos del kernel [SOLUCIONADO]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
gbobr
n00b
n00b


Joined: 10 Apr 2012
Posts: 10

PostPosted: Sat Sep 08, 2012 5:19 am    Post subject: Error de compilación modulos del kernel [SOLUCIONADO] Reply with quote

Buenas,
¿Cómo va?

Estoy teniendo problemas para compilar el kernel, tanto con genkernel como manualmente me falla la compilación de los módulos.
Cito a continuación las últimas lineas de la consola

Quote:
--
CC [M] drivers/net/wan/hdlc_raw_eth.o
CC [M] drivers/net/wan/hdlc_cisco.o
CC [M] drivers/net/wan/hdlc_fr.o
CC [M] drivers/scsi/iscsi_boot_sysfs.o
CC [M] drivers/scsi/advansys.o
drivers/scsi/advansys.c:71:2: aviso: #warning this driver is still not properly converted to the DMA API
--
CC [M] drivers/scsi/lpfc/lpfc_nportdisc.o
CC [M] drivers/net/wireless/iwlwifi/iwl-1000.o
CC [M] drivers/net/wireless/iwlwifi/iwl-2000.o
CC [M] drivers/scsi/lpfc/lpfc_scsi.o
CC [M] drivers/net/wireless/iwlwifi/iwl-pci.o
cc1: warnings being treated as errors
drivers/scsi/lpfc/lpfc_scsi.c: En la función ‘lpfc_bg_setup_bpl’:
drivers/scsi/lpfc/lpfc_scsi.c:1900:11: error: variable ‘rc’ sin usar
drivers/scsi/lpfc/lpfc_scsi.c: En la función ‘lpfc_bg_setup_bpl_prot’:
drivers/scsi/lpfc/lpfc_scsi.c:2037:11: error: variable ‘rc’ sin usar
drivers/scsi/lpfc/lpfc_scsi.c: En la función ‘lpfc_bg_setup_sgl’:
drivers/scsi/lpfc/lpfc_scsi.c:2256:11: error: variable ‘rc’ sin usar
drivers/scsi/lpfc/lpfc_scsi.c: En la función ‘lpfc_bg_setup_sgl_prot’:
drivers/scsi/lpfc/lpfc_scsi.c:2386:11: error: variable ‘rc’ sin usar
make[3]: *** [drivers/scsi/lpfc/lpfc_scsi.o] Error 1
make[2]: *** [drivers/scsi/lpfc] Error 2
make[1]: *** [drivers/scsi] Error 2
--
CC [M] drivers/net/wireless/zd1211rw/zd_rf_al7230b.o
CC [M] drivers/net/wireless/zd1211rw/zd_rf_uw2453.o
CC [M] drivers/net/wireless/zd1211rw/zd_rf.o
CC [M] drivers/net/wireless/zd1211rw/zd_usb.o
LD [M] drivers/net/wireless/zd1211rw/zd1211rw.o
make: *** [drivers] Error 2
* Gentoo Linux Genkernel; Version 3.4.24_p2
* Running with options: all

* ERROR: Failed to compile the "modules" target...

* -- End log... --

* Please consult /var/log/genkernel.log for more information and any
* errors that were reported above.

* Report any genkernel bugs to bugs.gentoo.org and
* assign your bug to genkernel@gentoo.org. Please include
* as much information as you can in your bug report; attaching
* /var/log/genkernel.log so that your issue can be dealt with effectively.
*
* Please do *not* report compilation failures as genkernel bugs!
*


Agradezco cualquier ayuda que me puedan dar.

Saludos


Last edited by gbobr on Fri Sep 14, 2012 6:40 pm; edited 1 time in total
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1460

PostPosted: Sat Sep 08, 2012 8:42 am    Post subject: Reply with quote

Aqui:
http://forums.gentoo.org/viewtopic-t-935380-start-0.html
Parece que tienen un problema similar al tuyo.
En todo caso dado que buscar en este foro es bastante problematico lo mejor cuando te pase algo parecido es pegar el error en google.
En tu caso he copiado/pegado "make[3]: *** [drivers/scsi/lpfc/lpfc_scsi.o] Error 1" sin comillas y me ha dejado esa referencia entre otras.
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3705

PostPosted: Sat Sep 08, 2012 4:18 pm    Post subject: Reply with quote

según lo que dicen aqui -> https://lkml.org/lkml/2012/6/17/215
este es el parche que necesitas -> http://marc.info/?l=linux-scsi&m=133661285100503&w=2

de cualquier manera, necesitas lpfc ? Por que si no es asi es tan fácil como que deshabilites el soporte para ese hardware en la configuración del kernel.
Aparentemente es el driver para "Emulex LightPulse Fibre Channel Support".

saluetes
Back to top
View user's profile Send private message
gbobr
n00b
n00b


Joined: 10 Apr 2012
Posts: 10

PostPosted: Wed Sep 12, 2012 9:52 pm    Post subject: Reply with quote

Gracias chicos, ya está solucionado.

Compilé el último kernel (3.5.4) y no me dio más ese error.

Saludos y gracias nuevamente
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum