Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Problema aggiornamento
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 161
Location: Rome

PostPosted: Wed Sep 05, 2012 2:38 pm    Post subject: [RISOLTO] Problema aggiornamento Reply with quote

Ciao ragazzi aggiornando mi sono trovato davanti questo problema:

Code:
emerge -uNDpv @world                                                                                                                                                                                                         
These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=kde-base/kwin-4.9.1:4[aqua=]" has unmet requirements.
- kde-base/kwin-4.9.1::gentoo USE="(multilib) (-aqua) -debug -gles -opengl"

  The following REQUIRED_USE flag constraints are unsatisfied:
    !opengl? ( gles ) !gles? ( opengl )

(dependency required by "kde-base/kdebase-meta-4.9.1" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


Idee su come risolvere? :)


Last edited by stifler83 on Thu Sep 06, 2012 5:29 pm; edited 2 times in total
Back to top
View user's profile Send private message
Zizo
Apprentice
Apprentice


Joined: 04 Feb 2010
Posts: 200
Location: Padova, Italy

PostPosted: Wed Sep 05, 2012 6:32 pm    Post subject: Reply with quote

Il pacchetto "kde-base/kwin-4.9.1" richiede come USE flag "opengl" o "gles". Abilita una delle due e procedi con l'installazione.
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1497
Location: Cosenza, Italy

PostPosted: Thu Sep 06, 2012 12:24 pm    Post subject: Reply with quote

Per spiegare meglio:
Code:
The following REQUIRED_USE flag constraints are unsatisfied:
    !opengl? ( gles ) !gles? ( opengl )


Se tu non hai opengl attivo devi avere gles attivo.
Se tu non hai gles attivo devi avere openg attivo.

In sostanza, il programma per funzionare necessita di almeno una delle 2 USE.
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 161
Location: Rome

PostPosted: Thu Sep 06, 2012 5:30 pm    Post subject: Reply with quote

risolto proprio come avete detto ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum