Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Firefox Flash/Java plugin issues
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
ashlyw42
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jul 2012
Posts: 86

PostPosted: Wed Aug 29, 2012 7:54 pm    Post subject: Firefox Flash/Java plugin issues Reply with quote

I recently installed Firefox on my system, and have been trying to install the Flash and Java plugins. When I follow the instructions at http://support.mozilla.org/en-US/kb/install-flash-plugin-view-videos-animations-games , everything goes fine until I try to get back into Firefox, at which point I get an error saying "Failed to add a plugin to the panel: no running instance of xfce4-panel was found". I attempted to install the Java plugin both before and after this. Before, neither FIrefox nor Java's website recognized its existence even though I had already downloaded and unpacked it (I now think this may have been due to a mistake on my part, although I'm not entirely certain), and after, either due to the Flash plugin issues or its own error, I just get the same message as previously stated. If anyone knows how to fix this, please let me know.
Back to top
View user's profile Send private message
mocsokmike
Tux's lil' helper
Tux's lil' helper


Joined: 04 Aug 2005
Posts: 80
Location: Budapest, Hungary

PostPosted: Fri Aug 31, 2012 10:00 am    Post subject: Reply with quote

Do you have www-plugins/adobe-flash installed? That was enough for me.
As for java, post the output of:
Code:
java-config -L

_________________
format c:
emerge system
Back to top
View user's profile Send private message
ashlyw42
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jul 2012
Posts: 86

PostPosted: Sat Sep 01, 2012 5:07 pm    Post subject: Reply with quote

I don't see anything saying www-plugins/adobe-flash in any of my Downloads subfolders or anything, so I'm assuming I don't have it. (Perhaps this may be the root of the xfce4-panel error?) As for java-config -L, all I got was:
Code:

 -bash: java-config: command not found

I presume this means that my attempted Java installation somehow didn't work.
Back to top
View user's profile Send private message
mocsokmike
Tux's lil' helper
Tux's lil' helper


Joined: 04 Aug 2005
Posts: 80
Location: Budapest, Hungary

PostPosted: Sat Sep 01, 2012 6:07 pm    Post subject: Reply with quote

To install the flash plugin, run this command:
Code:
emerge www-plugins/adobe-flash

To install the Java VM do this:
Code:
emerge dev-java/sun-jre-bin

it will return a message similar to this:
Code:
Fetch instructions for dev-java/sun-jre-bin-1.6.0.33-r1:
 * Due to Oracle no longer providing the distro-friendly DLJ bundles, the package
 * has become fetch restricted again. Alternatives are switching to
 * dev-java/icedtea-bin:6 or the source-based dev-java/icedtea:6
 *
 * Please download jre-6u33-linux-x64.bin from:
 * http://www.oracle.com/technetwork/java/javase/downloads/jre6-downloads-1637595.html
 * and move it to /usr/portage/distfiles

Do as it says, download the mentinoed file from the given URL, and save it to /usr/portage/distfiles, then run the emerge command again:
Code:
emerge dev-java/sun-jre-bin

To check your Java installation, use the java-config -L command again. It should return your newly installed Java version.
_________________
format c:
emerge system
Back to top
View user's profile Send private message
forrestfunk81
Guru
Guru


Joined: 07 Feb 2006
Posts: 399
Location: münchen.de

PostPosted: Mon Sep 03, 2012 10:31 am    Post subject: Reply with quote

Take a look at the Gentoo Java guide. You might consider using oracle-jre-bin instead of sun-jre. Sun JRE is the Java SE 6 version whereas Oracle JRE is Java SE 7.
_________________
# cd /pub/
# more beer
Back to top
View user's profile Send private message
ashlyw42
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jul 2012
Posts: 86

PostPosted: Mon Sep 03, 2012 2:47 pm    Post subject: Reply with quote

Firefox started working again even before I installed Java, which is odd but nice. Strangely enough, though, now when I run java-config -L, even though I emerged dev-java/oracle-jdk-bin, the output says that the only VM available on my system is icedtea-bin-6. I don't think it's the same thing, but at this point any Java is good Java as long as it works, so I'm going with it. Thank you both!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum