Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GRUB2 EFI/GPT boot
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
inch
n00b
n00b


Joined: 04 Mar 2012
Posts: 17

PostPosted: Tue Aug 28, 2012 9:21 pm    Post subject: GRUB2 EFI/GPT boot Reply with quote

Hello, I have problems with installing Gentoo on Ivy Bridge Hardware (4th gen core Intel CPU).

The following steps have been made:
- sda1 = ext4 /boot
sda2 = FAT32 EFI partition
sda3 = ext4 /
- Stage3 and Portage unpacked
- Chroot, installed and configured gentoo
- emerge GRUB2 with efi-64 grub platform
grub2-install /dev/sda2

What exactly are the next steps? Grub was installed without error, however sysfs couldn't be accessed.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6710
Location: Goose Creek SC

PostPosted: Tue Aug 28, 2012 11:34 pm    Post subject: Reply with quote

boot cd, enter the chroot, nominally:
CODE:
mount /dev/sda3 /mnt/gentoo
mount /dev/sda1 /mnt/gentoo/boot
cp /etc/resolv.conf /mnt/gentoo/etc/resolv.conf
mount -t proc none /mnt/gentoo/proc
mount -t sysfs sys /mnt/gentoo/sys
mount -o bind /dev /mnt/gentoo/dev
chroot /mnt/gentoo /bin/bash
env-update
source /etc/profile
export PS1="(chroot) $PS1"
then retry
Code:
grub2-install /dev/sda2
and continue
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum