Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gnome 3 umlaute probleme und thunar statt nautilus
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
theblackraven
n00b
n00b


Joined: 12 Oct 2005
Posts: 7

PostPosted: Thu Aug 23, 2012 10:08 am    Post subject: gnome 3 umlaute probleme und thunar statt nautilus Reply with quote

hi,
ich habe ein problem mit den umlauten in nautilus. Zwar werden diese alle richtig dargestellt so lange ich den dateinamen in nautilus selbst ändere.
Wenn ich aber einen usb-stick einstecke, welcher unter windows benutzt wurde, dann werden die umlaute nicht richtig angezeigt.
unter /etc/localegen habe ich folgende einträge:

de_DE.UTF-8 UTF-8
de_DE@euro ISO-8859-15

damit habe ich mein komplettes system neu gebaut.

Außerdem habe ich noch das problem, dass ich parallel xfce installiert habe und nun mein usb-stick mit thunar geöffnet werden soll, wenn ich diesen einstecke. wie stelle ich das wieder auf nautilus um?

danke schon mal im voraus
Back to top
View user's profile Send private message
Christian99
l33t
l33t


Joined: 28 May 2009
Posts: 990

PostPosted: Thu Aug 23, 2012 10:53 am    Post subject: Reply with quote

Das ist kein Problem von gnome. Der Stick wird von windows mit dem charset ISO-8859-15 (vermutlich) beschrieben. Das charset muss dem mount Befehl übergeben werden mit der Option "iocharset=ISO-8859-15", das wird nicht automatisch erkannt. Wie das mit dem automounter geht, weiß ich leider nicht, in der Konsole einfach "-o iocharset=ISO-8859-15" an den mount befehl anhängen.
Back to top
View user's profile Send private message
schmidicom
l33t
l33t


Joined: 09 Mar 2006
Posts: 989
Location: Schweiz

PostPosted: Thu Aug 23, 2012 2:09 pm    Post subject: Reply with quote

Christian99 wrote:
Das ist kein Problem von gnome. Der Stick wird von windows mit dem charset ISO-8859-15 (vermutlich) beschrieben. Das charset muss dem mount Befehl übergeben werden mit der Option "iocharset=ISO-8859-15", das wird nicht automatisch erkannt. Wie das mit dem automounter geht, weiß ich leider nicht, in der Konsole einfach "-o iocharset=ISO-8859-15" an den mount befehl anhängen.

Diese Kerneloptionen wären auch ne Möglichkeit dies sicher zu stellen sofern beim mounten nichts anderes angegeben wird:
Code:
CONFIG_FAT_DEFAULT_CODEPAGE=850
CONFIG_FAT_DEFAULT_IOCHARSET="iso8859-15"

_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)
Back to top
View user's profile Send private message
theblackraven
n00b
n00b


Joined: 12 Oct 2005
Posts: 7

PostPosted: Thu Aug 23, 2012 7:00 pm    Post subject: Reply with quote

ah, es ging noch einfacher. das problem war, dass ich in der /etc/fstab folgenden eintrag hatte:

/dev/sdb1 /home/theblackraven/sdcard vfat users,noauto 0 0 # habe kurzzeitig mal eine sd karte als 2 Festplatte bentuzt.

dieser war dafür verantwortlich, dass der usb stick falsch gemountet wurde.
das problem mit thunar habe ich einfach so gelöst, dass ich es deinstalliert habe. XFCE dient sowieso nur als reines backup....
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum