Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
--autounmask doesn't work
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
ckid113
n00b
n00b


Joined: 19 Oct 2010
Posts: 41

PostPosted: Thu Aug 16, 2012 6:13 pm    Post subject: --autounmask doesn't work Reply with quote

I have added xmms-zombie overlay and trying to install xmms but there are masked packages and --autounmask doesn't seem to work. Please review:

Code:

# emerge xmms -av --autounmask y

These are the packages that would be merged, in order:

Calculating dependencies / * ERROR: media-plugins/xmms-mikmod-1.2.10 failed (depend phase):
 *   xmms-plugin.eclass could not be found by inherit()
 *
 * Call stack:
 *                   ebuild.sh, line 541:  Called source '/usr/local/portage/layman/xmms-zombie/media-plugins/xmms-mikmod/xmms-mikmod-1.2.10.ebuild'
 *   xmms-mikmod-1.2.10.ebuild, line   6:  Called inherit 'xmms-plugin'
 *                   ebuild.sh, line 259:  Called die
 * The specific snippet of code:
 *         [ ! -e "$location" ] && die "${1}.eclass could not be found by inherit()"
 *
 * If you need support, post the output of `emerge --info '=media-plugins/xmms-mikmod-1.2.10'`,
 * the complete build log and the output of `emerge -pqv '=media-plugins/xmms-mikmod-1.2.10'`.
 * This ebuild is from an overlay named 'xmms-zombie': '/usr/local/portage/layman/xmms-zombie/'
 * Working directory: '/usr/portage/app-portage'
 * S: '/var/tmp/portage/media-plugins/xmms-mikmod-1.2.10/work/xmms-mikmod-1.2.10'
... done!

!!! All ebuilds that could satisfy "media-plugins/xmms-mikmod" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-plugins/xmms-mikmod-1.2.10::xmms-zombie (masked by: corruption)

(dependency required by "media-sound/xmms-1.2.10-r15[mikmod]" [ebuild])
(dependency required by "xmms" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2470
Location: Austria

PostPosted: Thu Aug 16, 2012 6:25 pm    Post subject: Reply with quote

There's a different error:

Code:
Calculating dependencies / * ERROR: media-plugins/xmms-mikmod-1.2.10 failed (depend phase):
 *   xmms-plugin.eclass could not be found by inherit()

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32099
Location: 56N 3W

PostPosted: Thu Aug 16, 2012 6:37 pm    Post subject: Reply with quote

ckid113,

Code:
(masked by: corruption)
is the misleading message you get when your portage does not understand the ebuild, usually becase portage is too old.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum