Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Software blocked during updating my system...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
hyson
n00b
n00b


Joined: 21 Aug 2010
Posts: 23
Location: Shanghai, China

PostPosted: Wed Aug 15, 2012 7:54 am    Post subject: [Solved] Software blocked during updating my system... Reply with quote

It's a long long time since my last update.

Today, I update my system.
But some software blocked this update.

I encountered this issue before.
But at that time, my system was destroyed by my mis-operation.

The online document said, I can uninstall some software.
But, I don't know which software to uninstall...


This time, I wish some body could help me out.
Thanks.



localhost hyson # emerge --update --deep --newuse --fetchonly world
Code:

Calculating dependencies... done!
[ebuild     U  ] sys-libs/glibc-2.15-r2 [2.14.1-r3]
[ebuild     U  ] app-text/poppler-data-0.4.5-r1 [0.4.4]
[ebuild     U  ] sys-devel/gcc-config-1.7.3 [1.5-r2]
[ebuild     U  ] sys-devel/binutils-config-3-r3 [2-r1]
[ebuild     U  ] sys-devel/automake-wrapper-7 [6]
[ebuild     U  ] dev-libs/json-c-0.9-r1 [0.9] USE="-static-libs%"
[ebuild  N     ] app-shells/push-1.5
[ebuild     U  ] sys-power/acpid-2.0.16-r1 [2.0.14]
[ebuild     U  ] app-portage/portage-utils-0.10 [0.8]
[ebuild     U  ] sys-apps/sdparm-1.07 [1.06]
[ebuild     U  ] sys-kernel/linux-firmware-20120502 [20120125]
[ebuild     U  ] dev-libs/icu-49.1.2 [49.1.1-r1]
[ebuild     U  ] sys-libs/cracklib-2.8.19 [2.8.16] USE="zlib%* -static-libs%"
[ebuild     U  ] app-misc/pax-utils-0.4 [0.2.3]
[ebuild     U  ] sys-apps/file-5.11 [5.09]
[ebuild  N    ~] dev-libs/gobject-introspection-common-1.32.1
[ebuild     U  ] sys-devel/m4-1.4.16 [1.4.15]
[ebuild  N     ] sys-libs/mtdev-1.1.2  USE="-static-libs"
[ebuild     U  ] dev-util/strace-4.7 [4.6]
[ebuild     U  ] media-libs/libjpeg-turbo-1.2.1 [1.2.0-r1]
[ebuild     U  ] dev-libs/libassuan-2.0.3 [2.0.1]
[ebuild     U  ] sys-apps/ed-1.6 [1.4]
[ebuild     U  ] media-libs/tiff-4.0.2 [4.0.1-r1]
[ebuild     U  ] media-libs/libv4l-0.8.8 [0.8.5]
[ebuild     U  ] dev-util/pkgconfig-0.27 [0.26] USE="-internal-glib%"
[ebuild     U  ] dev-libs/libevent-2.0.19 [2.0.18]
[ebuild     U  ] sys-apps/busybox-1.20.1 [1.19.3-r1] USE="-math% -sep-usr%"
[ebuild     U  ] sys-apps/debianutils-4.3.2 [3.4.4]
[ebuild     U  ] x11-proto/xproto-7.0.23-r1 [7.0.22]
[ebuild     U  ] x11-proto/xextproto-7.2.1 [7.2.0]
[ebuild     U  ] x11-proto/inputproto-2.2 [2.0.2]
[ebuild     U  ] x11-proto/kbproto-1.0.6 [1.0.5]
[ebuild     U  ] dev-db/sqlite-3.7.13 [3.7.10]
[ebuild     U  ] x11-libs/xtrans-1.2.7 [1.2.6]
[ebuild     U  ] dev-libs/libgcrypt-1.5.0-r2 [1.4.6]
[ebuild     U  ] x11-libs/libdrm-2.4.33 [2.4.27] VIDEO_CARDS="(-omap)"
[ebuild     U  ] x11-libs/pixman-0.26.0 [0.24.0] USE="-test%"
[ebuild  N     ] media-libs/jbig2dec-0.11-r1  USE="png -static-libs -test"
[ebuild     U  ] media-libs/libvorbis-1.3.3 [1.3.2]
[ebuild     U  ] x11-proto/scrnsaverproto-1.2.2 [1.2.1]
[ebuild     U  ] dev-libs/nspr-4.9.1 [4.9]
[ebuild     U  ] x11-proto/recordproto-1.14.2 [1.14.1]
[ebuild     U  ] x11-proto/xf86dgaproto-2.1-r1 [2.1]
[ebuild     U  ] x11-proto/fontsproto-2.1.2 [2.1.1]
[ebuild   R    ] dev-libs/nettle-2.4  USE="(-ssl%*)"
[ebuild     U  ] x11-proto/bigreqsproto-1.1.2 [1.1.1]
[ebuild     U  ] x11-libs/libpciaccess-0.13.1 [0.12.1]
[ebuild     U  ] x11-proto/xf86rushproto-1.1.2-r1 [1.1.2]
[ebuild     U  ] x11-proto/xcmiscproto-1.2.2 [1.2.1]
[ebuild     U  ] media-libs/libdvdcss-1.2.12 [1.2.11]
[ebuild     U  ] media-sound/lame-3.99.5 [3.99.3]
[ebuild  N     ] media-libs/vo-aacenc-0.1.2  USE="-examples (-neon) -static-libs"
[ebuild     U  ] media-fonts/font-util-1.3.0 [1.2.0]
[ebuild     U  ] dev-libs/iniparser-3.1 [3.0b-r1] USE="-doc% -examples% -static-libs%"
[ebuild     U  ] app-admin/gam-server-0.1.10-r1 [0.1.10]
[ebuild     U  ] x11-libs/libICE-1.0.8 [1.0.7]
[ebuild     U  ] x11-libs/libXau-1.0.7 [1.0.6]
[ebuild     U  ] x11-libs/libXdmcp-1.1.1 [1.1.0]
[ebuild     U  ] dev-libs/nss-3.13.5 [3.13.4]
[ebuild     U  ] x11-libs/libfontenc-1.1.1 [1.1.0]
[ebuild     U  ] x11-misc/makedepend-1.0.4 [1.0.3]
[ebuild     U  ] net-misc/curl-7.25.0-r1 [7.24.0] CURL_SSL="nss%* -axtls% -gnutls% -openssl% -polarssl%"
[ebuild     U  ] x11-base/xorg-drivers-1.12 [1.11] VIDEO_CARDS="-modesetting%"
[ebuild     U  ] x11-libs/qt-core-4.8.2 [4.8.1-r3]
[ebuild     U  ] x11-libs/qt-script-4.8.2 [4.8.1]
[blocks b      ] <x11-libs/qt-script-4.8.2:4 ("<x11-libs/qt-script-4.8.2:4" is blocking x11-libs/qt-qt3support-4.8.2, x11-libs/qt-core-4.8.2, x11-libs/qt-sql-4.8.2, x11-libs/qt-gui-4.8.2, x11-libs/qt-opengl-4.8.2, x11-libs/qt-dbus-4.8.2)
[ebuild     U  ] x11-libs/qt-sql-4.8.2 [4.8.1] USE="-oci8%"
[blocks b      ] <x11-libs/qt-sql-4.8.2:4 ("<x11-libs/qt-sql-4.8.2:4" is blocking x11-libs/qt-qt3support-4.8.2, x11-libs/qt-core-4.8.2, x11-libs/qt-script-4.8.2, x11-libs/qt-gui-4.8.2, x11-libs/qt-opengl-4.8.2, x11-libs/qt-dbus-4.8.2)
[ebuild   R    ] sys-devel/gettext-0.18.1.1-r1  USE="-git*"
[ebuild     U  ] sys-apps/sed-4.2.1-r1 [4.2.1]
[ebuild     U  ] sys-apps/util-linux-2.20.1-r2 [2.20.1-r1]
[ebuild     U  ] x11-libs/libSM-1.2.1 [1.2.0]
[ebuild     U  ] app-admin/eselect-1.3.1 [1.2.18]
[ebuild     U  ] app-admin/eselect-opengl-1.2.5-r1 [1.2.4]
[ebuild     U  ] sys-devel/binutils-2.22-r1 [2.21.1-r1]
[ebuild     U  ] sys-devel/make-3.82-r3 [3.82-r1]
[ebuild     U  ] x11-proto/glproto-1.4.15 [1.4.14-r1]
[ebuild     U  ] sys-apps/grep-2.12 [2.9]
[ebuild     U  ] sys-process/psmisc-22.16 [22.14]
[ebuild  N     ] dev-libs/elfutils-0.149  USE="bzip2 nls zlib -lzma"
[ebuild     U ~] dev-libs/glib-2.32.4 [2.30.3] USE="-static-libs*"
[ebuild   R    ] app-text/hunspell-1.3.2-r3  LINGUAS="-is% -km% -pt_BR% -sq%"
[ebuild     U  ] media-libs/libexif-0.6.21 [0.6.20]
[ebuild     U  ] app-admin/eselect-xvmc-0.3 [0.2]
[ebuild  NS    ] app-text/docbook-xml-dtd-4.2-r2 [4.1.2-r6, 4.3-r1, 4.4-r2]
[ebuild     U  ] media-libs/libmp4v2-2.0.0 [1.9.1] USE="-test%"
[ebuild     U  ] dev-lang/python-2.7.3-r2 [2.7.3-r1]
[ebuild     U  ] dev-libs/libatasmart-0.19 [0.18]
[ebuild  NS    ] sys-kernel/gentoo-sources-3.3.8 [3.2.12] USE="-build -deblob -symlink"
[ebuild     U  ] sys-apps/portage-2.1.11.9 [2.1.10.49] USE="(-pypy1_9)"
[ebuild     U  ] x11-proto/xcb-proto-1.7.1 [1.6-r2]
[ebuild     U  ] x11-libs/libxcb-1.8.1 [1.7]
[ebuild     U  ] x11-libs/libX11-1.5.0 [1.4.4]
[ebuild     U  ] x11-libs/libXext-1.3.1 [1.3.0]
[ebuild     U  ] x11-libs/libXt-1.1.3 [1.1.1]
[ebuild     U  ] sys-apps/dbus-1.6.2 [1.4.20] USE="-systemd%"
[ebuild     U  ] x11-libs/qt-dbus-4.8.2 [4.8.1]
[blocks b      ] <x11-libs/qt-dbus-4.8.2:4 ("<x11-libs/qt-dbus-4.8.2:4" is blocking x11-libs/qt-qt3support-4.8.2, x11-libs/qt-core-4.8.2, x11-libs/qt-sql-4.8.2, x11-libs/qt-script-4.8.2, x11-libs/qt-gui-4.8.2, x11-libs/qt-opengl-4.8.2)
[ebuild     U  ] x11-libs/qt-gui-4.8.2 [4.8.1-r1]
[blocks b      ] <x11-libs/qt-gui-4.8.2:4 ("<x11-libs/qt-gui-4.8.2:4" is blocking x11-libs/qt-qt3support-4.8.2, x11-libs/qt-core-4.8.2, x11-libs/qt-sql-4.8.2, x11-libs/qt-script-4.8.2, x11-libs/qt-opengl-4.8.2, x11-libs/qt-dbus-4.8.2)
[ebuild     U  ] x11-libs/qt-qt3support-4.8.2 [4.8.1]
[blocks b      ] >x11-libs/qt-opengl-4.8.1-r9999 (">x11-libs/qt-opengl-4.8.1-r9999" is blocking x11-libs/qt-gui-4.8.1-r1, x11-libs/qt-qt3support-4.8.1, x11-libs/qt-core-4.8.1-r3, x11-libs/qt-sql-4.8.1, x11-libs/qt-script-4.8.1, x11-libs/qt-dbus-4.8.1)
[blocks b      ] <x11-libs/qt-qt3support-4.8.2:4 ("<x11-libs/qt-qt3support-4.8.2:4" is blocking x11-libs/qt-core-4.8.2, x11-libs/qt-sql-4.8.2, x11-libs/qt-script-4.8.2, x11-libs/qt-gui-4.8.2, x11-libs/qt-opengl-4.8.2, x11-libs/qt-dbus-4.8.2)
[ebuild     U  ] dev-libs/dbus-glib-0.100 [0.98]
[ebuild     U  ] x11-libs/libXrender-0.9.7 [0.9.6]
[ebuild     U  ] x11-libs/libXi-1.6.1 [1.4.3-r1]
[ebuild     U  ] x11-libs/libXv-1.0.7 [1.0.6]
[ebuild     U  ] x11-libs/libXmu-1.1.1 [1.1.0]
[ebuild     U  ] x11-libs/libXxf86vm-1.1.2 [1.1.1]
[ebuild     U  ] x11-libs/libxkbfile-1.0.8 [1.0.7]
[ebuild     U  ] x11-libs/libXScrnSaver-1.2.2 [1.2.1]
[ebuild     U  ] x11-libs/libXpm-3.5.10 [3.5.9]
[ebuild     U  ] x11-libs/libXinerama-1.1.2 [1.1.1]
[ebuild     U  ] x11-libs/libXres-1.0.6 [1.0.5]
[ebuild     U  ] x11-libs/libXfont-1.4.5 [1.4.4]
[ebuild     U  ] x11-apps/xmodmap-1.0.7 [1.0.5]
[ebuild     U  ] x11-apps/mkfontscale-1.1.0 [1.0.9-r1]
[ebuild     U  ] net-ftp/lftp-4.3.7 [4.3.6]
[ebuild     U  ] app-emulation/virtualbox-modules-4.1.12 [4.1.4]
[ebuild     U  ] app-portage/eix-0.25.5 [0.23.10] USE="dep%*"
[ebuild     U  ] net-misc/rdesktop-1.7.1 [1.7.0]
[ebuild     U  ] x11-apps/xwud-1.0.4 [1.0.3]
[ebuild     U  ] x11-apps/luit-1.1.1 [1.1.0]
[ebuild     U  ] x11-apps/xcmsdb-1.0.4 [1.0.3]
[ebuild     U  ] x11-apps/xlsatoms-1.1.1 [1.1.0]
[ebuild     U  ] x11-libs/libXxf86dga-1.1.3 [1.1.2]
[ebuild     U  ] sys-libs/tdb-1.2.9 [1.2.7-r1]
[ebuild     U  ] media-libs/faac-1.28-r3 [1.28-r1]
[ebuild     U  ] x11-libs/libXcursor-1.1.13 [1.1.12]
[ebuild     U  ] x11-libs/libXtst-1.2.1 [1.2.0]
[ebuild     U  ] x11-apps/xauth-1.0.7 [1.0.6]
[ebuild     U  ] dev-python/numpy-1.6.1-r1 [1.6.0]
[ebuild     U  ] dev-python/dbus-python-1.1.1 [1.0.0]
[ebuild     U  ] x11-libs/libXaw-1.0.11 [1.0.9]
[ebuild     U  ] x11-libs/libXvMC-1.0.7 [1.0.6]
[ebuild     U  ] app-portage/gentoolkit-0.3.0.6-r3 [0.3.0.5]
[ebuild     U  ] x11-apps/xinput-1.6.0 [1.5.3]
[ebuild     U  ] x11-apps/xgamma-1.0.5 [1.0.4]
[ebuild     U  ] x11-apps/xhost-1.0.5 [1.0.4]
[ebuild     U  ] x11-apps/setxkbmap-1.3.0 [1.2.0]
[ebuild     U  ] x11-apps/xkbevd-1.1.3 [1.1.2]
[ebuild     U  ] x11-apps/xwd-1.0.5 [1.0.4]
[ebuild     U  ] x11-apps/xpr-1.0.4 [1.0.3]
[ebuild     U  ] x11-apps/mkfontdir-1.0.7 [1.0.6]
[ebuild     U  ] media-libs/mesa-8.0.3 [7.11.2] USE="-d3d% -g3dvl% -gles1% -gles2% -vdpau% (-wayland) -xa% -xvmc%" VIDEO_CARDS="-i915% -i965% -r100% -r200% -r300% -r600%"
[ebuild     U  ] x11-misc/xkeyboard-config-2.6 [2.4.1-r3]
[ebuild     U  ] x11-apps/xinit-1.3.2 [1.3.1-r1]
[ebuild     U  ] x11-apps/xev-1.2.0 [1.1.0]
[ebuild     U  ] x11-apps/bitmap-1.0.6 [1.0.5]
[ebuild     U  ] x11-apps/xdpyinfo-1.3.0-r1 [1.3.0]
[ebuild     U  ] x11-apps/xcursorgen-1.0.5 [1.0.4]
[ebuild     U  ] x11-base/xorg-server-1.12.2 [1.11.2-r2] USE="(-selinux)"
[ebuild     U  ] x11-libs/libxklavier-5.2.1 [5.1] USE="introspection%*"
[ebuild     U  ] x11-drivers/xf86-input-keyboard-1.6.1 [1.6.0]
[ebuild     U  ] x11-drivers/xf86-input-mouse-1.7.2 [1.7.1]
[ebuild     U  ] x11-drivers/xf86-input-evdev-2.7.0 [2.6.0]
[ebuild     U  ] x11-drivers/xf86-input-synaptics-1.6.2 [1.4.0]
[ebuild     U  ] dev-games/irrlicht-1.7.3 [1.7.2]
[ebuild     U  ] x11-libs/qt-opengl-4.8.2 [4.8.1]
[blocks b      ] >x11-libs/qt-script-4.8.1-r9999 (">x11-libs/qt-script-4.8.1-r9999" is blocking x11-libs/qt-gui-4.8.1-r1, x11-libs/qt-qt3support-4.8.1, x11-libs/qt-core-4.8.1-r3, x11-libs/qt-sql-4.8.1, x11-libs/qt-dbus-4.8.1, x11-libs/qt-opengl-4.8.1)
[blocks b      ] >x11-libs/qt-dbus-4.8.1-r9999 (">x11-libs/qt-dbus-4.8.1-r9999" is blocking x11-libs/qt-gui-4.8.1-r1, x11-libs/qt-qt3support-4.8.1, x11-libs/qt-core-4.8.1-r3, x11-libs/qt-sql-4.8.1, x11-libs/qt-script-4.8.1, x11-libs/qt-opengl-4.8.1)
[blocks b      ] >x11-libs/qt-gui-4.8.1-r9999 (">x11-libs/qt-gui-4.8.1-r9999" is blocking x11-libs/qt-qt3support-4.8.1, x11-libs/qt-core-4.8.1-r3, x11-libs/qt-sql-4.8.1, x11-libs/qt-script-4.8.1, x11-libs/qt-dbus-4.8.1, x11-libs/qt-opengl-4.8.1)
[blocks b      ] >x11-libs/qt-core-4.8.1-r9999 (">x11-libs/qt-core-4.8.1-r9999" is blocking x11-libs/qt-gui-4.8.1-r1, x11-libs/qt-qt3support-4.8.1, x11-libs/qt-sql-4.8.1, x11-libs/qt-script-4.8.1, x11-libs/qt-dbus-4.8.1, x11-libs/qt-opengl-4.8.1)
[blocks b      ] >x11-libs/qt-sql-4.8.1-r9999 (">x11-libs/qt-sql-4.8.1-r9999" is blocking x11-libs/qt-gui-4.8.1-r1, x11-libs/qt-qt3support-4.8.1, x11-libs/qt-core-4.8.1-r3, x11-libs/qt-script-4.8.1, x11-libs/qt-dbus-4.8.1, x11-libs/qt-opengl-4.8.1)
[blocks b      ] <x11-libs/qt-opengl-4.8.2:4 ("<x11-libs/qt-opengl-4.8.2:4" is blocking x11-libs/qt-qt3support-4.8.2, x11-libs/qt-core-4.8.2, x11-libs/qt-sql-4.8.2, x11-libs/qt-script-4.8.2, x11-libs/qt-gui-4.8.2, x11-libs/qt-dbus-4.8.2)
[blocks b      ] >x11-libs/qt-qt3support-4.8.1-r9999 (">x11-libs/qt-qt3support-4.8.1-r9999" is blocking x11-libs/qt-gui-4.8.1-r1, x11-libs/qt-core-4.8.1-r3, x11-libs/qt-sql-4.8.1, x11-libs/qt-script-4.8.1, x11-libs/qt-dbus-4.8.1, x11-libs/qt-opengl-4.8.1)
[ebuild     U  ] x11-libs/libXft-2.3.1 [2.2.0]
[ebuild     U  ] x11-libs/xcb-util-0.3.9 [0.3.8]
[ebuild     U  ] x11-libs/xcb-util-wm-0.3.9 [0.3.8]
[ebuild     U  ] x11-libs/xcb-util-keysyms-0.3.9 [0.3.8]
[ebuild     U  ] x11-libs/xcb-util-image-0.3.9 [0.3.8]
[ebuild     U ~] dev-libs/gobject-introspection-1.32.1 [1.30.0-r2] USE="-doctool%"
[ebuild     U ~] app-text/poppler-0.20.3 [0.18.4-r1]
[ebuild     U  ] x11-drivers/nvidia-drivers-295.59 [295.49]
[ebuild     U  ] app-i18n/scim-1.4.11-r1 [1.4.9-r1]
[ebuild     U  ] media-gfx/imagemagick-6.7.8.7 [6.7.6.4] USE="-postscript%"
[ebuild     U  ] dev-vcs/git-1.7.8.6 [1.7.3.4-r1] USE="python%*"
[ebuild     U  ] app-text/ghostscript-gpl-9.05-r1 [9.04-r4]
[ebuild     U  ] net-print/foomatic-filters-4.0.16 [4.0.15]
[ebuild     U  ] sys-fs/udisks-1.0.4-r2 [1.0.4-r1]
[ebuild     U  ] media-libs/libsdl-1.2.15-r2 [1.2.15]
[ebuild     U  ] media-libs/libao-1.1.0-r1 [1.0.0-r1]
[ebuild     U  ] media-sound/mpg123-1.14.2 [1.13.2]
[ebuild  N     ] media-video/ffmpeg-0.10.3  USE="X aac alsa bzip2 encode hardcoded-tables mp3 pulseaudio sdl truetype vorbis x264 xvid zlib -3dnow -3dnowext -aacplus (-altivec) -amr -avx -bindist -cdio (-celt) -cpudetection -debug -dirac -doc -faac -frei0r -gnutls -gsm -ieee1394 -jack -jpeg2k -libass -libv4l -mmx -mmxext -modplug (-neon) -network -openal -openssl -oss -pic -rtmp -schroedinger -speex -ssse3 -static-libs -test -theora -threads -v4l -vaapi -vdpau (-vis) -vpx" FFTOOLS="aviocat cws2fws ffeval graph2dot ismindex pktdumper qt-faststart trasher"
[ebuild  N     ] virtual/ffmpeg-0.10.2-r1  USE="X encode mp3 sdl truetype x264 -jpeg2k -theora -threads -vaapi -vdpau"
[ebuild  N     ] media-video/mplayer2-2.0_p20120309  USE="X a52 alsa cdio dts dv dvd dvdnav enca faad gif iconv ipv6 jpeg libass mad mmx mng mp3 network opengl png pulseaudio quicktime rar rtc sdl shm speex theora truetype unicode vorbis xscreensaver xv xvid -3dnow -3dnowext -aalib (-altivec) (-aqua) -bidi -bindist -bl -bluray -bs2b -cddb -cdparanoia -cpudetection -custom-cpuopts -debug -directfb (-doc) -dvb -dxr3 -fbcon -ftp -ggi -jack -joystick -ladspa -libcaca -lirc -md5sum -mmxext -nas -nut -oss -pnm -pvr -radio (-real) -samba -sse -sse2 -ssse3 -symlink -tga -v4l -vdpau -win32codecs -xanim -xinerama" VIDEO_CARDS="-mga -s3virge -tdfx -vesa"
[ebuild   R    ] media-video/smplayer-0.8.0  LINGUAS="-ar_SY% -el_GR% -ro_RO% -ru_RU% -sl_SI% -uk_UA% -vi_VN% (-ar%) (-el%) (-ro%) (-ru%) (-sl%) (-uk%) (-vi%)"
[ebuild     U  ] net-im/pidgin-2.10.6 [2.10.4]
[ebuild     U  ] x11-libs/libnotify-0.7.5 [0.7.4] USE="(symlink%*)"
[ebuild     U  ] www-client/firefox-10.0.6 [10.0.4]
[ebuild     U  ] media-gfx/gimp-2.6.12-r2 [2.6.12] LINGUAS="-am% -ar% -ast% -az% -be% -bg% -ca% -ca@valencia% -cs% -da% -de% -dz% -el% -en_CA% -en_GB% -eo% -es% -et% -eu% -fa% -fi% -fr% -ga% -gl% -gu% -he% -hi% -hr% -hu% -id% -is% -it% -ja% -ka% -kk% -km% -kn% -ko% -lt% -lv% -mk% -ml% -mr% -ms% -my% -nb% -nds% -ne% -nl% -nn% -oc% -or% -pa% -pl% -pt% -pt_BR% -ro% -ru% -rw% -si% -sk% -sl% -sr% -sr@latin% -sv% -ta% -th% -tr% -tt% -uk% -vi% -xh% -yi% -zh_CN% -zh_HK% -zh_TW%"
[ebuild     U  ] dev-java/icedtea-bin-6.1.11.3-r1 [6.1.11.1]
[ebuild     U  ] virtual/jdk-1.6.0-r1 [1.6.0]
[ebuild  N     ] app-admin/eselect-pinentry-0.3
[ebuild     U  ] app-crypt/pinentry-0.8.1 [0.8.0]
[blocks b      ] <app-crypt/pinentry-0.8.0-r1 ("<app-crypt/pinentry-0.8.0-r1" is blocking app-admin/eselect-pinentry-0.3)
[ebuild     U  ] app-crypt/gnupg-2.0.19 [2.0.17] USE="readline%* usb%*"
[ebuild     U  ] sys-libs/talloc-2.0.7 [2.0.1-r2] USE="-python%"
[blocks B      ] <dev-libs/gobject-introspection-1.32.0 ("<dev-libs/gobject-introspection-1.32.0" is blocking dev-libs/gobject-introspection-common-1.32.1)
[blocks B      ] <sys-libs/talloc-2.0.5 ("<sys-libs/talloc-2.0.5" is blocking sys-libs/talloc-2.0.7)
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:
dev-libs/gobject-introspection:0
  (dev-libs/gobject-introspection-1.30.0-r2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)
  (dev-libs/gobject-introspection-1.32.1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/gobject-introspection-1.32.1 required by (app-text/poppler-0.20.3::gentoo, ebuild scheduled for merge)
dev-libs/glib:2
  (dev-libs/glib-2.32.4::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.31.22:2 required by (dev-libs/gobject-introspection-1.32.1::gentoo, ebuild scheduled for merge)
  (dev-libs/glib-2.30.3::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)
app-emulation/virtualbox-modules:0
  (app-emulation/virtualbox-modules-4.1.4::hyson_overlay, installed) pulled in by
    ~app-emulation/virtualbox-modules-4.1.4 required by (app-emulation/virtualbox-4.1.4::gentoo, installed)
  (app-emulation/virtualbox-modules-4.1.12::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)
app-text/poppler:0
  (app-text/poppler-0.18.4-r1::gentoo, installed) pulled in by
    >=app-text/poppler-0.18.0[xpdf-headers] required by (app-text/xpdf-3.02-r4::gentoo, installed)
  (app-text/poppler-0.20.3::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.
For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

The following keyword changes are necessary to proceed:
#required by dev-libs/gobject-introspection-1.32.1, required by app-text/poppler-0.20.3[introspection,cairo], required by media-gfx/gimp-2.6.12-r2[pdf], required by @selected, required by @world (argument)
=dev-libs/gobject-introspection-common-1.32.1 ~x86
#required by app-text/poppler-0.20.3[introspection,cairo], required by media-gfx/gimp-2.6.12-r2[pdf], required by @selected, required by @world (argument)
=dev-libs/gobject-introspection-1.32.1 ~x86
#required by net-libs/libproxy-0.4.7[gnome], required by net-libs/glib-networking-2.30.2[libproxy], required by net-libs/libsoup-2.36.1-r1, required by dev-libs/libgdata-0.8.1-r2, required by gnome-extra/evolution-data-server-2.32.3-r2, required by net-im/pidgin-2.10.6[eds,gtk], required by @selected, required by @world (argument)
=dev-libs/glib-2.32.4 ~x86
Use --autounmask-write to write changes to config files (honoring CONFIG_PROTECT).
!!! The following updates are masked by LICENSE changes:
- www-plugins/adobe-flash-11.2.202.236::gentoo (masked by: AdobeFlash-10.3 license(s))
A copy of the 'AdobeFlash-10.3' license is located at '/usr/portage/licenses/AdobeFlash-10.3'.
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

!!! The following installed packages are masked:
- net-p2p/mldonkey-3.0.6::gentoo (masked by: package.mask)
- www-plugins/adobe-flash-11.1.102.55::gentoo (masked by: AdobeFlash-10.3 license(s))
A copy of the 'AdobeFlash-10.3' license is located at '/usr/portage/licenses/AdobeFlash-10.3'.
- app-emulation/virtualbox-4.1.4::gentoo (masked by: package.mask)
- x11-wm/compiz-fusion-0.8.6::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org> (22 Jan 2012)
# Mask compiz for last-rites unless someone steps up
# to maintain it. Proxy maintainers will take care of this.
- x11-plugins/compiz-plugins-extra-0.8.6-r1::gentoo (masked by: package.mask)
- x11-themes/emerald-themes-0.5.2::gentoo (masked by: package.mask)
- x11-libs/compizconfig-backend-gconf-0.8.4-r2::gentoo (masked by: package.mask)
- x11-libs/compiz-bcop-0.8.4::gentoo (masked by: package.mask)
- x11-wm/emerald-0.8.4-r2::gentoo (masked by: package.mask)
- x11-plugins/compiz-plugins-main-0.8.6-r1::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.



#emerge --info
Code:

Portage 2.1.10.49 (default/linux/x86/10.0/desktop/gnome, gcc-4.5.3, glibc-2.14.1-r3, 3.2.1-gentoo-r2 i686)
=================================================================
System uname: Linux-3.2.1-gentoo-r2-i686-Intel-R-_Core-TM-_i3_CPU_M_350_@_2.27GHz-with-gentoo-2.1
Timestamp of tree: Wed, 15 Aug 2012 07:00:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r1, 3.2.3
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo hyson_overlay
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=prescott -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=prescott -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://mirrors.163.com/gentoo/ rsync://mirrors.xmu.edu.cn/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa berkdb bluetooth branding bzip2 cairo cdda cdr cli colord consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran gdbm gif gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv ipv6 jpeg lcms ldap libnotify mad mng modules mp3 mp4 mpeg mudflap nautilus ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pppd pulseaudio qt3support qt4 readline sdl session socialweb spell ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 x86 xcb xml xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


Last edited by hyson on Tue Oct 16, 2012 3:59 am; edited 1 time in total
Back to top
View user's profile Send private message
hyson
n00b
n00b


Joined: 21 Aug 2010
Posts: 23
Location: Shanghai, China

PostPosted: Wed Aug 15, 2012 8:00 am    Post subject: Reply with quote

If you're interested in my last miserable experience, you can refer to:http://forums.gentoo.org/viewtopic-t-897390-highlight-.html

Finally I had to reinstall my Gentoo...
So, I'm afraid of this "Software Block" problem...

This time, I wish some guy could teach me how to solve this issue.
Back to top
View user's profile Send private message
Dethnull
n00b
n00b


Joined: 15 Aug 2012
Posts: 1
Location: Planet earth

PostPosted: Wed Aug 15, 2012 8:44 am    Post subject: Reply with quote

The software block problem can be a breeze really. First thing to try is to emerge each of the packages are the blocking the other packages. Start at the top and work your way down.

As It states in the Gentoo handbook for portage complaints about blocks, http://www.gentoo.org/doc/en/handbook/handbook-amd64.xml?part=2&chap=1#doc_chap5,

Quote:
You may also see blocking packages with specific atoms, such as <media-video/mplayer-1.0_rc1-r2. In this case, updating to a more recent version of the blocking package would remove the block.


This is the method I try before removing anything at all. Also note that if the block is colored blue, that means portage can resolve the block itself and you don't have to intervene with it at all. If the package is red, then try to update it first.

For instance, since x11-libs/qt-script-4.8.2:4 is blocking x11-libs/qt-qt3support-4.8.2, x11-libs/qt-core-4.8.2, x11-libs/qt-sql-4.8.2, x11-libs/qt-gui-4.8.2, x11-libs/qt-opengl-4.8.2, x11-libs/qt-dbus-4.8.2) , try "emerge -av x11-libs/qt-script". After that check the update again and you hopefully will see that block has disappeared. Then just go down the list. I had to do this to my newly installed system, it really wasn't that bad.

Now I only assume that the atom I specified was colored red.

Hope that helps!
Back to top
View user's profile Send private message
gerard82
Advocate
Advocate


Joined: 04 Jan 2004
Posts: 2229
Location: Netherlands

PostPosted: Wed Aug 15, 2012 9:23 am    Post subject: Reply with quote

@hyson,
Code:

[blocks B      ] <dev-libs/gobject-introspection-1.32.0 ("<dev-libs/gobject-introspection-1.32.0" is blocking dev-libs/gobject-introspection-common-1.32.1)
[blocks B      ] <sys-libs/talloc-2.0.5 ("<sys-libs/talloc-2.0.5" is blocking sys-libs/talloc-2.0.7)


gobject-introspection is being replaced by gobject-introspection-common.
Simply do emerge -C gobject-introspection talloc and then try again.
Then before you actually install run
Code:

emerge --update --deep --newuse -p > uworld

That will give you a file with all the new/updated packages.
Once the emerge is finished run revdep-rebuild.
Gerard.
_________________
To install Gentoo I use sysrescuecd.Based on Gentoo,has firefox to browse Gentoo docs and mc to browse (and edit) files.
The same disk can be used for 32 and 64 bit installs.
You can follow the Handbook verbatim.
http://www.sysresccd.org/Download
Back to top
View user's profile Send private message
mvaterlaus
Apprentice
Apprentice


Joined: 01 Oct 2010
Posts: 155
Location: Switzerland

PostPosted: Wed Aug 15, 2012 9:53 am    Post subject: Reply with quote

as for the compiz stuff, which is also blocking things, just add the packages to /etc/protage/package.unmask, so portage won't complain about compiz anymore, even if it is masked in /usr/portage/profile/package.mask. do this only, if you want to keep compiz on your desktop.
Back to top
View user's profile Send private message
hyson
n00b
n00b


Joined: 21 Aug 2010
Posts: 23
Location: Shanghai, China

PostPosted: Tue Oct 16, 2012 3:59 am    Post subject: Reply with quote

Thank you all.

Sorry to update late.
I waited for a long time on purpose not to update my system.
I hoped it will be solved by time...(Maybe it's a portage issue.)
But, time approved that it's not the solution:(

I followed the suggestion of gerard82, tried "emerge -C gobject-introspection talloc".

Although there was still something wrong, it seems to be a different issue.
I changed my "package.keyword" to solve this new issue. And, the updating can go on and succeed in the end.

Anyway, everything seems to be good now.
Hated Gentoo more, and Love Gentoo more... :P
_________________
Stay awake!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum