Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst]wine Programme crashen wegen Audiodev
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3009
Location: Berlin

PostPosted: Sat Aug 11, 2012 9:19 am    Post subject: [gelöst]wine Programme crashen wegen Audiodev Reply with quote

Beispiel
Code:
wine Diamantris2.exe
fixme:win:EnumDisplayDevicesW ((null),0,0x39ef1b0,0x00000000), stub!
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
ALSA lib conf.c:3314:(snd_config_hooks_call) Cannot open shared library /usr/lib/alsa-lib/libasound_module_conf_pulse.so
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM default
s2.exe: pcm_null.c:142: snd_pcm_null_drop: Assertion `null->state != SND_PCM_STATE_OPEN' failed.
Unhandled Memory Exception Error


Last edited by flammenflitzer on Tue Aug 14, 2012 6:25 pm; edited 1 time in total
Back to top
View user's profile Send private message
haegar87
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jan 2006
Posts: 134

PostPosted: Sun Aug 12, 2012 10:44 pm    Post subject: Reply with quote

Nabend,

ich behaupte dir fehlt pulseaudio, und du hast alsa/wine mit pulseaudio Support kompiliert.
(siehe hierzu: http://forums.gentoo.org/viewtopic-t-916116-start-0.html)
Anderer Fall, aber selber Fehler...
Quote:
Cannot open shared library /usr/lib/alsa-lib/libasound_module_conf_pulse.so


Grüße,

haegar87
_________________
"Spielt man die Windows CD rückwärts ab, hört man satanistische Texte!" - "Das ist ja noch harmlos! Wenn man sie vorwärts abspielt, installiert sich das Teufelszeug!"
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3009
Location: Berlin

PostPosted: Mon Aug 13, 2012 6:15 pm    Post subject: Reply with quote

pulseaudio läuft.
Code:
ebuild   R    ] media-plugins/alsa-plugins-1.0.25-r1  USE="ffmpeg libsamplerate pulseaudio -debug -jack -speex"

Code:
olaf@flammenflitzer ~ $ ldd $(which alsamixer)
        linux-vdso.so.1 (0x00007fffb31ff000)
        libformw.so.5 => /usr/lib64/libformw.so.5 (0x00007eff85990000)
        libmenuw.so.5 => /usr/lib64/libmenuw.so.5 (0x00007eff85787000)
        libpanelw.so.5 => /usr/lib64/libpanelw.so.5 (0x00007eff85583000)
        libncursesw.so.5 => /lib64/libncursesw.so.5 (0x00007eff85322000)
        libasound.so.2 => /usr/lib64/libasound.so.2 (0x00007eff85042000)
        libm.so.6 => /lib64/libm.so.6 (0x00007eff84d4e000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007eff84b31000)
        libc.so.6 => /lib64/libc.so.6 (0x00007eff8478a000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007eff84586000)
        librt.so.1 => /lib64/librt.so.1 (0x00007eff8437d000)
        /lib64/ld-linux-x86-64.so.2 (0x00007eff85ba1000)
Code:
olaf@flammenflitzer ~ $ ls -l /usr/lib/alsa-lib/libasound_module_conf_pulse.so
-rwxr-xr-x 1 root root 5984 11. Aug 18:57 /usr/lib/alsa-lib/libasound_module_conf_pulse.so
Code:
olaf@flammenflitzer ~ $ grep SND /usr/src/linux/.config | grep -v \#
CONFIG_SND=y
CONFIG_SND_TIMER=m
CONFIG_SND_PCM=m
CONFIG_SND_HWDEP=m
CONFIG_SND_RAWMIDI=m
CONFIG_SND_SEQUENCER=m
CONFIG_SND_SEQ_DUMMY=m
CONFIG_SND_OSSEMUL=y
CONFIG_SND_MIXER_OSS=m
CONFIG_SND_PCM_OSS=m
CONFIG_SND_PCM_OSS_PLUGINS=y
CONFIG_SND_SEQUENCER_OSS=y
CONFIG_SND_DYNAMIC_MINORS=y
CONFIG_SND_VMASTER=y
CONFIG_SND_KCTL_JACK=y
CONFIG_SND_DMA_SGBUF=y
CONFIG_SND_RAWMIDI_SEQ=m
CONFIG_SND_MPU401_UART=m
CONFIG_SND_AC97_CODEC=m
CONFIG_SND_DRIVERS=y
CONFIG_SND_PCSP=m
CONFIG_SND_DUMMY=m
CONFIG_SND_ALOOP=m
CONFIG_SND_VIRMIDI=m
CONFIG_SND_MTPAV=m
CONFIG_SND_MTS64=m
CONFIG_SND_SERIAL_U16550=m
CONFIG_SND_MPU401=m
CONFIG_SND_AC97_POWER_SAVE=y
CONFIG_SND_AC97_POWER_SAVE_DEFAULT=0
CONFIG_SND_PCI=y
CONFIG_SND_HDA_INTEL=m
CONFIG_SND_HDA_PREALLOC_SIZE=64
CONFIG_SND_HDA_HWDEP=y
CONFIG_SND_HDA_RECONFIG=y
CONFIG_SND_HDA_INPUT_BEEP=y
CONFIG_SND_HDA_INPUT_BEEP_MODE=1
CONFIG_SND_HDA_PATCH_LOADER=y
CONFIG_SND_HDA_CODEC_REALTEK=y
CONFIG_SND_HDA_ENABLE_REALTEK_QUIRKS=y
CONFIG_SND_HDA_CODEC_ANALOG=y
CONFIG_SND_HDA_CODEC_SIGMATEL=y
CONFIG_SND_HDA_CODEC_VIA=y
CONFIG_SND_HDA_CODEC_HDMI=y
CONFIG_SND_HDA_CODEC_CIRRUS=y
CONFIG_SND_HDA_CODEC_CONEXANT=y
CONFIG_SND_HDA_CODEC_CA0110=y
CONFIG_SND_HDA_CODEC_CA0132=y
CONFIG_SND_HDA_CODEC_CMEDIA=y
CONFIG_SND_HDA_CODEC_SI3054=y
CONFIG_SND_HDA_GENERIC=y
CONFIG_SND_INTEL8X0=m
CONFIG_SND_INTEL8X0M=m
Code:

olaf@flammenflitzer ~ $ grep SOUND /usr/src/linux/.config | grep -v \#
CONFIG_SOUND=y
CONFIG_SOUND_OSS_CORE=y
CONFIG_SOUND_OSS_CORE_PRECLAIM=y
Code:
olaf@flammenflitzer ~ $ cat /etc/asound.conf
cat: /etc/asound.conf: Datei oder Verzeichnis nicht gefunden
Code:
olaf@flammenflitzer ~ $ cat ~/.asoundrc
cat: /home/olaf/.asoundrc: Datei oder Verzeichnis nicht gefunden
Code:
olaf@flammenflitzer ~ $ lsmod | grep snd
snd_hda_codec_hdmi     22094  4
snd_hda_codec_realtek    54831  1
snd_hda_intel          22881  6
snd_hda_codec          88980  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
snd_pcsp                7637  2
snd_hwdep               5508  1 snd_hda_codec
snd_pcm                63429  5 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_pcsp
snd_timer              17755  1 snd_pcm
snd_page_alloc          6909  2 snd_hda_intel,snd_pcm
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4116

PostPosted: Mon Aug 13, 2012 7:41 pm    Post subject: Reply with quote

32Bit oder 64Bit system?

wine ist eine 32Bit binary.
Vermutlich wird eine 32Bit Fassung von libasound_module_conf_pulse.so benötigt.
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3009
Location: Berlin

PostPosted: Mon Aug 13, 2012 7:51 pm    Post subject: Reply with quote

Habe ich das nicht mit
Code:
[ebuild   R    ] app-emulation/emul-linux-x86-soundlibs-20120520-r2  USE="alsa -development"
Kann das der Bug sein? https://bugs.gentoo.org/show_bug.cgi?id=417289
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4116

PostPosted: Mon Aug 13, 2012 8:05 pm    Post subject: Reply with quote

flammenflitzer wrote:
Habe ich das nicht mit
Code:
[ebuild   R    ] app-emulation/emul-linux-x86-soundlibs-20120520-r2  USE="alsa -development"
Kann das der Bug sein? https://bugs.gentoo.org/show_bug.cgi?id=417289

Ja da ist die 32Bit Fassung enthalten. Scheint der genannte Bug zu sein.
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3009
Location: Berlin

PostPosted: Tue Aug 14, 2012 6:12 pm    Post subject: Reply with quote

Der ist doch schon alt.
Code:
2012-05-23
Das der noch nicht behoben wurde. Muß ich wohl abwarten.
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3009
Location: Berlin

PostPosted: Tue Aug 14, 2012 6:25 pm    Post subject: Reply with quote

http://forums.gentoo.org/viewtopic-p-7059586.html?sid=03e4d4d55ec281aec28142452d2513fe#7059586
funktioniert. Danke.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum