Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg seg-fault [solved]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Treborius
Guru
Guru


Joined: 18 Oct 2005
Posts: 539
Location: Berlin

PostPosted: Sat Aug 11, 2012 12:13 am    Post subject: Xorg seg-fault [solved] Reply with quote

hallo, ich habe hier ein Problem mit X und komme nicht weiter

es geht um einen Geode LX,
X hat mal wunderbar funktioniert, nun bekomme ich es nichtmehr zum laufen

wenn ich versuche X zu starten bekomme ich folgende Fehlermeldung :

Code:

AmdPciProbe: Probing for supported devices!
Unable to open /dev/cpu/0/msr: 2

Backtrace:
0: X (xorg_backtrace+0x50) [0xb78bc920]

Segmentation fault at address (nil)

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting


in der /var/log/Xorg.0.log steht eigentlich nix interessantes drin :

Code:

[  3618.831] (II) GEODE(0): Not using default mode "960x720" (vrefresh out of range)
[  3618.831] (II) GEODE(0): Not using default mode "2048x1536" (height too large for virtual size)
[  3618.831] (II) GEODE(0): Not using default mode "1024x768" (hsync out of range)
[  3618.831] (II) GEODE(0): Not using default mode "2048x1536" (height too large for virtual size)
[  3618.831] (II) GEODE(0): Not using default mode "1024x768" (vrefresh out of range)
[  3618.831] (II) GEODE(0): Not using default mode "2048x1536" (height too large for virtual size)
[  3618.831] (II) GEODE(0): Not using default mode "1024x768" (vrefresh out of range)
[  3618.831] (II) GEODE(0): Printing probed modes for output default
[  3618.831] (II) GEODE(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz d)
[  3618.831] (II) GEODE(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz d)
[  3618.831] (II) GEODE(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz d)
[  3618.831] (II) GEODE(0): Modeline "512x384"x60.0   32.50  512 524 592 672  384 385 388 403 doublescan -hsync -vsync (48.4 kHz d)
[  3618.831] (II) GEODE(0): Modeline "400x300"x60.3   20.00  400 420 484 528  300 300 302 314 doublescan +hsync +vsync (37.9 kHz d)
[  3618.832] (II) GEODE(0): Modeline "320x240"x60.1   12.59  320 328 376 400  240 245 246 262 doublescan -hsync -vsync (31.5 kHz d)
[  3618.832] (II) GEODE(0): Output default connected
[  3618.832] (II) GEODE(0): Using fuzzy aspect match for initial modes
[  3618.832] (II) GEODE(0): Output default using initial mode 1024x768
[  3618.832] (II) GEODE(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[  3618.832] (--) GEODE(0): Virtual size is 1024x1024 (pitch 0)
[  3618.832] (**) GEODE(0):  Default mode "1024x768": 65.0 MHz (scaled from 0.0 MHz), 48.4 kHz, 60.0 Hz
[  3618.832] (II) GEODE(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz d)
[  3618.832] (**) GEODE(0):  Default mode "800x600": 40.0 MHz (scaled from 0.0 MHz), 37.9 kHz, 60.3 Hz
[  3618.832] (II) GEODE(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz d)
[  3618.832] (**) GEODE(0):  Default mode "640x480": 25.2 MHz (scaled from 0.0 MHz), 31.5 kHz, 59.9 Hz
[  3618.833] (II) GEODE(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz d)
[  3618.833] (**) GEODE(0):  Default mode "512x384": 32.5 MHz (scaled from 0.0 MHz), 48.4 kHz, 60.0 Hz (D)
[  3618.833] (II) GEODE(0): Modeline "512x384"x60.0   32.50  512 524 592 672  384 385 388 403 doublescan -hsync -vsync (48.4 kHz d)
[  3618.833] (**) GEODE(0):  Default mode "400x300": 20.0 MHz (scaled from 0.0 MHz), 37.9 kHz, 60.3 Hz (D)
[  3618.833] (II) GEODE(0): Modeline "400x300"x60.3   20.00  400 420 484 528  300 300 302 314 doublescan +hsync +vsync (37.9 kHz d)
[  3618.833] (**) GEODE(0):  Default mode "320x240": 12.6 MHz (scaled from 0.0 MHz), 31.5 kHz, 60.1 Hz (D)
[  3618.833] (II) GEODE(0): Modeline "320x240"x60.1   12.59  320 328 376 400  240 245 246 262 doublescan -hsync -vsync (31.5 kHz d)
[  3618.833] (==) GEODE(0): DPI set to (96, 96)
[  3618.833] (II) Loading sub module "fb"
[  3618.833] (II) LoadModule: "fb"
[  3618.834] (II) Loading /usr/lib/xorg/modules/libfb.so
[  3618.836] (II) Module fb: vendor="X.Org Foundation"
[  3618.836]    compiled for 1.12.2, module version = 1.0.0
[  3618.836]    ABI class: X.Org ANSI C Emulation, version 0.4
[  3618.836] (II) Loading sub module "exa"
[  3618.836] (II) LoadModule: "exa"
[  3618.837] (II) Loading /usr/lib/xorg/modules/libexa.so
[  3618.838] (II) Module exa: vendor="X.Org Foundation"
[  3618.838]    compiled for 1.12.2, module version = 2.5.0
[  3618.838]    ABI class: X.Org Video Driver, version 12.0
[  3618.838] (II) UnloadModule: "vesa"
[  3618.838] (II) Unloading vesa
[  3618.838] (II) UnloadModule: "fbdev"
[  3618.838] (II) Unloading fbdev
[  3618.838] (II) UnloadSubModule: "fbdevhw"
[  3618.838] (II) Unloading fbdevhw
[  3618.839]
[  3618.839] Backtrace:
[  3618.840] 0: X (xorg_backtrace+0x50) [0xb78bc920]
[  3618.840]
[  3618.841] Segmentation fault at address (nil)
[  3618.841]
Fatal server error:
[  3618.841] Caught signal 11 (Segmentation fault). Server aborting
[  3618.842]
[  3618.842]
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[  3618.842] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  3618.843]
[  3618.844] Server terminated with error (1). Closing log file.


Das sagt mir erstmal nur, das bis zum Segmentation fault alles wunderbar läuft,
ein strace auf die ganze Sache lieferte mir dann das

Code:

open("/sys/class/pci_bus/0000:00/legacy_mem", O_RDWR|O_CLOEXEC) = -1 ENOENT (No such file or directory)
open("/dev/mem", O_RDWR|O_CLOEXEC)      = 7
mmap2(NULL, 65536, PROT_READ|PROT_WRITE, MAP_SHARED, 7, 0xa0) = 0xb7009000
close(7)                                = 0
--- SIGSEGV {si_signo=SIGSEGV, si_code=SEGV_MAPERR, si_addr=0} ---


ich tippe ja darauf, das die datei "/sys/class/pci_bus/0000:00/legacy_mem" existieren sollte
(tut sie nämlich nicht) und ich irgendwas im kernel vergessen hab

jemand ne ahnung wie ich weiter vorgehen sollte? google hat mir irgendwie nix gebracht ...

Code:

Portage 2.1.10.65 (hardened/linux/x86, gcc-4.5.3, glibc-2.14.1-r3, 3.0.6-gentoo-alix i586)
=================================================================
System uname: Linux-3.0.6-gentoo-alix-i586-Geode-TM-_Integrated_Processor_by_AMD_PCS-with-gentoo-2.1
Timestamp of tree: Tue, 07 Aug 2012 22:00:01 +0000
ccache version 3.1.7 [enabled]
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.1.4-r3, 3.2.3
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.6
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i486-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
CHOST="i486-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-
release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-
rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
DISTDIR="/var/distfiles"
FCFLAGS="-march=i686 -O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-f
etch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans user
fetch"
FFLAGS="-march=i686 -O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --
human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
...


Vielleicht ist es ja ein total dummer denkfehler meinerseits :roll:

Danke im Vorraus

Treb
_________________
System : Intel Core2 Quad Q6600


Last edited by Treborius on Mon Aug 13, 2012 6:03 am; edited 1 time in total
Back to top
View user's profile Send private message
Treborius
Guru
Guru


Joined: 18 Oct 2005
Posts: 539
Location: Berlin

PostPosted: Mon Aug 13, 2012 6:03 am    Post subject: Reply with quote

bin erstmal auf vesa umgestiegen
_________________
System : Intel Core2 Quad Q6600
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum