Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can not auto start vmware daemon
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
buptwugh
Tux's lil' helper
Tux's lil' helper


Joined: 16 Jan 2012
Posts: 94
Location: Beijing,China

PostPosted: Fri Aug 03, 2012 12:59 pm    Post subject: Can not auto start vmware daemon Reply with quote

I add the vmware service to the default level
Code:

NextZone ~ # rc-update show
            alsasound |      default                 
             bootmisc | boot                         
           consolekit |      default                 
                 dbus |      default                 
                devfs |                       sysinit
                dmesg |                       sysinit
                 fsck | boot                         
           git-daemon |      default                 
             hostname | boot                         
              hwclock | boot                         
              keymaps | boot                         
            killprocs |              shutdown       
                local |      default                 
           localmount | boot                         
              modules | boot                         
             mount-ro |              shutdown       
                 mtab | boot                         
                mysql |      default                 
               net.lo | boot                         
             netmount |      default                 
               procfs | boot                         
                 root | boot                         
            savecache |              shutdown       
                 sshd |      default                 
                 swap | boot                         
               sysctl | boot                         
            syslog-ng |      default                 
         termencoding | boot                         
                 udev |                       sysinit
       udev-postmount |      default                 
              urandom | boot                         
           vixie-cron |      default                 
               vmware |      default                 
 vmware-USBArbitrator |      default                 
                 wicd |      default                 
                  xdm |      default               


But when I boot the system, the vmware daemons can not start.
Code:

NextZone ~ # ls -l /etc/init.d/vmware*
-rwxr-xr-x 1 root root 13077 Jul 13 23:18 /etc/init.d/vmware
-rwxr-xr-x 1 root root  2653 Jul 14 10:48 /etc/init.d/vmware-USBArbitrator



this two daemon can not start, I have to Manually start these.
Code:

NextZone ~ # /etc/init.d/vmware start
Starting VMware services:
   Virtual machine monitor                                             done
   Virtual machine communication interface                             done
   VM communication interface socket family                            done
   Blocking file system                                                done
   Virtual ethernet                                                    done
   VMware Authentication Daemon                                        done
   Shared Memory Available                                             done
NextZone ~ # /etc/init.d/vmware-USBArbitrator start



Then I can use vmware.
I do not know how to solved it.
Thank you.
Back to top
View user's profile Send private message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2396

PostPosted: Fri Aug 03, 2012 5:12 pm    Post subject: Reply with quote

buptwugh,

do you see a try to start the daemon(s) during system boot?
what does rc-status say before you manually start the daemon(s)?
Back to top
View user's profile Send private message
buptwugh
Tux's lil' helper
Tux's lil' helper


Joined: 16 Jan 2012
Posts: 94
Location: Beijing,China

PostPosted: Sat Aug 04, 2012 12:47 am    Post subject: Reply with quote

I boot the system the status is
Code:

NextZone ~ # /etc/init.d/vmware status
Module vmmon not loaded
Module vmnet not loaded
NextZone ~ # /etc/init.d/vmware-USBArbitrator status
Usage: vmware-USBArbitrator {start|stop|restart}


Then I add these two modules to /etc/conf.d/modules
Code:

NextZone ~ # cat /etc/conf.d/modules
# You can define a list modules for a specific kernel version,
# a released kernel version, a main kernel version or just a list.
# The most specific versioned variable will take precedence.
#modules_2_6_23_gentoo_r5="ieee1394 ohci1394"
#modules_2_6_23="tun ieee1394"
#modules_2_6="tun"
#modules_2="ipv6"
#modules="ohci1394"

# You can give modules a different name when they load - the new name
# will also be used to pick arguments below.
#modules="dummy:dummy1"

# Give the modules some arguments if needed, per version if necessary.
# Again, the most specific versioned variable will take precedence.
#module_ieee1394_args="debug"
#module_ieee1394_args_2_6_23_gentoo_r5="debug2"
#module_ieee1394_args_2_6_23="debug3"
#module_ieee1394_args_2_6="debug4"
#module_ieee1394_args_2="debug5"

# You should consult your kernel documentation and configuration
# for a list of modules and their options.
modules="${modules} vboxdrv"
modules="${modules} vmmon vmnet"



Then I get the these status
Code:

NextZone ~ # /etc/init.d/vmware status
Module vmmon loaded
Module vmnet loaded



And I can not use vmware .

Even I add these service to boot level , the vmware does not work.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum