Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE-Geräteüberwachung sieht keine USB/CDROM Devices [solved]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1003
Location: /dev/koelsch

PostPosted: Tue Jun 12, 2012 7:22 am    Post subject: KDE-Geräteüberwachung sieht keine USB/CDROM Devices [solved] Reply with quote

Hi Leute.

Beim anstöpseln von USB-Sticks kommt der KDE-Automounter nicht mehr hoch und sieht keine devices mehr, außer Cameras, die kann er noch einbinden.
CDROMs/DVDs gehen auch nicht mehr., /dev/sr0 wird aber erzeugt.

Händisch kann ich alles mounten, kein Thema.

Irgendeins der Updates der letzten Tage hat mir diese Funktion gebrochen, jedoch nur auf meinem ~amd64 arch.
Auf'm ~x86 geht's noch trotz gleicher Aktualität.

Heute kam openrc-0.10.3, der fehler war aber auch schon davor.
Hab auch schon verschiedene udisks versionen getestet, ohne Erfolg.
Was mich hier auf'm System wundert warum er das slottet, scheint mir aber bisher so funktioniert zu haben.

Code:

sys-fs/udisks
     Available versions: 
        (0)     1.0.4-r1^t (~)1.0.4-r2
        (2)     (~)1.97.0-r1 [M](~)1.98.0
        {{crypt debug doc +gptfdisk +introspection nls remote-access systemd}}
     Installed versions:  1.0.4-r2(01:20:35 12.06.2012)(nls -debug -remote-access) 1.97.0-r1(2)(01:00:07 12.06.2012)(crypt gptfdisk introspection -debug -doc -systemd)
     Homepage:            http://www.freedesktop.org/wiki/Software/udisks
     Description:         Daemon providing interfaces to work with storage devices


Hab auch schon mit 'ner älteren kernelversion probiert die bisher definitiv funktioniert hat (3.3.5)
Das Dateisystem der USB devices scheint auch keine rolle zu spielen (fat, ntfs, ext2,3,4) getestet.
Siehe auch

Code:
 /etc/filesystems
#
# This file defines the filesystems search order used by a                                                                           
# 'mount -t auto' command.                                                                                                           
#                                                                                                                                   
                                                                                                                                     
# Uncomment the following line if your modular kernel has vfat                                                                       
# support and you want mount to try vfat.                                                                                           
#vfat                                                                                                                               
                                                                                                                                     
# Keep the last '*' intact as it directs mount to use the                                                                           
# filesystems list available at /proc/filesystems also.                                                                             
# Don't remove it unless you REALLY know what you are doing!                                                                         
*                                                                                                                                   
Für temporären Problemfall selbst hinzugefügt.                                                                                       
ntfs-3g


kdelibs hab ich auch noch mal neu gebaut, nach änderungen von udisks.

Hatte da was zu nem bug von udisks mit systemd und dem /run Verz. gefunden, unter dem nun media eingehangen werden sollte, aber da ich noch auf openrc setzte sollte das doch nichts damit zu tun haben.
Meine bisherige Recherche ergab also nichts Zielführendes, wisst ihr da mehr, hat das sonst noch Jemand?

Gruß, Andy.
_________________
If you want to see a Distro done right, compile it yourself!


Last edited by Randy Andy on Tue Jun 12, 2012 4:57 pm; edited 1 time in total
Back to top
View user's profile Send private message
Christian99
l33t
l33t


Joined: 28 May 2009
Posts: 899

PostPosted: Tue Jun 12, 2012 7:29 am    Post subject: Reply with quote

was verlangt denn bei dir udisks-1.9x? bei mir verlangen alle pakete kdelibs etc explizit udev:0, also die 1.0.x versionen...
Back to top
View user's profile Send private message
Max Steel
Veteran
Veteran


Joined: 12 Feb 2007
Posts: 1951
Location: My own world! I and Gentoo!

PostPosted: Tue Jun 12, 2012 7:32 am    Post subject: Reply with quote

Hast du zwischendurch die CDROM-Devices und evtl auch noch ein paar "USB-Devices" in die fstab eingetragen?
_________________
mfg
Steel
___________________
Big sorry for my bad English.

Heim-PC: AMD Phenom II X4 3,2GHz, 16GB RAM, gentoo-sources-3.10.7, NV GTX 780
Laptop: Intel Celeron 1,7GHz, 512MB Ram, tuxonice-sources-3.7.1, SIS Graphic

Version 0.4
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1003
Location: /dev/koelsch

PostPosted: Tue Jun 12, 2012 12:23 pm    Post subject: Reply with quote

Christian99 wrote:
was verlangt denn bei dir udisks-1.9x? bei mir verlangen alle pakete kdelibs etc explizit udev:0, also die 1.0.x versionen...


In die Richtung hatte ich Gestern ja auch mal gedacht.

Deshalb hatte ich udisks udisks-1.97.0-r1 unmerged, udisks-1.0.4-r2 neu gebaut und später auch mal kdelibs neu gebaut, alles getestet - ohne Erfolg.
Beim mergen von udisks fiel mir einn Hinweis auf, dass USB_SUSPEND im kernel aktiviert sein soll, was bei mir nicht der Fall war, aber bisher trotzdem alles immer funktionierte.
Egal, hab's dann noch mit rein genommen, geht aber trotzdem nicht.

udisks-1.97.0-r1 hängt bei mir von
Code:

gnome-base/gvfs-1.12.3 (udisks ? >=sys-fs/udisks-1.90:2)

ab und das wiederum von:

Code:
equery d gvfs
 * These packages depend on gvfs:
gnome-base/libgnome-2.32.1-r1 (gnome-base/gvfs)
media-gfx/gimp-2.8.0-r1 (gnome ? gnome-base/gvfs)
media-video/ogmrip-0.13.7 (gnome-base/gvfs)


Und das obwohl gimp bei mir ohne das gnome use-flag gebaut ist.
Jedenfalls bewirken diese Abhängigkeiten dass bei einem world update sys-fs/udisks-1.97.0-r1 geslottet zusätzlich installiert wird.
Hat aber alles früher auch damit funktioniert - fürchte das zielt nicht in die richtige Richtung...

Max Steel wrote:
Hast du zwischendurch die CDROM-Devices und evtl auch noch ein paar "USB-Devices" in die fstab eingetragen?


Nö, guckst du hier:
Code:
big-server andy # cat /etc/fstab
LABEL=OS1                        /                        ext4    defaults                1 1
LABEL=OS2                        /OS2                     ext4    defaults                1 2
LABEL=OS3                        /OS3                     ext4    defaults                1 2
LABEL=home                       /home                    ext4    defaults                1 2
LABEL=Archiv                     /Archiv                  ext4    defaults                1 2
LABEL=Mirror_OS1                 /Mirror_OS1              ext4    defaults                1 2
LABEL=Mirror_OS2                 /Mirror_OS2              ext4    defaults                1 2
LABEL=Mirror_OS3                 /Mirror_OS3              ext4    defaults                1 2
LABEL=Mirror_home                /Mirror_home             ext4    defaults                1 2
LABEL=Tresor                     /Tresor                  ext4    defaults                1 2
#LABEL=Tmp                       /tmp                     ext2    defaults                1 0
LABEL=swap                       swap                     swap    defaults                0 0
none                             /proc                    proc    defaults                0 0
none                             /dev/shm                 tmpfs   defaults                0 0

#vdr1:/mnt/video /home/andy/share/VDR                   nfs      intr,rw,user,noauto    0 0
#vdr1:/audio /home/andy/share/VDR/audio                 nfs      intr,rw,user,noauto    0 0
#vdr1:/pictures /home/andy/share/VDR/pictures           nfs      intr,rw,user,noauto    0 0
#vdr1:/film /home/andy/share/VDR/film                   nfs      intr,rw,user,noauto    0 0

#mobile:/home /home/andy/share/mobile                   nfs      intr,rw,user,noauto    0 0

#little-server:/OS2 /home/andy/share/VDR                                nfs      intr,rw,user,noauto    0 0
#mobile:/mnt/OS2 /home/andy/share/mobile                                nfs      intr,rw,user,noauto    0 0



Code:
big-server andy # rc-status
Runlevel: default
 syslog-ng                                                                                                              [  started  ]
 dhcpcd                                                                                                                 [  started  ]
 dbus                                                                                                                   [  started  ]
 net.eth0                                                                                                               [  started  ]
 ntpd                                                                                                                   [  started  ]
 gpm                                                                                                                    [  started  ]
 avahi-daemon                                                                                                           [  started  ]
 cupsd                                                                                                                  [  started  ]
 nfs                                                                                                                    [  started  ]
 netmount                                                                                                               [  started  ]
 acpid                                                                                                                  [  started  ]
 xdm                                                                                                                    [  started  ]
 distccd                                                                                                                [  started  ]
 mysql                                                                                                                  [  started  ]
 sshd                                                                                                                   [  started  ]
 udev-postmount                                                                                                         [  started  ]
 vixie-cron                                                                                                             [  started  ]
 local                                                                                                                  [  started  ]
Dynamic Runlevel: hotplugged
Dynamic Runlevel: needed
 rpc.pipefs                                                                                                             [  started  ]
 sysfs                                                                                                                  [  started  ]
 udev-mount                                                                                                             [  started  ]
 xdm-setup                                                                                                              [  started  ]
 rpcbind                                                                                                                [  started  ]
 rpc.idmapd                                                                                                             [  started  ]
Dynamic Runlevel: manual


Hab wohl letztens ein wenig mit nfsv4 experimentiert aber ich seh da gerade nicht den Zusammenhang.
Daher steh ich gerade mächtig auf'm Schlauch.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2186
Location: Germany

PostPosted: Tue Jun 12, 2012 1:24 pm    Post subject: Reply with quote

Hm, nur ein blinder Schuss ins Blaue:
War für die Device-Notifier und "Auto"-mount Geschichte nicht consolekit mit nötig - sprich eine aktive Session nötig?
Laut dem rc-status scheint consolekit nicht im default Runlevel gestartet zu sein.
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1003
Location: /dev/koelsch

PostPosted: Tue Jun 12, 2012 2:59 pm    Post subject: Reply with quote

Hi Josef,

keine Ahnung ob das noch erforderlich ist, hab consolekit aber mal mit hinein genommen und hat leider nichts gebracht:
Code:

big-server andy # rc-status
Runlevel: default
 syslog-ng                                                                                                              [  started  ]
 dhcpcd                                                                                                                 [  started  ]
 dbus                                                                                                                   [  started  ]
 net.eth0                                                                                                               [  started  ]
 ntpd                                                                                                                   [  started  ]
 gpm                                                                                                                    [  started  ]
 avahi-daemon                                                                                                           [  started  ]
 cupsd                                                                                                                  [  started  ]
 nfs                                                                                                                    [  started  ]
 netmount                                                                                                               [  started  ]
 consolekit                                                                                                             [  started  ]
 acpid                                                                                                                  [  started  ]
 xdm                                                                                                                    [  started  ]
 distccd                                                                                                                [  started  ]
 mysql                                                                                                                  [  started  ]
 sshd                                                                                                                   [  started  ]
 udev-postmount                                                                                                         [  started  ]
 vixie-cron                                                                                                             [  started  ]
 local                                                                                                                  [  started  ]
Dynamic Runlevel: hotplugged
Dynamic Runlevel: needed
 rpc.pipefs                                                                                                             [  started  ]
 sysfs                                                                                                                  [  started  ]
 udev-mount                                                                                                             [  started  ]
 xdm-setup                                                                                                              [  started  ]
 rpcbind                                                                                                                [  started  ]
 rpc.idmapd                                                                                                             [  started  ]
Dynamic Runlevel: manual 


Sehe gerade noch einige Fehler in der Ausgabe von dmesg, vielleicht seht ihr da eine Zusammenhang:
Code:

7.073266] snd_hda_intel 0000:00:1b.0: irq 48 for MSI/MSI-X
[    7.431938] WARNING! power/level is deprecated; use power/control instead
# hier wohl eher nicht, bezieht sich doch auf den soundchip
....

[   19.395878] e1000e 0000:00:19.0: eth0: 10/100 speed: disabling TSO
[   53.737577] upowerd[2930] trap int3 ip:7f3c734cc595 sp:7fff1ff50830 error:0
[   53.759474] upowerd[2938] trap int3 ip:7fca410e3595 sp:7fff02970a50 error:0
[   53.775836] upowerd[2945] trap int3 ip:7f5b9e0b3595 sp:7fff11ce19a0 error:0
[   53.795355] upowerd[2951] trap int3 ip:7f9aecce2595 sp:7fff51227d60 error:0
[   53.998279] upowerd[2961] trap int3 ip:7fddcc066595 sp:7fff4a1adcd0 error:0
[   54.017574] upowerd[2967] trap int3 ip:7f3501d3b595 sp:7ffffbb6b770 error:0
[   55.990296] upowerd[3005] trap int3 ip:7f6cb8979595 sp:7fff035bd8f0 error:0
[   56.009385] upowerd[3011] trap int3 ip:7f7c1d84a595 sp:7fffb7f5cfb0 error:0
[   56.055582] upowerd[3017] trap int3 ip:7f91c6c95595 sp:7fff31bd9810 error:0
[   57.477485] upowerd[3029] trap int3 ip:7fcc10236595 sp:7fff49f16fc0 error:0
[   60.596302] do_trap: 1 callbacks suppressed
[   60.596307] upowerd[3081] trap int3 ip:7f51de870595 sp:7fff04245df0 error:0
[   60.615821] upowerd[3087] trap int3 ip:7fef8442f595 sp:7fff744c5570 error:0
[   60.655401] upowerd[3103] trap int3 ip:7f269590f595 sp:7fff8dd51110 error:0
[   64.024259] upowerd[3216] trap int3 ip:7f8dc9fe1595 sp:7fff3cd55e70 error:0
[   64.041913] upowerd[3222] trap int3 ip:7f01d5c75595 sp:7fffdd9d8690 error:0
[   66.236035] upowerd[3279] trap int3 ip:7f21aa78f595 sp:7fff1f491700 error:0
[   66.253748] upowerd[3285] trap int3 ip:7fa2430a7595 sp:7fffcad54660 error:0
[   67.787125] upowerd[3338] trap int3 ip:7f8639d7b595 sp:7fff522cc630 error:0
[   68.919721] upowerd[3361] trap int3 ip:7fbbbb8be595 sp:7fffdef5afa0 error:0
[   68.935176] upowerd[3367] trap int3 ip:7fd1a80aa595 sp:7fff2526df00 error:0
[   74.145665] upowerd[3404] trap int3 ip:7f70d1246595 sp:7fff952d05f0 error:0
[   74.161725] upowerd[3410] trap int3 ip:7f57c99a9595 sp:7fff02c1af30 error:0
[   98.100179] upowerd[3552] trap int3 ip:7f272dfd9595 sp:7fff5750d9b0 error:0
[   98.121489] upowerd[3559] trap int3 ip:7f017ac75595 sp:7fff6de3ad30 error:0
[  103.623889] upowerd[3691] trap int3 ip:7f1e45683595 sp:7fff66b24730 error:0
[  103.645637] upowerd[3697] trap int3 ip:7fcccc65c595 sp:7fff89bb7520 error:0
[  110.090891] upowerd[3743] trap int3 ip:7ff47800f595 sp:7fff26fb4b00 error:0
[  110.110534] upowerd[3749] trap int3 ip:7f98b4f58595 sp:7fffa69b3960 error:0
[  118.188044] usb 1-3: new high-speed USB device number 2 using ehci_hcd
[  118.305137] usb 1-3: New USB device found, idVendor=090c, idProduct=1000
[  118.305142] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  118.305146] usb 1-3: Product: Flash Disk
[  118.305149] usb 1-3: Manufacturer: USB
[  118.305151] usb 1-3: SerialNumber: FBA0909100030857
[  118.305519] scsi7 : usb-storage 1-3:1.0
[  120.174572] scsi 7:0:0:0: Direct-Access     USB      Flash Disk       1100 PQ: 0 ANSI: 0 CCS
[  120.175519] sd 7:0:0:0: Attached scsi generic sg10 type 0
[  120.178529] sd 7:0:0:0: [sdj] 7831552 512-byte logical blocks: (4.00 GB/3.73 GiB)
[  120.179305] sd 7:0:0:0: [sdj] Write Protect is off
[  120.179311] sd 7:0:0:0: [sdj] Mode Sense: 43 00 00 00
[  120.180057] sd 7:0:0:0: [sdj] No Caching mode page present
[  120.180061] sd 7:0:0:0: [sdj] Assuming drive cache: write through
[  120.182304] sd 7:0:0:0: [sdj] No Caching mode page presen
[  120.182308] sd 7:0:0:0: [sdj] Assuming drive cache: write through
[  120.183319]  sdj: sdj1
[  120.185301] sd 7:0:0:0: [sdj] No Caching mode page present
[  120.185305] sd 7:0:0:0: [sdj] Assuming drive cache: write through
[  120.185309] sd 7:0:0:0: [sdj] Attached SCSI disk


Bitte um weitere Ideen...
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1003
Location: /dev/koelsch

PostPosted: Tue Jun 12, 2012 4:56 pm    Post subject: Reply with quote

Hallo Leute,

hab's gelöst. Es lag an der (zwischenzeiltlich?) maskierten Version von polkit- {M}(~)0.106, die bei mir installiert war.
Ein downgrade auf sys-auth/polkit-0.105 brachte dann die Abhilfe.

Seltsam das ganze, denn nach einem Blick in die /etc/portage/package.unmask sah ich das:

#required by sys-fs/udisks-1.98.0, required by @selected, required by @world (argument)
# /usr/portage/profiles/package.mask:
# Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org> (09 Jun 2012)
# Doesn't work, bug #420269. Bad dependencies, bugs #420173, #420307.
=sys-auth/polkit-0.106

Hab seit einiger Zeit diese Feature --autounmask-write aktiviert und dabei übersieht man sowas doch schneller, als wenn man es bewusst von Hand demaskiert.
Oder ich wusste die Zeichen nicht so recht zu deuten, denn das changelog von udisks fand ich jetzt nicht sehr aufschlussreich, da es nichts zur maskierten version
[M](~)1.98.0 erwähnt:

Code:
equery c udisks
*udisks-1.97.0-r1 (15 May 2012)

  15 May 2012; Samuli Suominen <ssuominen@gentoo.org> +udisks-1.97.0-r1.ebuild:
  Revision bump for last change to ensure /run is in place. Warn the user if
  /run is not mounted with tmpfs wrt #415987

  15 May 2012; Samuli Suominen <ssuominen@gentoo.org> udisks-1.97.0.ebuild:
  Keyword ~ppc/~ppc64 wrt #412801

  15 May 2012; Samuli Suominen <ssuominen@gentoo.org> -udisks-1.94.0.ebuild,
  -udisks-1.96.0.ebuild:
  old

  15 May 2012; Samuli Suominen <ssuominen@gentoo.org> udisks-1.97.0.ebuild:
  Remove keepdir for /media and create /run if it's missing for
  /run/media/$user support wrt #415987

  13 May 2012; Samuli Suominen <ssuominen@gentoo.org> udisks-1.94.0.ebuild,
  udisks-1.96.0.ebuild, udisks-1.97.0.ebuild:
  Force at least >=sys-kernel/linux-headers-3.1 for linux/loop.h to gain
  #define LOOP_CTL_GET_FREE wrt #415715 by Thomas Sachau


Na ja, mal wieder um 'ne Erfahrung reicher geworden, gell.

Gruß, Andy.

P.S. @Josef. Das consolekit hab ich wieder aus'm runlevel rausgenommen, da ich bisher noch keine Nachteile entdecken konnnte und meine mich dumpf zu erinnern dass es dort obsolet geworden wäre, durch eine Änderung von polkit oder so...
Dachte ich hätt's mir notiert, finde aber leider die Begründung nicht mehr und in den logfiles konnte ich's auch nicht finden -verdammt.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2186
Location: Germany

PostPosted: Sat Aug 04, 2012 12:54 pm    Post subject: Reply with quote

Randy Andy wrote:
P.S. @Josef. Das consolekit hab ich wieder aus'm runlevel rausgenommen, da ich bisher noch keine Nachteile entdecken konnnte und meine mich dumpf zu erinnern dass es dort obsolet geworden wäre, durch eine Änderung von polkit oder so...
Dachte ich hätt's mir notiert, finde aber leider die Begründung nicht mehr und in den logfiles konnte ich's auch nicht finden -verdammt.

Hm, mag ja sein das consolekit inzwischen gar automatisch gestartet wird, sofern vorhanden und benötigt. Aber warum nicht mit im default- Runlevel aufnehmen wenn man den Service braucht?
Wird laut aktuellen Gentoo KDE Guide auch immer noch "empfohlen" siehe unter
Code Listing 7.6: checking and starting services
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1003
Location: /dev/koelsch

PostPosted: Mon Aug 06, 2012 6:57 am    Post subject: Reply with quote

Josef.95 wrote:
Hm, mag ja sein das consolekit inzwischen gar automatisch gestartet wird, sofern vorhanden und benötigt.


Vermutlich der Grund warum es bei mir auch so zu funktionieren scheint.


Josef.95 wrote:

Aber warum nicht mit im default- Runlevel aufnehmen wenn man den Service braucht?
Wird laut aktuellen Gentoo KDE Guide auch immer noch "empfohlen" siehe unter
Code Listing 7.6: checking and starting services


Hast ja recht, dagegen spricht eigntlich auch nichts.

Vielen Dank auch für den Link, unter dem man alles Wesentliche nochmal schön zusammengefasst nachlesen kann.

Gruß, Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum