Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(SOLVED)Brak możliwości połączenia wifi w laptop eeepc1001HA
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt
View previous topic :: View next topic  
Author Message
maxim.251
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jul 2012
Posts: 86

PostPosted: Sat Jul 14, 2012 2:47 pm    Post subject: (SOLVED)Brak możliwości połączenia wifi w laptop eeepc1001HA Reply with quote

Przekompilowałem jądro i dodałem sterownik do karty WIFI. Teraz mi system go widzi, ale wciąż mam błędy związane z Wicd. Próbuję go instalować na różne sposoby lecz wiciąż mi wyskakuje ten sam problem.

Code:
>>> Failed to emerge net-misc/wicd-1.7.2.1, Log file:

>>>  '/var/tmp/portage/net-misc/wicd-1.7.2.1/temp/build.log'

 * Messages for package net-misc/wicd-1.7.2.1:

 * ERROR: net-misc/wicd-1.7.2.1 failed (install phase):
 *   Installation failed with CPython 2.7 in distutils_installation() function
 *
 * Call stack:
 *     ebuild.sh, line   85:  Called src_install
 *   environment, line 5053:  Called distutils_src_install
 *   environment, line 1225:  Called python_execute_function '-s' 'distutils_installation'
 *   environment, line 3420:  Called die
 * The specific snippet of code:
 *                       die "${failure_message}";
 *
 * If you need support, post the output of `emerge --info '=net-misc/wicd-1.7.2.1'`,
 * the complete build log and the output of `emerge -pqv '=net-misc/wicd-1.7.2.1'`.
 * The complete build log is located at '/var/tmp/portage/net-misc/wicd-1.7.2.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-misc/wicd-1.7.2.1/temp/environment'.
 * Working directory: '/var/tmp/portage/net-misc/wicd-1.7.2.1/work/wicd-1.7.2.1-2.7'
 * S: '/var/tmp/portage/net-misc/wicd-1.7.2.1/work/wicd-1.7.2.1'


Może jest jakieś wyjście by zainstalować ten program? I co mogę robić źle że on nie chce mi się zainstalować.
Wspomnę że na razie korzystam ze środowiska chroot.


Last edited by maxim.251 on Sat Sep 22, 2012 6:22 am; edited 7 times in total
Back to top
View user's profile Send private message
maxim.251
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jul 2012
Posts: 86

PostPosted: Sat Jul 14, 2012 2:50 pm    Post subject: Reply with quote

Udało mi się zainstalować wicd. HURA!
Chociaż nie mam pojęcia co pogrzebałem w plikach konfiguracyjnych. :?
No i dupa, nie wiem jak go skonfigurować żeby sam się łączył z siecią. Nie mogę znaleźć żadnego tekstowego konfiguratora, a według zapisków na stronie programu powinien tam jakiś być.

Bo z Xorgiem też mam problem i nie mogę go odpalić, bo gdy by mi poszło to wtedy miałem szansę na konfigurację z poziomu xorga. :?


Last edited by maxim.251 on Wed Jul 25, 2012 2:09 pm; edited 3 times in total
Back to top
View user's profile Send private message
maxim.251
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jul 2012
Posts: 86

PostPosted: Sat Jul 14, 2012 4:23 pm    Post subject: Reply with quote

..

Last edited by maxim.251 on Mon Jul 16, 2012 2:08 pm; edited 1 time in total
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7938
Location: Somewhere over Atlanta, Georgia

PostPosted: Sat Jul 14, 2012 5:04 pm    Post subject: Reply with quote

Moved from Networking & Security to Instalacja i sprzęt.

- John
_________________
I can confirm that I have received between 0 and 999 National Security Letters.
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2837

PostPosted: Sat Jul 14, 2012 5:31 pm    Post subject: Reply with quote

Przestan spamowac, nie pisz posta pod swoim postem, uzyj funkcji edycja, przeredaguj te posty bo nie sadze, by ktos w ogole zrozumial w czym problem masz. Juz w ogole pomijam to, ze piszesz w anglojezycznych dzialach posty po polsku...
_________________
BitBucket -- better-initramfs
Back to top
View user's profile Send private message
maxim.251
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jul 2012
Posts: 86

PostPosted: Sat Jul 28, 2012 1:00 pm    Post subject: Reply with quote

Nie wiem co nagrzebałem w konfiguracjach, ale zadziałało. Wicd się zainstalował. Wydaje mi się, ale pewności nie mam że dodałem konto roota , strefe czasową lub coś innego. Tak czy siak zadziałało.
Następnie wszedłem na płytę (Pendrive) gdzie miałem LIVEDVD i z tamtąd skopiowałem gotowy plik konfiguracyjny połączenia WiFi.
W którym to znajdowało się hasło wpa2.
Po przeniesieniu pliku na mój nowy system i po restarcie, nawet się nie obejżałem jak internet zaczoł mi śmigać.

Chciał bym jeszcze pozostawić ten temat na chwilę, może wyjaśni mi ktoś co potrzebowałem ustawić by Wicd się zainstalował bez wyświetlania tych errorów?
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2837

PostPosted: Sat Jul 28, 2012 1:16 pm    Post subject: Reply with quote

Przeciez Ty nawet nie pokazales tych errorow, jedynie fragment loga ebuilda, w ktorym napisane jest, ze nie przeszlo.
_________________
BitBucket -- better-initramfs
Back to top
View user's profile Send private message
maxim.251
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jul 2012
Posts: 86

PostPosted: Mon Jul 30, 2012 6:39 am    Post subject: Reply with quote

Aha, to przepraszam, myślałem że ten fragment akurat jest ważny.... Tam on stawał na samym początku instalacji WICD. Od momentu kiedy wpisałem emerge wicd i od razu mi wywalał ten komunikat.

Ale teraz jak instaluje gentoo na drógim laptopie to wydaje mi się że musiałem dodać coś związanego z konfiguracją konta użytkownika. Ale pewności nie mam.
Na drógim lapku też dodałem masę flag wyłączających wszytskie dodatki dla Wicd i zostawiłem jedynie ncurse który według zapisków jest ważny. Instalacja się powiodła bez problemów. Wifi też ładnie zrestartował. Może to też była przyczyna wcześniejszych błędów jakie miałem za pierwszym razem... Że nie powyłączałem wszystkiego we flagach lub nie skonfigurowałem do końca podstawowych plików związanych z kontem użytkownika.
Wiem że coś było właśnie z tą konfiguracją.
Back to top
View user's profile Send private message
maxim.251
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jul 2012
Posts: 86

PostPosted: Tue Jul 31, 2012 6:26 pm    Post subject: Reply with quote

To chyba ostatnia odpowiedź w tym poście. Podczas instalowania systemu na drógim laptopie napotkałem na identyczny problem z WICD, nie mogłem go zainstalować bo wyskakiwały mi błędy.
W logu za wiele się nie dowiedziałem. Ale coś tam było interesującego. W logu było napisane że nie może skopiować tłumaczenia i te miejsce nie istnieje...
A ja specialnie dodałem tą flagę by mieć tłumaczenie tego programu. Okazało się że właśnie ta flaga uniemożliwiała mi instalację wicid.
nls tak się nazywa ta flaga.

Na zakończenie chcę dodać że jeśli ktoś chce próbować instalację przez wifi, jeśli nie ma możliwości przez kabel, to powinien sobie zainstalować ten program. Szczegulnie jeśli ktoś uzywa routera z kodowaniem WPA2. Jak już wcześniej napisałem wystarczy wtedy skopiować plik z LiveDvd z którego stawiamy system do nowego miejsca.
Jeśli ktoś będzie miał pytania jak to zrobić to można pisać, ja już wiem jak to zrobić więc mogę chętnie pomóc.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum